Armbian support


just started out with the RockPi4, and as it seems the perfect board for our experimental setup in deep sea, I would like to see it supported in Armbian (as the Odroid C2 is, which we use up to now).
I need a professional board with genuine second GbE port, and the RockPi4 fits perfectly (professional board layout, good eMMC system, RAM,…)
I already started a thread in Armbian forum, and tried some images for other RK3399 boards, but failed so far.

How can we get RockPi4 into Armbian? It is the only cross compiling system for ARM which could really work our of the box for me, and allows me to customize images to my needs.

So far, the Uboot 2018 fails booting the board (nanoPC T4 images).

Any help (especially from Radxa) is highly appreciated.

So far Michael


Do you know the status of Armbian support on general RK3399 based boards? ie, what RK3399 boards are supported on Armbian currently and how complete the functions are?

Hi JackMa,

currently supported are (legacy 4.4y kernel):

  • Nanopi M4 (suitable for testing, WiP)
  • Nanopc T4 (suitable for testing, WiP)
  • Nanopi Neo4 (suitable for testing, WiP)

I tried compiling an image for T4, and booting it from eMMC on RockPI4, but fails on UBoot (stock Uboot is 2017, Armbian one is 2017).

Any help is appreciated.


Nano Pi T4 is LPDDR3, ROCK Pi is LPDDR4, the dram controller is different. I am not sure how Armbian boots because there are multiple boot options. We will check it.

Feel free to ask me testing new images :slight_smile:


Armbian preview image now can be downloaded from:


:slight_smile: you guys are awesome. Thanks for putting in the time and effort

Great. Will check ASAP. Is it already included in Armbian build system?

Hi, I have bought a rockpi4 a week ago. Has both asus tinker board and 2 raspbarry b+. I have to say that I’m glad that Armbian is getting ready for my rockpi4.

not yet, we are cleaning the patches and will send PR.

Was trying the kernel modules packages in Armbian, I get the following error.

root@rockpi4b:/root/# apt-get install rockchip-overlay rockchip-fstab
Reading package lists... Done
Building dependency tree
Reading state information... Done
rockchip-fstab is already the newest version (0.1).
rockchip-overlay is already the newest version (0.9).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Setting up rockchip-fstab (0.1) ...
sed: -e expression #1, char 0: no previous regular expression
mount all partitions
mount: mount point vfat does not exist
mount: mount point vfat does not exist
mount: mount point vfat does not exist
mount: mount point vfat does not exist
mount: mount point vfat does not exist
dpkg: error processing package rockchip-fstab (--configure):
 subprocess installed post-installation script returned error exit status 32
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

You can’t install these packages in Armbian. Armbian has its package repositories and maintains its own packages. The main reason is Armbian uses a whole partitions as the rootfs but for Debian/Ubuntu Released by us and Rockchip officially, we uses 5 partitions, p4 for boot and p5 for rootfs. If you want to install modules, you should install it from the Armbian repository.


I just received my rockpi 4A, Does anyone know if Armbian includes GPU hardware acceleration? I need to develop on OpenGLES 3.1.



I’d very much like to know this too, as GLES 3.1 and 3.2 would be a major reason for me buying this board, I can’t commit to it until I know it has all drivers available.

Will you release a minimal Armbian image? No desktop or other optional software installed. Just a nice clean base for a headless server?

I just got my Rock Pi4A that I will be using as a docker server. And I noticed all the desktop stuff installed in the armbian image.

As well as a bluetooth process running. :frowning:

There’s a WIP testing version up on armbian now.


Oh, wow, totally missed it

Hi, I installed the armbian image from radxa to my sd card with etcher and it works fine. If I flash the image from to my sd card rock pi is always booting from my emmc card (there is an ubuntu image installed). Any idea?

I had the same problem three weeks ago. I then removed the eMMC, but I asked in the Armbian forum if this is normal. I didn’t remove the heat sink and think I could fiddle with the eMMC later.

The RockPi does not boot Armbian Stretch from the inserted SD card if an eMMC is installed at the same time. As soon as I remove the eMMC it works. An image of radxa boots even if eMMC is installed. This behavior irritates me a bit, is that normal?

probably not… But you have at least to provide a bootlog from serial console to get a clue where it messes… RockPi is in early stage of board bring up (wip). Bugs must be expected…