All-Images-Depot Rock 5B

To make a spot for everyone to share their own image and track them I decided to open this post in order to make easier to find and track member’s images again I don’t work for Radxa I own a Rock 5B like yourselves and I want to see it thrive.
All this and more here:

Credits to:

@monka — 07/07/2022 15:41

user:radxa ,password:radxa

08/07/2022 14:47
yes mpv is patched
lib mali deb's are in this folder

08/07/2022 14:57
user: radxa ,password:armbian

08/07/2022 17:06


09/07/2022 21:48
That looks better with vpu 😉



12/07/2022 08:56

12/07/2022 09:50

12/07/2022 15:02

22/07/2022 12:11






@monka  — 31/08/2022 16:21

Credits to:

@coder1337 — 30/10/2022 20:36

for any kde fans here, this is what i did (not strictly in this order for my first attempts, but you get the idea):
- downloaded ►
- flashed to microsd
- set up using armbian wizard (starts automatically)
- followed this: ►
- installed kde and xorg (packages xorg and kde-plasma-desktop, kwin-x11)
- rebooted, signed in to user account
- executed startx to start the desktop (can be automated with an xinit file i believe, and it would also nice to have sddm but didn't attempt it yet)

at first i had no window title bars, which was fixed by installing kwin-x11. now it's actually quite a fast user experience, although we have the known graphical glitches with the current driver.
it would be interesting if we could swap the armbian kernel with the radxa one to get nvme boot. but while i can install my systems from command line, i'm not a linux expert. so take all of this with a grain of salt. 

Credits to: 

@monka 01/11/2022 04:01

Manjaro ARM Gnome Legacy Rock5b test
user: rock , password: rock

02/11/2022 00:44
RetroPie Rock5b WIP
user: pi , password: armbian

Credits to: 


Arch linux for the rock 5b:
sha256: 7f9fef591d81ee5e24b0b081cd50336c2e37f77b8657011c025925efb784a074
It’s based on today’s radxa image and the latest arch linux arm release. Consider it to be experimental.

Credits to: 

@thc013 Rock 5B Android 12.1 RKR10 Google TV

Follow up > [ROM] ROCK 5B Android 12.1 rkr10 GoogleTV

Android OS and Google TV (from adt3 source)
rooted multiple markets for apps HDR, 4K etc etc…

**Based on PixelPropsUtils, GamesProps will spoof the device needed to unlock the FPS of the following games:**
  *Free Fire - Spoof Asus ROG Phone 1 will unlock 90 FPS
  *COD Mobile - Spoof Xperia 5 || will unlock 120 FPS (only on multiplayer mode)
  *PUBG Mobile - Spoof OnePlus 8 Pro will unlock 90 FPS
  *Wild Rift - Spoof OnePlus 8 Pro will unlock 120 FPS
  *Cyber Hunter - Spoof OnePlus 8 Pro will unlock 90 FPS
  *Fortnite - Spoof OnePlus 8 Pro will unlock 90 FPS

Credits to: 

Alpine Linux SD image -

Credits to: 


Fedora 36 Rockpi 4B
Wifi works, USB works, SATA works, kernel update works, performance is good, the rest I didn’t check. For my use case (headless backup server) it’s just perfect.
Link: Fedora 36 Rockpi 4b

Credits to: 

@rpardini Armbian Master:

“we did some code shuffling and some additional testings could help to see if there are some obvious troubles”

Credits to: 

@Pandaa and @dangeruss26 Updated 22/01/2023
Reborn OS for Rock 5B

Budgie desktop is working on that build. XFCE, and MATE


The New Rock Pi 5 Is So Fast It Could Replace a Desktop PC! Reborn …

Pandaa 24/01/2023 19:37

RebornOS ARM new device support (beta)

We are proud to announce that RebornOS now supports a variety of new ARM devices! Our ARM team has also grown with the addition of new members, which means that we are now able to offer even more support for our users and continue to improve the experience for those on ARM devices. New devices: RPI 4 Rock5B (beta) Orange Pi 5 (beta) Generic Q…


OpenFyde OS for Rock5B

It needs RKDevTool + Driver to install the firmware into the emmc connected to the board in Maskrom.

Known Issues so far:

  • Bluetooth support is coming on the next patch for the A8 Module
  • No google apps support yet.

For the fan to work ctrl alt T type Shell then sudo su -

echo 0 > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/export 
echo 10000 > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/pwm0/period 
echo 5000 > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/pwm0/duty_cycle 
echo normal > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/pwm0/polarity 
echo 1 > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/pwm0/enable 
#echo 0 > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/pwm0/enable

Arch Linux for Rock 5B > Archlinux on Rock5b

Credits to: 

user: rock , password : armbian

Jammy Legacy AfterburnerMOD + Waydroid on Panfork
This is the image with box86/64 + wine

More info: Rock 5B - My experience Armbian Afterburner image

Focal Legacy AfterburnerMod on Mali Blobs (The best one IMO)

DietPi for ROCK 5B - available for ROCK 5B

Credits to: 


Batocera Linux: The true emulation image - 15/01/2023

Batocera Linux v36 - Batocera.linux is an open-source and completely free retro-gaming distribution that can be copied to a USB stick or an SD card with the aim of turning any computer/nano computer into a gaming console during a game or permanently. - 25/01/2023 15:17

Manjaro Image (still recent id say its “beta”).
Source: (Trying to get) Manjaro on Rock5B

Rock 5 Slarm64 Rock 5 Slarm64 (aarch64 unofficial slackware)

Jelos for Rock 5B

Can’t promise to keep this always updated so please do always give a look at discord and search the forum.


Some troubleshooting I have found usefull to help new members (like myself who came from Windows and ChromeOS).

For the fan heatsink to work:

git clone
cd fan-control-rock5b
make package
sudo dpkg -i fan-control*.deb
sudo systemctl enable fan-control
systemctl start fan-control 

Or Non-GPIO 4012 Fan Fix (Archlinux) (not for armbian).

git clone
cd Rock5B_Naive_Pwm_Fan/
cp fan_pwm /usr/local/bin/. 
chmod +x /usr/local/bin/fan_pwm
cp fan_pwm.service /etc/systemd/system/.
systemctl daemon-reload 
systemctl start fan_pwm
systemctl enable fan_pwm

A8 Module Bluetooth:
sudo su
nano /etc/modprobe.d/blacklist.conf
then add these lines somewhere (at the bottom of the file is fine):

blacklist btusb
blacklist btrtl
blacklist btbcm
#blacklist btintel

Then press Ctrl+X, then Y.
sudo apt install bluez or bluetooth – not needed to install since latest armbian version
systemctl status bluetooth CTRL+ C
systemctl start bluetooth
Then reboot .

For AX210 Wifi/BT to Work - Not sure if we can activate this without internet at all.

cd /usr/lib/firmware/
sudo remove iwlwifi-ty-a0-gf-a0.pnvm

Audio Tutorial for Bluetooth devices: – (not required since armbian latest versions)

sudo add-apt-repository ppa:pipewire-debian/pipewire-upstream
sudo apt install pipewire pipewire-audio-client-libraries
sudo apt install gstreamer1.0-pipewire libpipewire-0.3-{0,dev,modules} libspa-0.2-{bluetooth,dev,jack,modules} pipewire{,-{audio-client-libraries,pulse,media-session,bin,locales,tests}} 

systemctl --user daemon-reload
systemctl --user --now disable pulseaudio.service pulseaudio.socket
systemctl --user --now enable pipewire pipewire-pulse
pactl info

(Short guide) SPI flashing on the board itself would be:

gzip -d zero.img.gz
sudo dd if=zero.img of=/dev/mtdblock0

Wait ~5 minutes for the command to complete, check that sudo md5sum /dev/mtdblock0 returns 2c7ab85a893283e98c931e9511add182. Then:

sudo dd if=rock-5b-spi-image-g49da44e116d.img of=/dev/mtdblock0

Wait ~5 minutes for the command to complete, check that this time sudo md5sum /dev/mtdblock0 returns 46de85de37b8e670883e6f6a8bb95776. Then:


For more info:

More info (Spi to NVME boot from SD Card):

Issues with Google Apps Device Isn’t Play Protect Certified? (On Android OS)
Install an android id apk and register the id on this website
Wait 5 minutes,reboot and google playstore will work.

Use this apk ,install it and open it then use the number in the top left corner to register


sudo apt install fonts-emojione -- Emojis to work
sudo apt install btop -- Control temperatures etc.

Rock 5B Graphics Panfrost/fork on Wayland

sudo add-apt-repository ppa:liujianfeng1994/panfork-mesa
sudo add-apt-repository ppa:liujianfeng1994/rockchip-multimedia
sudo apt update
sudo apt dist-upgrade
sudo apt install glmark2 glmark2-es2 glmark2-es2-wayland
sudo apt install mesa-utils
sudo apt install mali-g610-firmware
sudo apt install malirun
reboot (better shutdown and start again manually for safety)
glxinfo|grep OpenGL -- check actual status of things
--sudo apt install libegl-mesa0 libegl1-mesa-dev libgbm-dev libgl1-mesa-dev libgles2-mesa-dev libglx-mesa0 mesa-common-dev mesa-vulkan-drivers

Try some benchmarks - Ubuntu Wayland

PAN_MESA_DEBUG=gofaster glmark2 
Expected results: 1st Line - 1669fps - Score: 1249fps - you are good.

PAN_MESA_DEBUG=gofaster glmark2-es2-wayland 
Expected results: 1st Line - 3527fps - Score: 4067fps - you are sorted.

LD_LIBRARY_PATH=/usr/lib/aarch64-linux-gnu/mali glmark2-es2-wayland 
Expected results: 1st Line - 4229fps - Score: 3933fps - what a legend.

For Mali to Work on Armbian on X11
Do GPU acceleration works in X11 with malirun !

malirun chromium-browser

Switching Between Mali Blobs and Panfrost - for experts to run X11 like a Pro

Max out the 5B performance (Optional) - That’s if you want some real performance at the cost of being hot and power-hungry.

echo performance | sudo tee /sys/bus/cpu/devices/cpu[046]/cpufreq/scaling_governor /sys/class/devfreq/dmc/governor /sys/class/devfreq/fb000000.gpu/governor

Once you’re done with your benchmarks, you may want to go back:

echo ondemand | sudo tee /sys/bus/cpu/devices/cpu[046]/cpufreq/scaling_governor
echo dmc_ondemand | sudo tee /sys/class/devfreq/dmc/governor
echo simple_ondemand | sudo tee /sys/class/devfreq/fb000000.gpu/governor

Allows you to Run Windows 7 on Rock 5B Virtualized

The soup is served :smiley: and credits are not mine this soup was given by the most talented members of this community.


Anyone want to buy a 16gb Rock5 ? I got a second thinking it was going to be fun.

I have a build script that builds an Arch-Linux image for rk3588 now too:

Build script for building an SD card for Rockchip devices running ArchLinux (RK3288/RK3588 for now) (

It can also help building an image on nvme and writing u-boot to spi.

Read the

1 Like

I’ve had a metric shit ton of bad luck so far with this board. I’ve tried android, Armbian, and quite a few other linux distros with little to no luck. I’m not a linux person as I’ve used windows exclusively so command line stuff really isn’t my forte. I guess I’ll just have to wait until Libreelec releases a version for this board as all I want to do is use it for a media player and nothing else.


My troubleshooting for that is:
Power Unit? - I use samsung 45W and hear that Pi PSU works fine too. (5.1V 3A)
Grab one to try maybe? if not Pi PSU I suggest a thunderbolt type c cable for the power to be fine.

Also Flashing the SPI seems to do magic but I cant confirm when yous do it for the nvme do a clean spi flash for the emmc follow radxa tutorial.
Or follow mine here: openFyde (Chromium OS fork) for ROCK 5B
It’s a bit dense and made for the OpenFyde Overlay… which I was able to flash but not to maintain (openfyde would just reboot on me… and I didnt knew why so I did a clean to zero spi flash and works like magic now).

Where to find more info about this? I don’t find this link anywhere else

You dont. The owner only uses Radxa Discord. My suggestion join Radxa Discord and speak to @monkablyat at #rock5-series-images

" After getting a lot of feedback on my popular Ubuntu 22.04 LTS port for the Orange Pi 5, I now have support for the Rock 5B! Additional support for the Rock 5A will be available soon, I’m waiting on hardware to be delivered.

• Kernel, firmware, and bootloader updates through apt
• Desktop first-run wizard for user setup and configuration
• 3D video hardware acceleration support via panfork
• Smooth 4k video playback with MPV, Gstreamer, and Chromium YouTube
• Familiar Ubuntu Desktop and Server image experience

**Known Issues: **
• Cursor flickering only during the first-run wizard, see GitHub issues for more details

Download: " by @Spooky


Bro, this is awesome. I have the feeling that because the amount of different boards Radxa has, the focus on Rock 5B has become less of a priority as they have given the users just the basics to start with.

I have also two boards both 16 GB and i really wanted to have Ubuntu 22.04 server jammy running on them, but no real good images to be found out there. As you have a Rock 5B yourself i have more hope like you said you want it to thrive.

I was reading anoher topic and there it was said that basic ethernet support in u-boot is now supported. Is this a possibility that we can maybe get it to work? I am not sure if it is done through firmware updates or so?

The reason i am asking this, is that both of my boards i still have not put them in the metal case because if i want to put a different OS on it, i have to disassemble the whole board to get to the M.2 Nvme SSD so i get put the new image on.

1 Like

I havent tried anything related to that at all u-boot uefi or even Windows on Arm. I havent had the need to find about it and thats the reason so all I can say is keep an eye on radxa discord most folks who do know are there and most likely Mario from the Windows On R knows that better than me.

The issue imo with the 5B is the boot hangings that will be ‘somewhat’ fixed on the next versions radxa will be making apparently Radxa Yuntian found a way to reduce them and hopefully that will be the overall fix for those issues I want also to suggest you to keep an eye on the Rock 5A in particular to this one I find it perfect. No boot issues at all perfect for everything and literally a step ahead into the future with the micro hdmi and all options on deck.

With this said… yes there a whole world of options its just a matter of trying and finding the best way and imo sticking with it.