Rock 5B - My experience Armbian Afterburner image

So here it goes - @monka MonkaBlyat best version of Armbian with all goodies ready and Installed:"

This is my desktop experience for cloud gaming and I love the webapps because they run better and are always updated.

I am using MonkaBlyat’s Afterburner Armbian Image which is modded to work well with Mali GPU and takes the best advantages on most ROCK 5B resources:

Latest armbian jammy with minimal gnome desktop and amazingfate’s multimedia + panfork branch, not much pre-installed just box86/64 with wine 8.2 and steam client.

user: rock , password : armbian

For the fan heatsink to work: (Armbian)

git clone
cd fan-control-rock5b
make package
sudo dpkg -i fan-control*.deb
sudo systemctl enable fan-control
systemctl start fan-control

A8 Module Bluetooth:
sudo su
nano /etc/modprobe.d/blacklist.conf
then add these lines somewhere (at the bottom of the file is fine):

blacklist pgdrv
blacklist btusb
blacklist btrtl
blacklist btbcm
blacklist btintel

Then press Ctrl+X, then Y.
sudo apt install bluez or bluetooth – not needed to install since latest armbian version
systemctl status bluetooth CTRL+ C
systemctl start bluetooth
Then reboot .

For AX210 Wifi/BT to Work - Not sure if we can activate this without internet at all.

sudo apt install flex bison
git clone
cd backport-iwlwifi
cd iwlwifi-stack-dev

sudo make defconfig-iwlwifi-public
sudo make
sudo make install

git clone git://
cd linux-firmware/
sudo cp iwlwifi-* /lib/firmware/


Max out the 5B performance (Optional) - That’s if you want some real performance at the cost of being hot and power-hungry.

echo performance | sudo tee /sys/bus/cpu/devices/cpu[046]/cpufreq/scaling_governor /sys/class/devfreq/dmc/governor /sys/class/devfreq/fb000000.gpu/governor

Once you’re done with your benchmarks, you may want to go back:

echo ondemand | sudo tee /sys/bus/cpu/devices/cpu[046]/cpufreq/scaling_governor
echo dmc_ondemand | sudo tee /sys/class/devfreq/dmc/governor
echo simple_ondemand | sudo tee /sys/class/devfreq/fb000000.gpu/governor

Or if you want a shortcut for performance / ondemand and powersave do nano .bash_aliases and add these instructions - save it Ctrl X, Yes, restart and after just type the governor you desire Terminal: performance to trigger it.

alias performance="echo performance | sudo tee /sys/bus/cpu/devices/cpu[046]/cpufreq/scaling_governor /sys/class/devfreq/dmc/governor /sys/class/devfreq/fb000000.gpu/governor"
alias ondemand="echo ondemand | sudo tee /sys/bus/cpu/devices/cpu[046]/cpufreq/scaling_governor && echo dmc_ondemand | sudo tee /sys/class/devfreq/dmc/governor && echo simple_ondemand | sudo tee /sys/class/devfreq/fb000000.gpu/governor"
alias powersave="echo powersave | sudo tee /sys/bus/cpu/devices/cpu[046]/cpufreq/scaling_governor /sys/class/devfreq/dmc/governor /sys/class/devfreq/fb000000.gpu/governor"

Try some benchmarks - Ubuntu Wayland

PAN_MESA_DEBUG=gofaster glmark2 
Expected results: 1st Line - 1669fps - Score: 1249fps - you are good.

PAN_MESA_DEBUG=gofaster glmark2-es2-wayland 
Expected results: 1st Line - 3527fps - Score: 4067fps - you are sorted.

LD_LIBRARY_PATH=/usr/lib/aarch64-linux-gnu/mali glmark2-es2-wayland 
Expected results: 1st Line - 4229fps - Score: 3933fps - what a legend.

This was my experience I wanted to share it with yous… maybe more people here knows other tricks to make things blasting perfect… Im not an linux expert… compiling kernels makes me confuse theres yet too much to read and learn but I’m enjoying this experience so far and why not? This community is great theres also a lot of users paying attention on Radxa Discord and things are going to get better so I feel.

Also very important… guys: Samsung 45W Super Fast Charger (and is probably PD) connected with Emmc, Micro SD, A8 module, 1TB Nvme, K7 keyChron Keyboard and a shitty chimichanga mouse with a scorpian logo via usb dongle all works ah and also an JBL Flip 5 perfectly fine between images and so long… If theres an usb type C power brick that I can say YES… this is the one use it.

SP1 to boot Rock5b running Armbian from NVMe SSD
Thanks @student

This post is made possible thanks to a few members who helped me a lot on Discord so I want to thank them and off course many others did help too (but I can’t and probably shouldn’t fetch for their names too).
Radxa Discord
@GinKage @monka @bread @igorp @rippanda12


Is this image stable or not? I heard only 5V/3A USB-C adapter is stable and the PD on Armbian still is still borken/not working… I have 65w USB-C adapter but seems PD handshake but not stable when in use.
I tried Armbian, however for some unknown reason my rock5b reboot or freezes sometimes.

It hasnt to do with the image… but the rockchip itself.
Like I mentioned in my post I use the Samsung 45w and it handles all cards on deck perfectly fine.
I had also suggested for whoever has power issues to re-flash the SPI with the provided files also to clear it from any constraints… do an clean spi flash and then check if it still happens.

what’s the spi flash file? Could you kindly share the link you mentioned? Also if possible could you please also indicate the model/part number of your Samsung usbc adapter? I tried 4 or 5 usbc adapter but all have reboot or freeze issue. Thanks mate in advance :stuck_out_tongue:

Hm… OK, so the complete (but short) guide for SPI flashing on the board itself would be:

gzip -d zero.img.gz
sudo dd if=zero.img of=/dev/mtdblock0

Wait ~5 minutes for the command to complete, check that sudo md5sum /dev/mtdblock0 returns 2c7ab85a893283e98c931e9511add182. Then:

sudo dd if=rock-5b-spi-image-g49da44e116d.img of=/dev/mtdblock0

Wait ~5 minutes for the command to complete, check that this time sudo md5sum /dev/mtdblock0 returns 46de85de37b8e670883e6f6a8bb95776. Then:


For more info:

Samsung 45W - super fast charger its on samsung page just google it or check on samsung page.
Edit: And yes I tried a bunch none of them can handle the Rock 5B the rpi4b power brick from pi hunt doesnt even makes it boot if I plug my k7 keyboard without it plugged it boots. In short you need the strongest and filtered type of PD QC energy flowing and since the Samsung 45W is made to power the galaxy chromebook its more reliable at least for me… its on the 5 star level.

Also keep in mind you can’t just use any type of usb c cable… you need a powered type c cable like the ones of 100W type C cables they are fat compared to the shitty ones. If your charger is too over-powered for your cable you can end up with a burnt board.
( I have seen this happened before ).

Really appreciate mate. I’m going to grab that Samsung 45W charger and make that SPI flashing. Thanks again!

1 Like

Add the 4k type C cable… otherwise… u can end up with this

emm… interesting DIY job… I got a lot of USB-C cables including some thunderbolt usb-c cables. Should be the problem caused by adapter.

1 Like

zero.img.gz can bring help: formerly I flash the specific SPI img for Armbian NVME bootup, then usb-c power supplying became not stable. After switching back to zero.img.gz, 5V/3A adapter now can support one NVME and one SD card’s power consumption. But I will still buy that Samsung 45W charger. Thanks again, and any further experience sharing is highly welcomed!

1 Like

Just passing along. My notes on how I updated SP1 to boot Rock5b running Armbian from NVMe SSD.


thanks for sharing ,will try your article method.

1 Like

What is the login password?

user: rock , password : armbian

I have installed and started it, but sometimes Google Play store can be opened and sometimes it can not be opened.
There is no video when playing YouTube, and the screen is black. What is the reason? My network is normal.

Google play store is part of waydroid. @monka made it work but if you do sudo updates it wont anymore.
The reason relies on Waydroid not being available to Rockchip GPU drivers or something. He can explain that better… in other words… forget waydroid for now…
Youtube works fine for me I dont have any black screen.

how about the gpu performance? I ran the glmark2 which results the mark of1200. Is that normal?

Those are rookie numbers, let’s pump them up.
So, let’s say you’ve set CPU+GPU+DMC to performance, we’re running a Wayland session in 4K, with gofaster patches, and we get:

Hm, so I’m exactly where you are now. Can we do any better? What if we used a Wayland-native benchmark, and OpenGLESv2 rather than OpenGL?

Much better… Is there any more room for improvement? Well, let’s try the blob driver.

Oh no, the scores are lower now… Or are they? All eyes on the Terrain test: it’s actually twice as fast now! And that’s the only number that actually reflects e.g. GameCube emulation performance, and the only one I really care about.

That’s the issue with benchmarks: in my experience, if I want my Dolphin emulator to run smoothly, I’ll choose the blob driver. If all I care about is the desktop environment, Panfork works quite well. The benchmark scores are mostly irrelevant, really.

1 Like

Extras added to the main post:

Max out the 5B performance (Optional) - That’s if you want some real performance at the cost of being hot and power-hungry.

echo performance | sudo tee /sys/bus/cpu/devices/cpu[046]/cpufreq/scaling_governor /sys/class/devfreq/dmc/governor /sys/class/devfreq/fb000000.gpu/governor

Once you’re done with your benchmarks, you may want to go back:

echo ondemand | sudo tee /sys/bus/cpu/devices/cpu[046]/cpufreq/scaling_governor
echo dmc_ondemand | sudo tee /sys/class/devfreq/dmc/governor
echo simple_ondemand | sudo tee /sys/class/devfreq/fb000000.gpu/governor
1 Like

@DarkevilPT changing the CPU and GPU governor to performance is not overclocking at all, just running at the max allowed frequency all the time.

1 Like