openFyde (Chromium OS fork) for ROCK 5B

I think U might be able to make it work if u are using the A8 check radxa wiki theres a few lines u have to blacklist and after reboot it works.

1 Like

They are paying attention here.
I have those issues which keeps the system rebooting… otherwise It would be my main OS.

Hi, I tried this and could successfuly install the openfyde-os into emmc. Thanks.
I like this because chronium browser is just chrome that can synclonize completely with my google account.
Then I’d like to study the openfyde more and to know how to enable developer mode.
Do you know the way?

Yoshis which version of Radxa board do you have? Im going crazy I cant literally use OpenFyde it keeps freezing and rebooting very often… Does the same happens on yours?

Mine is stable but android does not work for it, tried everything.

Update > Finally Sort out this ISSUE! FINALLY!!
Auff what a relief!

RKDEVTOOLS you guys really need to make it more clearer on how to flash this.

My issue was that, because on my first attempt it failed to do the Download Image (tab) I was just doing Upgrade Firmware (Tab) and for some reason it never worked decent.

So here it goes and I hope this help the community because I love this!

At least for some clarity on Windows:
RK Dev Tools:
The files for RK Dev Tools are here:
(You need the loader.bin and the Release.img)

I suggest everyone to do an SPI update with those files up aiming for the release.img
Theres a SPI config file in RKDevTools paste to Swap between EMMC and SPI.
SPI requires a SPI BIN file and the IMG file. (both on the links above each for what type of usage you desire in my case EMMC). Release is for a default standard (Do Flash your SPI for a boot in EMMC then Micro SD if nothing then NVME).

Before yous say (this has nothing to do with flashing openfyde) well yes but for someone who does a lot of image swapping and to give a fresh install you better reset the boot spi flashing it via emmc right on RKDEVTOOLS or skip this part where the next one was the deal breaker for me.

RkDevTools has first a Download Image tab (because for me the first time I have used it / it failed to enter the maskmode I thought the mask mode button on Rock5B was the second button… it detects something but its not the maskmode.
The maskmode button is beside the CPU on a top left corner in line with the type C connector.
Meaning that everytime RkDevTools fails u better close it and open (again the windows app) and enter into mask mode again by unplugging and plugging the typeC cable.

Here we go:
Download Image you will need RK Dev Tool.BIN file (found here
Second file to add is the image.IMG file which will be the OpenFyde OS image from github (Tutorial how to do RkDevTool also here

Check option Write by address then Press run. After done unplug type C.

We are not done yet.

Next - Second tab the Upgrade Firmware.
Get into maskmode - Load firmware.img from openfyde github wait - Then Flash.
After its done unplug type C et voilá!! OpenFyde works nay!

For the fan to work ctrl alt T type Shell then sudo su -u
echo 0 > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/export
echo 10000 > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/pwm0/period
echo 5000 > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/pwm0/duty_cycle
echo normal > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/pwm0/polarity
echo 1 > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/pwm0/enable
#echo 0 > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/pwm0/enable

Runs really slow… it should run a bit stronger for heavier duty to cooldown.

Now known Issues:
Bluetooth support is coming on the next patch.
-No google apps support yet.

Thanks Damenly.

1 Like

Open questions.

  1. Do we know if OpenFyde will support android apps in the future?
  2. Will this version (r102-r1) boot from NVME?

Details: I was able to configure 5B to boot OpenFyde from EMMC (32GB) and an loving it. Was able to install the Linux but have not done anything with it besides turn it on.

My knowledge of SBC is zero, I literally just started hands on with this hobby 1/26 so I have a lot to learn on how all of this works.

Thank you all for is thread and DarkevilPT detailed but to me cryptic post. This forum and to a lesser extent the WIKI have been extremely helpful.

1 - From my understanding… (which is not extensive as I am new to sbc) is that… untill the gpu cant run waydroid with mali blobs the same way it can chrome browser for videos with hw acceleration and etc… OpenFyde will probably never put Android apps to us…
Also for that… probably the RK3588 needed to become a mainline on the service.

2 - I havent tried it but yes I think u can after installing and even on instalation I think you can.

I havent tried the linux console yet to try to install .apks files yet… like we can do on Chromebooks… I wonder if we can cause that would be F. awesome.

I made that tutorial cause … I was going mental with it stucking and rebooting on my side all the time and it was just an issue with the booting spi file I had previously flashed wrong… now it works like magic…

Im not gonna lie I like openfyde but not having google apps working puts me down.
Can you confirm if we can install apks in it?

I’ve not had success getting it on NVME. I’ll try to see if I have time this weekend to tinker some more. Anyways in regards to openfyde supporting android subsystem I got an update in regards to fydetab duo hardware today and they mentioned it. So I hope I’m not mudding the waters here but if you look at the wiki for the duo, it mentioned, ArchHeroNg ( Android subsystem 11) as did their update message. I looked at the hash for that version of that openfyde and sadly it does not match this version. :frowning: The good news is that both these chips are similar so maybe hope for the future or someone more technical.

They are working on it:

Nobody ever told me a straight No for no gApps so far on OpenFyde so all we can do is hope and wait…

Idk how to put it into the nvme yet but have u checked the openfyde app store ? They have an partition app that gives you some options and I think you can select which storage to keep the OS.

I second this. Using a Rock is different from a Pi. I’m thankful for the guide. Especially for any Windows user

1 Like

UPDATE I got mine to boot from NVME. What i had to do was install the to EMMC and then DD to NVME. I then removed the EMMC module. It’s still not perfect because I still need debian on my SD to boot NVME but for now it works.

1 Like

Happy days ! Congrats

Has anyone tried this on OpenFyde Rock5B?

insert-coin let-me-play-you-foobar!

Edit: Only x86…

Upgrade OpenFyde from r102 to r108.
Support booting from TF card and installation to NVME/EMMC.
Add Android 11 implemented by project ARCHERO(Alpha test status).
Add Radxa A8 module support(WiFi and Bluetooth).
Add Radxa official fan control support.

New Update !!

To enable fan control:

Please follow the guide to enter the shell and be root.

mount -o remount,rw /
cp /usr/share/rock5b/rock5-fan-control.conf /etc/init/;

The daemon service will start fan as the strategy defined in /etc/fan-control.json. You can change it by doing steps 1 and 2 and then modify the file.

To enable A8 bluetooth:

Please follow the guide to enter the shell and be root.

mount -o remount,rw /
nano /etc/modprobe.d/blacklist.conf
-- then add these lines somewhere (at the bottom of the file is fine):
blacklist pgdrv
blacklist btusb
blacklist btrtl
blacklist btbcm
blacklist btintel
Then press Ctrl+X, then Y.

WoW we can have Android apps !!! :tropical_drink::beer::raised_hands:

For a much more updated version...
sudo apt update
sudo apt install chromium chromium-l10n


Thanks for all this. but where do i input this command?

Install the terminal its on the start up menu.
Set it up then sudo kudo play. :beer:

1 Like

Found the way to fix the Chinese Languages:

This is how it can be fixed.

Into app more options - Search for languages and then add your’s and put them first.

I finally DID IT!! Ahahah so basically all you guys need to login into Diablo Immortal, HearthStone and other games that requires browser login… its that exactly… a browser… and needs to be an Android browser… and all of them classic ones wont work… so try Via Browser.
Via Brower as main default browser. It WORKS!!! HELL YEAH!


Thanks for your contribution in helping in the forum!
Where can I find the firmware.img, cant find it in their github.

Regarding the latest post about installation to NVME.
Did you flash the SPI och loader using the files from Rock5/install/spi - Radxa Wiki
Then balenaetcher to flash the image to NVME? =)

For this release you dont need emmc anymore just a micro sd.

Grab openFyde image from their github flash your microsd with rpi imager or balena.
Place it in the board et voilá. Then inside the system you can just do full nvme installation.

Regarding spi flash if you want to clear it. Just follow yes radxa instructions but I use windows for that method basically rkdevtools via windows… as I dont complete master linux to do it straight via linux… therefore yes… read about that if you want.
Its just rkdev + driver on windows. Board into Maskroom (third button on the side) place load config spi then release img and default bin files provided at radxa spi wiki page and thats you sorted.

Join if you need help: