openFyde (Chromium OS fork) for ROCK 5B

Yeah its a reply to Whats the big advantage on between RK3855 and RK3588S? Rk3588s is purely cost and as said cut down boards with less connectors of expense look like the can be about $30ish cheaper than a RK3588

Wireless keyboard/trackpad hdmi into your TV and they make great web browsers / basic desktops where maybe extras of the rk3588 boards is just not needed.
Also Radxa do are going to do a CM5 compute unit based on the RK3588s which presume might also have industrial type carrier boards with can bus and others.

So guess its not all cost.

https://wiki.radxa.com/Rock5/CM

1 Like

Can we install diablo immortal on Openfyde? will it run perfect?

So, how can I install openFyde to my 5b? I downloaded https://github.com/openFyde/overlay-rock5b-openfyde/releases/tag/r96 but it does not work.

I wish I could help… but… idk either… my board is still on a promise to arrive… has anyone tried it yet ? any feedback ? Im super hyped to know more about this FydeOS

Its doesn’t seem to of got much love since it was posted but guess they are still figuring out drivers as there are differences to both linux and android

A " foundation " in openFyde is where we keep reusable and shared assets, they usually form a foundational layer to a family of hardware devices.

So they are doing something but likely not driver ready

@fydeos-alpha

1 Like

I had hope they made this the best Operative System to have on Rock5B tbh

1 Like

FydeOS inner project looks really neat !!

I hope we get it too for Rock 5B :smiley:

Not dissing their project, but it too bad its ‘yet another Chrome tablet’ ( in effect ), as there are tons of them out there. What i would love to see is a ChromeOS based phone. That id kick in some cash at kickstarter for.

Using a Rock 5B 8GB with a 32GB eMMC module, passive heatsink and the Radxa M8 M.2 WiFi/BT rtl8852be card.
I was able to flash OpenFyde 102_r1 from here using the upgrade_tool linked in the page.

Flashing procedure:
Connect via USB to a PC in mask mode, use the upgrade_tool to load the loader bin first, then flash the decompressed binary.
i.e.
Plug usb cable into PC
hold down mask button while connecting usb-c cable to rock5
On the PC (in linux terminal) use these commands:
upgrade_tool db /path/to/rk3399_loader_v1.20.119.bin
upgrade_tool uf /path/to/rock5b-openfyde_r102_r1.img

TL:DR Bluetooth does not work on the M.2 card. It gets a bit hot. So far it is seems very responsive while the temperature is not too high.

Issues so far:
Unable to use the BT function of the Radxa M.2 card (same problem also with Debian, Armbian as well).
Unable to set up PIN for login, reports “internal error”
Logging in with google account, sometimes repeats request (security issue?).
There is no pressure sensitivity registered with the Huion Pen, but it appears to work as a mouse, as well as drawing in e.g. Google Cursive.
Displays sometimes disconnect - unplug/plug HDMI brings it back on (I suspect this may be due to thermal issues with passive Heatsink)
Temperature on idle around 55 degrees C, went to 81 deg C when running the aquarium demo, and displays started disconnecting.
Netflix and Disney+ would not allow video to be played in the browser.

What I like so far:
Chrome browser works very well, Google web apps such as calculator, youtube, cursive etc can be added as PWA by clicking the icon in the address bar.
Boots up quickly - around 10s to login screen
Running 2x QHD plus Kamvas 13 pen display appears usable and responsive until temperatures rise.
Youtube 2k demo videos running smoothly at 30fps with no dropped frames.
OpenGL seems to be working - Aquarium OpenGL demo runs at 60FPS with 5000 fish and 1024x1024 canvas.
Wifi card working fine, but had to use a BT USB dongle
Linux environment installed and have run a few sample apps (krita, klondike, supertux)
Audio out working fine
Ethernet working fine

regarding flash we can use Rkdevtool 2.93:
Connect the device into maskrom mode
upgrade firmware —>firmware—>chose fydos image(wait for information to appear )—> Click Upgrade(wait for downloading finish 100%)

2 Likes

Works this way, no idea how to set up android inside it

I think U might be able to make it work if u are using the A8 check radxa wiki theres a few lines u have to blacklist and after reboot it works.

1 Like


They are paying attention here.
I have those issues which keeps the system rebooting… otherwise It would be my main OS.

Hi, I tried this and could successfuly install the openfyde-os into emmc. Thanks.
I like this because chronium browser is just chrome that can synclonize completely with my google account.
Then I’d like to study the openfyde more and to know how to enable developer mode.
Do you know the way?

Yoshis which version of Radxa board do you have? Im going crazy I cant literally use OpenFyde it keeps freezing and rebooting very often… Does the same happens on yours?

Mine is stable but android does not work for it, tried everything.

Update > Finally Sort out this ISSUE! FINALLY!!
Auff what a relief!

RKDEVTOOLS you guys really need to make it more clearer on how to flash this.

My issue was that, because on my first attempt it failed to do the Download Image (tab) I was just doing Upgrade Firmware (Tab) and for some reason it never worked decent.

So here it goes and I hope this help the community because I love this!

At least for some clarity on Windows:
RK Dev Tools: https://wiki.radxa.com/Rock5/install/rockchip-flash-tools
The files for RK Dev Tools are here: https://wiki.radxa.com/Rock5/install/spi
(You need the loader.bin and the Release.img)

I suggest everyone to do an SPI update with those files up aiming for the release.img
Theres a SPI config file in RKDevTools paste to Swap between EMMC and SPI.
SPI requires a SPI BIN file and the IMG file. (both on the links above each for what type of usage you desire in my case EMMC). Release is for a default standard (Do Flash your SPI for a boot in EMMC then Micro SD if nothing then NVME).

Before yous say (this has nothing to do with flashing openfyde) well yes but for someone who does a lot of image swapping and to give a fresh install you better reset the boot spi flashing it via emmc right on RKDEVTOOLS or skip this part where the next one was the deal breaker for me.

RkDevTools has first a Download Image tab (because for me the first time I have used it / it failed to enter the maskmode I thought the mask mode button on Rock5B was the second button… it detects something but its not the maskmode.
The maskmode button is beside the CPU on a top left corner in line with the type C connector.
Meaning that everytime RkDevTools fails u better close it and open (again the windows app) and enter into mask mode again by unplugging and plugging the typeC cable.

Here we go:
Download Image you will need RK Dev Tool.BIN file (found here https://wiki.radxa.com/Rock5/install/spi)
Second file to add is the image.IMG file which will be the OpenFyde OS image from github (Tutorial how to do RkDevTool also here https://wiki.radxa.com/Rock5/install/usb-install-emmc)

Check option Write by address then Press run. After done unplug type C.

We are not done yet.

Next - Second tab the Upgrade Firmware.
Get into maskmode - Load firmware.img from openfyde github wait - Then Flash.
After its done unplug type C et voilá!! OpenFyde works nay!

For the fan to work ctrl alt T type Shell then sudo su -u
echo 0 > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/export
echo 10000 > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/pwm0/period
echo 5000 > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/pwm0/duty_cycle
echo normal > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/pwm0/polarity
echo 1 > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/pwm0/enable
#echo 0 > /sys/devices/platform/fd8b0010.pwm/pwm/pwmchip*/pwm0/enable

Runs really slow… it should run a bit stronger for heavier duty to cooldown.

Now known Issues:
Bluetooth support is coming on the next patch.
-No google apps support yet.

Thanks Damenly.

1 Like

Open questions.

  1. Do we know if OpenFyde will support android apps in the future?
  2. Will this version (r102-r1) boot from NVME?

Details: I was able to configure 5B to boot OpenFyde from EMMC (32GB) and an loving it. Was able to install the Linux but have not done anything with it besides turn it on.

My knowledge of SBC is zero, I literally just started hands on with this hobby 1/26 so I have a lot to learn on how all of this works.

Thank you all for is thread and DarkevilPT detailed but to me cryptic post. This forum and to a lesser extent the WIKI have been extremely helpful.

1 - From my understanding… (which is not extensive as I am new to sbc) is that… untill the gpu cant run waydroid with mali blobs the same way it can chrome browser for videos with hw acceleration and etc… OpenFyde will probably never put Android apps to us…
Also for that… probably the RK3588 needed to become a mainline on the service.

2 - I havent tried it but yes I think u can after installing and even on instalation I think you can.

I havent tried the linux console yet to try to install .apks files yet… like we can do on Chromebooks… I wonder if we can cause that would be F. awesome.

I made that tutorial cause … I was going mental with it stucking and rebooting on my side all the time and it was just an issue with the booting spi file I had previously flashed wrong… now it works like magic…

Im not gonna lie I like openfyde but not having google apps working puts me down.
Can you confirm if we can install apks in it?

I’ve not had success getting it on NVME. I’ll try to see if I have time this weekend to tinker some more. Anyways in regards to openfyde supporting android subsystem I got an update in regards to fydetab duo hardware today and they mentioned it. So I hope I’m not mudding the waters here but if you look at the wiki for the duo, it mentioned, ArchHeroNg ( Android subsystem 11) as did their update message. I looked at the hash for that version of that openfyde and sadly it does not match this version. :frowning: The good news is that both these chips are similar so maybe hope for the future or someone more technical. https://wiki.fydetabduo.com/wiki/OS_Release/openFyde/r102-20221215