Never ending loop of dependencies, this is why I hate ubuntu…
rock@rock-5b:~$ sudo apt install build-essential libc6-dev g++
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
libc6-dev : Depends: libc6 (= 2.31-0ubuntu9.7) but 2.31-0ubuntu9.9 is to be installed
E: Unable to correct problems, you have held broken packages.
Seriously I have to downgrade to 2.31-0ubuntu9.7…