(Trying to get) Manjaro on Rock5B

With people working on getting Arch working thought I would attempt Manjaro. I am not really exactly sure what I am doing and I am sure a lot of this could be done using dd, but I am following close to what I saw users doing with Arch. I am doing this for fun, and was innebriated during all of this. This is NOT a best effort, but a likely bad idea spawned from boredom and curiosity. These are the steps I tried and what I got as a result.

Step 1
Burn Armbian Image.
It shouldn’t really matter which one from what I understand, but I used Jammy Minimal CLI

Step 2
Replace rootfs with one from Manjaro.
This is where I things deviated, where Arch has it in a neat tarball to extract after remaking the partition, Manjaro doesn’t ship that from what I could find. So I downloaded the generic arm image with gnome and used gnome disk utility to create a partition image of the root partition of the Manjaro boot media mounted as a loop-back.

I then used parted to resize the partition to be larger than the Image I retrieved earlier. I put it to 8GB for a little overhead. I used parted instead of continuing with the gnome utility because I was getting errors when I tried to resize with that.

I then returned to the gnome utility and started restoring the image to the root partition, taking note of the uuid before hand.

Step 3
Fix UUID or adjust fstab
I chose to use e2fsck and then tune2fs to set the UUID back to what was already set on the armbian image.

I popped it in my board, hooked up my UART, turned on my PSU and…

this is where things broke down and I gave up and decided to post my results here. In hopes someone else figures it out.

Uart Output
Dmesg Output

The only thing I am sure of that’s wrong is there is that things are being mounted as read only. I have never done anything like this before so I might be missing something obvious, or did something stupid that broke it. Either way, I am going to try to look more into this over the weekend.

1 Like

Here is the Manjaro rootfs image I ended up with as well. New users can only post 2 links per post.

You could try my archlinux install script. Replace the url in line:


with a manjaro mirror. Guess it should work, but have not tried it.

But should check if to following in the script:

if [ ! -f "/etc/arch-release" ]; then

Also works on manjaro for detecting archlinux or debian on the host that is running the script, if you want to run the script itself on manjaro.

I invite yous to share those details with us also on discord: https://discord.gg/828EKhgZTa

I think it would be better to use official image to start with instead of the armbian one.

The PKGBUILD we have in this forum if made for the official bootloader not the armbian bootloader and the kernel is not the armbian kernel. I know there is one armbian kernel package in the aur but the author of that one is not active in this forum so you are less likely to get help if you encounter any issue.