[ROM] ROCK 5B Android 12.1 rkr10 GoogleTV

Rock 5B Android 12.1 rkr10

Update 1-1-23 Begins with A

https://drive.google.com/file/d/1evwspu7UC9J5S4mjYQNZ_5htGQEkIaVg/view?usp=share_link

older:

Googletv

V5

https://drive.google.com/file/d/1orIwfD-lgh3JxPKLK3IDESzkwTMB1n5O/view?usp=share_link

Android with the 5.10 kernel Smile

Googletv (from adt3 source)

rooted

multiple markets for apps

HDR, 4K etc etc…

Based on PixelPropsUtils, GamesProps will spoof the device needed to unlock the FPS of the following games:

  • Free Fire - Spoof Asus ROG Phone 1 will unlock 90 FPS
  • COD Mobile - Spoof Xperia 5 || will unlock 120 FPS (only on multiplayer mode)
  • PUBG Mobile - Spoof OnePlus 8 Pro will unlock 90 FPS
  • Wild Rift - Spoof OnePlus 8 Pro will unlock 120 FPS
  • Cyber Hunter - Spoof OnePlus 8 Pro will unlock 90 FPS
  • Fortnite - Spoof OnePlus 8 Pro will unlock 90 FPS
6 Likes

Does it boot from nvme? If so, how to flash it.

wow, this is huge. good work on this.

though, i cant get this to boot with sd card, every android image didnt work for me :frowning:

i guess i need to get myself those emmc module then.

edited: just tried with my old class 4 sd card and its showing “androidtv” boot logo now

I have shared it to Radxa Discord Rock 5 Images Channel.

Does it have the app for the HDMI input?

1 Like

Wont load up on mvme or emmc. Just hangs on the rockchip logo. Super slow on sdcard. ;-(

1 Like

during the activation phase, i cant get ethernet connection to work. didnt see any dhcp request either.

thnx for feedback

1 Like

i am recompiling it with the raxda sources now (it was incomplette) this is based on the khadas source .

so thnx for the feedback .

1 Like

Your awesome!
Considering my main goal is to turn the Rock5B into a media center this goes a long way for me.

i see. i guess the realtek ethernet driver were not included then.

also i noticed there is no blue/activity led, i guess you did this on purpose then? :slightly_smiling_face:

no nothing on purpose but there are a lot of files in android source :wink:

on my rk3566 Quartz64-a it runs nice 4k could be better

on a H96 max v58 it also runs only have to proper make a dts for it no wifi or bluetooth but with ethernet

and since i got the source from raxda i made a rock 5b and a 3a image and i just today grabbed the raxda sdk to built a little more proper one for rock board

Great Build. Thank you for your hard work! Cant wait for the updated build! i managed to get it to work on the emmc. Boots super fast!

how, please share the steps

I was using balenaEtcher to write image. I switched to rufus-3.21 and it worked. dont know why it wasnt working with balenaEtcher.

did it failed on validation end on balenaEtcher?
i dont see any different between this two method, partition table looks the same, protective MBR with GPT and i cant still boot one of my SD card.

do a full sd format

uboot does like that sometimes if you used the sd before

yup, i did those disk wipe (fill with zeroes) with one of the windows tool (aomei partition assistance), didnt help.
anyway, radxa already acknowledge (https://github.com/radxa/manifests/releases) on the issue of some sd card cant be booted, perhaps it is something that rockchip need to address.

1 Like

yeah that is proberley a rk12 build wich i dont have a sdk from i have till rk10

didnt fail. just didnt boot. im using a 32gb samsung evo sd card