[ROM] ROCK 5B Android 12.1 rkr10 GoogleTV

Got it to boot RKDevTool installed to MMC… but yeah no wifi or Eth so I guess I’ll wait for your update…

1 Like

V2 please feeback



wifi, bluetooth working now. no ethernet. Everything else seems to be working!

that is strange your sure ?

it raxda kernel and raxda dts so i wont know why it wont work

i have an amazon basics usb to ethernet adapter. That works. But plugging in my cable directly to the Rock5 i get no connection. Wait for some more comments. Could be just me having issues.

connect ethernet before booting device , android disables ethernet when no connection is found

Turned off wifi. Restarted. No internet. Also removed wifi card. Same thing. No internet ethernet. But once i plug in my ethernet adapter. i get intenet via ethernet. just nothing from rock5 ethernet port. Let some more people test. lets see their results.

thnx for trying

i also enabled libsvep what i does ? think some ai thing in tv settings

do you have a log ? i dont have the device

where do i find logs? never looked for them.

yup, the same for my case, ethernet still doesnt work (both v1 and v2 image)

thc013 did you order the Rock5? Awesome job on this build! Exactly what i wanted.

some of the console output for the ethernet issueandroidtv-console.zip (54.9 KB)

cant find anything with rtl8125b/r8125

console:/ $ ifconfig -a
lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope: Host
RX 1packets:73 errors:0 dropped:0 overruns:0 frame:0
0 TX packets:73 errors:0 dropped:0 overruns:0 carrier:0
1 collisions:0 txqueue0len:1000
RX bytes.4:26910 TX bytes:26910

8100dummy0 Link encap:Ethernet7 HWaddr b6:48:0a:f8:a7:69][
inet6 addr: fe80::Tb448:aff:fef8:a769/64 Scope: 3Link
7 RX packets:0 errors:] 0 dropped:0 overruns:0 frame:t0
TX packets:109 errors:0 dropped:0 overruns:0 carrier:0
collisipons:0 txqueuelen:1000
e RX bytes:0 TX bytes:1294=8

ip_vti0 Link encap:UNSPEC
NOARP MTU:1480 Metric:1
RX p1ackets:0 errors:0 dropped:0 o4verruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelean:1000
RX bytes:0 TX bytes:0

ip6_vti0 Link encap:UNSPEC udit(1669822958.
NOAR364 0Metric:1
RX packet1:0 errors:0 dropped:0 overru TX packets:0 errors:0 dropped:0 ove0rruns:0 carrier:0
RX bytes:0 TX byt:es:0

sit0 -in-IPv4 88): avc: denie
NOARP d M{T Ui:o1c80 Metrckets:0 errors:0 dropped:0 overtruns:0 frame:0
TX paropped:0 overrluns:0 carrier:0
collisions:0 txqueuel RX bytes:0 TX bytes:0

ip6tnl0 Link encap:UNSPEC }
2 Me tric:1
0 txqueuelen:1000 ts:0fo errors:0 dropped:0 overru TX packetcs:0 errors:0 dropped:0 overruns:0 carrier:0
RX bytes:0 TX bytes:0

ignore the wlan error, i didnt install any wireless lan card
console:/ $ dmesg|egrep ‘lan|wan|rtk|ethernet|realtek’
[ 5.051713] [ T0] Linux version 5.10.66 (thc013@SHAGGY013) (Android (7284624, based on r416183b) clang version 12.0.5 (https://android.googlesource.com/toolchain/llvm-project c935d99d7cf2016289302412d708641d52d2f7ee), LLD 12.0.5 (/buildbot/src/android/llvm-toolchain/out/llvm-project/lld c935d99d7cf2016289302412d708641d52d2f7ee)) #2 SMP PREEMPT Wed Nov 30 16:18:24 CET 2022
[ 5.705174] [ T1] rockchip-vop2 fdd90000.vop: [drm:vop2_bind] vp0 assign plane mask: 0x5, primary plane phy id: 2
[ 5.705184] [ T1] rockchip-vop2 fdd90000.vop: [drm:vop2_bind] vp1 assign plane mask: 0xa, primary plane phy id: 3
[ 5.705196] [ T1] rockchip-vop2 fdd90000.vop: [drm:vop2_bind] vp2 assign plane mask: 0x140, primary plane phy id: 8
[ 5.705203] [ T1] rockchip-vop2 fdd90000.vop: [drm:vop2_bind] vp3 assign plane mask: 0x280, primary plane phy id: 9
[ 5.749150] [ T1] usbcore: registered new interface driver MOSCHIP usb-ethernet driver
[ 5.749240] [ T1] usbcore: registered new interface driver qmi_wwan
[ 5.914903] [ T1] usbcore: registered new interface driver hanwang
[ 5.985426] [ T1] rtk_btusb: RTKBT_RELEASE_NAME: 20220324_BT_ANDROID_12.0
[ 5.985434] [ T1] rtk_btusb: Realtek Bluetooth USB driver module init, version 5.2.1
[ 5.985442] [ T1] rtk_btusb: Register usb char device interface for BT driver
[ 5.985582] [ T1] usbcore: registered new interface driver rtk_btusb
[ 6.055310] [ T1] [WLAN_RFKILL]: Enter rfkill_wlan_init
[ 6.055588] [ T1] [WLAN_RFKILL]: Enter rfkill_wlan_probe
[ 6.055607] [ T1] [WLAN_RFKILL]: wlan_platdata_parse_dt: wifi_chip_type = ap6255
[ 6.055610] [ T1] [WLAN_RFKILL]: wlan_platdata_parse_dt: enable wifi power control.
[ 6.055614] [ T1] [WLAN_RFKILL]: wlan_platdata_parse_dt: wifi power controled by gpio.
[ 6.055645] [ T1] [WLAN_RFKILL]: wlan_platdata_parse_dt: WIFI,poweren_gpio = 20 flags = 0.
[ 6.055658] [ T1] [WLAN_RFKILL]: wlan_platdata_parse_dt: WIFI,host_wake_irq = 10, flags = 0.
[ 6.055664] [ T1] [WLAN_RFKILL]: wlan_platdata_parse_dt: The ref_wifi_clk not found !
[ 6.055667] [ T1] [WLAN_RFKILL]: rfkill_wlan_probe: init gpio
[ 6.055676] [ T1] [WLAN_RFKILL]: Exit rfkill_wlan_probe
[ 6.212396] [ T9] rockchip-vop2 fdd90000.vop: [drm:vop2_bind] vp0 assign plane mask: 0x5, primary plane phy id: 2
[ 6.212442] [ T9] rockchip-vop2 fdd90000.vop: [drm:vop2_bind] vp1 assign plane mask: 0xa, primary plane phy id: 3
[ 6.212477] [ T9] rockchip-vop2 fdd90000.vop: [drm:vop2_bind] vp2 assign plane mask: 0x140, primary plane phy id: 8
[ 6.212495] [ T9] rockchip-vop2 fdd90000.vop: [drm:vop2_bind] vp3 assign plane mask: 0x280, primary plane phy id: 9
[ 22.051993] [ T279] using random self ethernet address
[ 22.052002] [ T279] using random host ethernet address
[ 27.844865] [ T450] [dhd] STATIC-MSG) dhd_static_buf_init : 101.10.361.12 (wlan=r892223-20210928-1)
[ 27.844959] [ T450] [dhd] STATIC-MSG) dhd_init_wlan_mem : prealloc ok for index 0: 8131584(7941K)
[ 28.212234] [ T450] [dhd] _dhd_module_init: in Dongle Host Driver, version 101.10.361.16 (wlan=r892223-20220221-1)
[ 28.212234] [ T450] drivers/net/wireless/rockchip_wlan/rkwifi/bcmdhd compiled on Nov 30 2022 at 16:17:34
[ 28.212260] [ T450] [dhd] ======== dhd_wlan_init_plat_data ========
[ 28.212309] [ T450] [dhd] dhd_wlan_init_gpio: WL_HOST_WAKE=-1, oob_irq=149, oob_irq_flags=0x4
[ 28.212314] [ T450] [dhd] dhd_wlan_init_gpio: WL_REG_ON=-1
[ 30.760941] [ T450] [dhd] ======== dhd_wlan_deinit_plat_data ========
[ 30.760944] [ T450] [dhd] dhd_wlan_deinit_gpio: gpio_free(WL_HOST_WAKE 0)
[ 52.537412] [ T278] init: Unable to set property ‘wlan.driver.status’ from uid:1010 gid:1010 pid:450: Property type check failed, value doesn’t match expected type ‘enum ok unloaded’
console:/ $

console:/ $ dmesg |egrep ‘rtl’
[ 5.735874] [ T1] usbcore: registered new interface driver rtl8150

for comparison, radxa android build(with leanback laucher) does load r8125 driver (as per below)

[ 9.320757][ T325] r8125 2.5Gigabit Ethernet driver 9.009.00-NAPI loaded
[ 9.320850][ T325] r8125 0004:41:00.0: enabling device (0000 -> 0003)
[ 9.341363][ T325] r8125: This product is covered by one or more of the foll owing patents: US6,570,884, US6,115,776, and US6,327,625.
[ 9.343477][ T325] r8125 Copyright © 2022 Realtek NIC software team <nicf ae@realtek.com>
[ 9.343477][ T325] This program comes with ABSOLUTELY NO WARRANTY; for deta ils, please see http://www.gnu.org/licenses/.
[ 9.343477][ T325] This is free software, and you are welcome to redistribu

One more issue. My android tv bluetooth remote won’t pair.
After first boot and formatting sd as storage - I assume this is only the left over part as partition was not extended to cover whole sd - device did not boot again.

Also my nvme drive is not visible as it was under ubuntu.


would you be so kind to check if bluetooth also is broken in v1

i changed from khadas source to raxda source and bluetooth has changes

1 Like

V1 i had no bluetooth or wifi and ethernet. bluetooth works now V2. remote keeps loosing connectivity after reboot. But i hold down arrow (back button) and home for a second and it reconnects.

ah thnx back button ,i did something with it i have to look if that is related.

but thanks for the info and trying, i put it on the todo list

i also enabled hdmiin and libsevb the last has pproberley have to do with the ai settings in tv options

My is detected but not paired

looks a lot nicer as a boring default rockchip boxlauncher with phone/tablet google play


Mine didnt pair under remote & accessories. i went device preferences, bluetooth and set it up that way.

So much better! Thank you!