Use local USB3.0 port of Rpi4 with USB3.0 hub


Is there anybody know whether I can connect two USB3.0 ports on SATA HAT to one USB 3.0 port on Rpi4 via a USB3.0 hub (A-A cable from HAT to hub)? As NAS device will not always occupy the full bandwidth of two USB3.0, I would like to connect more external storage with a USB3.0 HDD cage.

Any hints of the 4 ports USB3.0 bridge? Can I use 2 A-A cables to replace this bridge?

I’ll try it tomorrow and tell you the result. In theory it’s possible, but the transmission speed will decrease.

Any news? @setq

Confirmed. You can use a hub.

Thanks a lot, @setq. Would you share the A-A cables you used? I bought cables from 2 shops on Taobao. None of them works…

The hub I’m using is Orico MH4U (chip: VL817) and I made the A-A cables myself.

Aha! You made the A-A cables! Amazing~~~
I used Orico VL815 hub. Will try homemade cables.

@setq Do I have to reverse the cable for this A-A cable?

No reverse. Simply connect them one by one.

I made A-A cables by myself. It works now. Thanks @setq!

Aha! Amazing~~~

how did you connect the plugs ? no crossing data cable or anything else ? Just connect pin1 to pin1, pin2 to pin 2 … and so on ?
Best regards

I see that I made simmilar topic :frowning:

But for me it is not working
I use this hub

I bought Orico with chip VL815 and for me it doesn’t work :frowning:

I bought another usb hub Orico F4U3-U3 also with mentioned chip VL817, but for me it doesn’t work.
System find only hub not devices behind this hub :frowning:

setq, laughterwym and me needed to made their A-A cables by themself

Finally I got it working and now I know that where was problem.
It was cable problem.
I used connection cable which works only with direct connection to one of usb port on RPi. When I connect it via HUB it was not working.
Now I tried connection together with connection and extension cable, system find usb device via HUB.
So now I have two possibilities.

  1. two cables: connection + extension
  2. make my own (by reconfigure existing which I have), maybe somebody can help me how I can make it :smiley:

An A-A connection cable (= non 1:1 wiring) plugged in an extension cable (= 1:1 wiring) stays a (than longer) connection cable (= non 1:1 wiring)

I made another test. If I connect connection + extension cable both USB3 it doesn’t work only when I use one of them USB2 (in my case extension).
Best way will be to make my own from existing connection cables

before starting USB-3 cable DIY
you may give a short extension cable in combination with your U connector a chance
as indicated here in Phase I Heat issue solved by separating SATA HAT and Pi

I could imagine those 30 cm extension could match that requirements
female part surface should be plastic and thickness not exceed 9.2 mm

Otherwise those will work for sure but are 1m long