Ubuntu image with X11 and Resolution 2560x1440

Not sure if same setup as op, I used ubuntu server image and then installed ubuntu-desktop and I’m able to get 4k60hz on HDMI1.
Unfortunately I am unable to get 4k120hz on same port. Switching to 120hz loses video and then will revert to 60hz.


Thanks, is it the 5:10 kernel or does the desktop install update the kernel? I’ll give it another try.

rock@rock-5b:~$ uname -a
Linux rock-5b 5.10.66-27-rockchip-gea60d388902d #rockchip SMP Mon Oct 24 08:25:47 UTC 2022 aarch64 aarch64 aarch64 GNU/Linux

I have to use this device tree overlay to enable my Philips 4K monitor: https://github.com/amazingfate/radxa-rock5b-overlays/blob/main/rk3588-add-hdptxphy_hdmi_clk.dts.

I think only one port can provide 120fps at 4k

I found a solution:

I got https://raw.githubusercontent.com/amazingfate/radxa-rock5b-overlays/main/rk3588-add-hdptxphy_hdmi_clk.dts

compile the dts file
dtc -O dtb -o rk3588-add-hdptxphy_hdmi_clk.dtbo rk3588-add-hdptxphy_hdmi_clk.dts

and install it into your current kernel dtbs directory:
cp rk3588-add-hdptxphy_hdmi_clk.dtbo /boot/dtbs/uname -r/rockchip/overlay/

sudo vim /boot/extlinux/extlinux.conf

and replace /dtbs/5.10.66-27-rockchip-gea60d388902d/rockchip/overlay/rock-5b-hdmi1-8k.dtbo with /dtbs/5.10.66-27-rockchip-gea60d388902d/rockchip/overlay/rk3588-add-hdptxphy_hdmi_clk.dtbo

use uname -r to get your current kernel release string and replace it accordingly.

reboot and then change the resolution in you running X11 session.


My ultra wide monitor worked perfectly with my rock 5B. I use just one type-c cable to get 5b powered up and runs at 3440*1440 165Hz. By the way, I’m using the official debian image.

1 Like

To be clear, your in display port alt-mode and the usb-c cable is providing both power to the 5b and video out to the monitor, correct?


1 Like

Tested on the official Debian image

I managed to get 2560x1440@60 on my monitor (native res) through USB-C (through a hub with HDMI output), but not able to get more than 1080p60 from the board’s own HDMI output.

Can you try out my Solution (Ubuntu image with X11 and Resolution 2560x1440)?

Try it without build a new Kernel.

Thank you!
It’s working fine with 2560x1440 at 100 Hz @HDMI1 without a new kernel.

I didn’t have a rock-5b-hdmi1-8k.dtbo line and only added the line to the fdtoverlay-line in the extlinux.conf (I am using the Debian-Image, not Ubuntu - maybe that’s the difference)

I had to install the dtc-package, before i could compile the dtb:

sudo apt-get install device-tree-compiler

1 Like

Hi n0x,

Roschach seemingly had a successful result, but on the contrary my main display capable of native 3440x1440 @ 75Hz was not totally usable out-of-the-box on the Debian X11 bullseye image, and only 1600x1200 was available.

But your suggested method, without kernel rebuild, worked fine for me too.

Thanks for your contributions

1 Like

Actually I had exactly the same problem, and as you I was success just I was a bit confused with the /boot/extlinux/extlinux.conf but as you said I just set:

fdtoverlays /dtbs/5.10.66-27-rockchip-gea60d388902d/rockchip/overlay/rk3588-add-hdptxphy_hdmi_clk.dtbo

and also took 2560x1440 60Hz in both HDMIs :slight_smile:


1 Like

I can confirm that this also works for my 1920x1200 display on armbian, I used user_overlays as described here: https://docs.armbian.com/User-Guide_Allwinner_overlays/
otherwise a new kernel package will overwrite it.

I built the `rk3588-add-hdptxphy_hdmi_clk.dtbo and cp’ed it to kernel dtbo location and edited armbianEnv.txt. I also set the perms same as other dtbo’s. (no extlinux on Armbian). Any help to get 1440p res pls. I tried the user_overlays way also.

Can you be so kind to provide some additional info on how you got this to work on Armbian?

It is in armbianEnv.txt you are editing?
Can you make a step by step?

  • create a folder /boot/overlay-user/
  • copy the dtbo file there
  • create line: user_overlays=rk3588-add-hdptxphy_hdmi_clk in armbianEnv.txt

note I I just wrote it from the top of my head, as I had to RMA my board.
The confusing thing here is the inconsistent nomenclature: overlay-user != user_overlays

TY sydarn2. It worked. :slight_smile:

Did not work for me :cry:

I’ve never compiled file before.

I simply copy the text in…:

…from browser and paste in notepad, saving as .dts file. Then compile the dts file I created.

Not correct way maybe?