Top Fan always running, not responsive to PWM

Hi,

I have a problem similar to Pi 4 Quad Sata Hat Fan always at 100% where no solution was given as it looked like a hardware issue. The date on my hat is 2020-09-17.

The fan in the top board is running as soon as I plug the power (12V DC direct to the hat), even without an sd card in the raspberry pi 4.

The fan is also not responsive the the GPIO PWM pins. I have pigpio and rocky-sata running fine (disks are up, oled is working, rocky-sata gets gpio with host localhost, both services are active). I have lvl0 set high of course.

But the gpio pins do nothing. Running the python code manually with import fan, fan.gpio.hardware_PWM(12, 0, 0) and fan.gpio.hardware_PWM(13, 0, 0) do nothing. It is basically impossible to turn off the fan.

Is there any solution to this? Do I need to get a new top board and if yes, where can I get one?

I should mention that I bought the kit used on eBay so I didn’t build it myself. Is it possible that the wrong kind of fan be fitted on the top board? How can I check? There’s nothing written on the fan itself, all I can see are the three red yellow and black wires.

Thanks!

Hello, what does the output of command

netstat -l | grep -o '\S*:8888' | tr -d ':8888'

Hi, the output is simply localhost.

Note I have changed the pigpio service config to force ipv4:

ExecStart=/usr/bin/pigpiod -l -m -n 127.0.0.1 -p 8888

Please have a try:

import pigpio
gpio = pigpio.pi(host='127.0.0.1')
gpio.hardware_PWM(12, 0, 0)
gpio.hardware_PWM(13, 0, 0)

Nothing happens, the fan is still spinning after I run the code.

pi@mediaserver:/usr/bin/rockpi-sata $ python3
Python 3.9.2 (default, Feb 28 2021, 17:03:44) 
[GCC 10.2.1 20210110] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import pigpio
>>> gpio = pigpio.pi(host='127.0.0.1')
>>> gpio
<pipio.pi host=127.0.0.1 port=8888>
>>> gpio.hardware_PWM(12, 0, 0)
0
>>> gpio.hardware_PWM(13, 0, 0)
0

Try stopping the rockpi-sata.service and run the code again.

Still nothing. I stopped the service first:

pi@mediaserver:~ $ sudo service rockpi-sata stop
pi@mediaserver:~ $ sudo service rockpi-sata status
● rockpi-sata.service - Rockpi SATA Hat
     Loaded: loaded (/lib/systemd/system/rockpi-sata.service; enabled; vendor preset: enabled)
     Active: inactive (dead) since Tue 2022-03-29 10:26:05 BST; 6s ago
    Process: 413 ExecStart=/usr/bin/python3 /usr/bin/rockpi-sata/main.py on (code=killed, signal=TERM)
    Process: 955398 ExecStop=/usr/bin/python3 /usr/bin/rockpi-sata/main.py off (code=exited, status=0/SUCCESS)
   Main PID: 413 (code=killed, signal=TERM)
        CPU: 13min 45.521s

Mar 28 13:46:49 mediaserver systemd[1]: Started Rockpi SATA Hat.
Mar 29 10:26:00 mediaserver systemd[1]: Stopping Rockpi SATA Hat...
Mar 29 10:26:05 mediaserver systemd[1]: rockpi-sata.service: Succeeded.
Mar 29 10:26:05 mediaserver systemd[1]: Stopped Rockpi SATA Hat.
Mar 29 10:26:05 mediaserver systemd[1]: rockpi-sata.service: Consumed 13min 45.521s CPU time.

Then I ran the code and nothing happened, fan still spinning hard.


pi@mediaserver:~ $ cat fanfix.py
import pigpio
gpio = pigpio.pi(host='127.0.0.1')
gpio.hardware_PWM(12, 0, 0)
gpio.hardware_PWM(13, 0, 0)

pi@mediaserver:~ $ python3 fanfix.py 

Anything else I can try? Thanks for your help.