Pi 4 Quad Sata Hat Fan always at 100%

Hello. I love this hat, but I do have an issue. The first time the Pi4 boots up, the sata hat fan starts up at 100%. After installing the install script

curl -sL https://rock.sh/get-rockpi-sata | sudo -E bash -

I thought I could control the fan by editing the file

/etc/rockpi-sata.conf

but none of the settings work and double pressing on the button did not turn off the fan. I double checked the setting and changed twice = 2.0 then rebooted, but still cannot get it to slow or stop the fan.

Try to increase the value of lv0

set the values below, saved and rebooted. No change on startup and no change when pressing and holding.

[fan]

When the temperature is above lv0 (35’C), the fan at 25% power,
# and lv1 at 50% power, lv2 at 75% power, lv3 at 100% power.
# When the temperature is below lv0, the fan is turned off.
# You can change these values if necessary.

lv0 = 80
lv1 = 85
lv2 = 90
lv3 = 95
[key]

# You can customize the function of the key, currently available functions are
# slider: oled display next page
# switch: fan turn on/off switch
# reboot, poweroff
# If you have any good suggestions for key functions,
# please add an issue on https://setq.me/rockpi-sata

click = slider
twice = switch
press = switch
[time]
####### twice: maximum time between double clicking (seconds)

# press: long press time (seconds)

twice = 1.0
press = 3.0
[slider]

# Whether the oled auto display next page and the time interval (seconds)

auto = true
time = 10
[oled]

# Whether rotate the text of oled 180 degrees, whether use Fahrenheit

rotate = false
f-temp = false

I do want to mention that this is a v1.1 board with USBC power and I am providing power via the included power adapter and cable to the USBC hat. As soon as I plug in the USBC power cable, the hat fan starts at 100%. I have unplugged the fan cable and put it back in.

I guess my question is, is it the CPU or sata hat fan that is being controlled by rockpi-sata.conf?

edit – is it a hardware issue? I removed the sd card and powered on the Pi. The Pi turns on, and both the hat fan and cpu fan turn on 100%. Based on this video https://youtu.be/Eix0PCB0byQ?t=334 he says that the fans do not turn on, until you install the script.

I ran this command: /opt/vc/bin/vcgencmd measure_temp
and got back: temp=41.0’C

So the fan should be off, since I have level 0 at 80c

Thank you for your detailed information. Judging from the current information, it is an issue of Raspberry Pi.

Please try not to put the hat on raspi, but directly power on the hat. So we can locate the issue.

So you want me to remove the hat from the Pi and then power on the hat and see if the fan turns on? is that correct?

Ok I did that. I removed the pi, so now the sata hat has no drives, has the white cord connecting the sata hat to the top hat. When I power on the sata hat, the top fan turns on.

Do you have any other raspi?

I have 1x Pi4 and 2xPi3b+

Please test again with a raspi3b+ without sd card.

Ok. raspi3b+ connected to sata hat, with no sd card and cord connecting sata hat to top hat… the top fan turns on 100% speed.

It is basically confirmed that there is something wrong with our hardware.

I still need to analyze whether it is hat or top-board.

I’m sorry to give you a bad experience.

Thats sad to hear. How do we fix this? Do you want me to send it back, continue troubleshooting? You tell me what to do.

We should be able to replace it with a new one, after I confirm which part is wrong.

Do you need me to send it back so you can troubleshoot?

Powering on Pi4, I was able to determine that the CPU fan and the top hat fan both turn on without a SD card inserted.

Hi @setq Is there an update?

I’m sorry there is no progress yet. I’ll make it as soon as possible.