Armbian support

Great. Will check ASAP. Is it already included in Armbian build system?

Hi, I have bought a rockpi4 a week ago. Has both asus tinker board and 2 raspbarry b+. I have to say that I’m glad that Armbian is getting ready for my rockpi4.

not yet, we are cleaning the patches and will send PR.

Was trying the kernel modules packages in Armbian, I get the following error.

root@rockpi4b:/root/# apt-get install rockchip-overlay rockchip-fstab
Reading package lists... Done
Building dependency tree
Reading state information... Done
rockchip-fstab is already the newest version (0.1).
rockchip-overlay is already the newest version (0.9).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Setting up rockchip-fstab (0.1) ...
sed: -e expression #1, char 0: no previous regular expression
mount all partitions
mount: mount point vfat does not exist
mount: mount point vfat does not exist
mount: mount point vfat does not exist
mount: mount point vfat does not exist
mount: mount point vfat does not exist
dpkg: error processing package rockchip-fstab (--configure):
 subprocess installed post-installation script returned error exit status 32
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

You can’t install these packages in Armbian. Armbian has its package repositories and maintains its own packages. The main reason is Armbian uses a whole partitions as the rootfs but for Debian/Ubuntu Released by us and Rockchip officially, we uses 5 partitions, p4 for boot and p5 for rootfs. If you want to install modules, you should install it from the Armbian repository.


I just received my rockpi 4A, Does anyone know if Armbian includes GPU hardware acceleration? I need to develop on OpenGLES 3.1.



I’d very much like to know this too, as GLES 3.1 and 3.2 would be a major reason for me buying this board, I can’t commit to it until I know it has all drivers available.

Will you release a minimal Armbian image? No desktop or other optional software installed. Just a nice clean base for a headless server?

I just got my Rock Pi4A that I will be using as a docker server. And I noticed all the desktop stuff installed in the armbian image.

As well as a bluetooth process running. :frowning:

There’s a WIP testing version up on armbian now.


Oh, wow, totally missed it

Hi, I installed the armbian image from radxa to my sd card with etcher and it works fine. If I flash the image from to my sd card rock pi is always booting from my emmc card (there is an ubuntu image installed). Any idea?

I had the same problem three weeks ago. I then removed the eMMC, but I asked in the Armbian forum if this is normal. I didn’t remove the heat sink and think I could fiddle with the eMMC later.

The RockPi does not boot Armbian Stretch from the inserted SD card if an eMMC is installed at the same time. As soon as I remove the eMMC it works. An image of radxa boots even if eMMC is installed. This behavior irritates me a bit, is that normal?

probably not… But you have at least to provide a bootlog from serial console to get a clue where it messes… RockPi is in early stage of board bring up (wip). Bugs must be expected…


As was stated later Armbian use different boot order, than Radxa version. So for Radxa it’s
Sd – eMMC
amd for armvian it’s

Hi, I like the boot order SD - eMMC more. I installed Armbian from the Radxa Website and then installed on the Rock pi the same image witth dd to eMMC. When I then remove the sd it boots perfect the armbian image from eMMC. I think this is the best way to test different images. I will stay with the rock pi Armbian image from radxa for the main image on eMMC card. it works really good. The only problem I do have is that on debin images my Apple USB Keyboard is not working (it works on ubuntu images without any problem).

I tried switching to armbian from ubuntu ( armbian from radxa downloads ), in an attempt to solve a hang ( like every 2 - 3 days ). Now I can not get my nvme to recognize. The device is a ‘patriot’ scorch 128GB NVMe M.2 PCIe. Ubuntu image could find this device, but armbian can not. Anyone know how to solve this? I’ve tried nightly and stable builds.

I think you installed the Armbian downloaded from Armbian website, not the one from Radxa, right?

Don’t think so. I tried this:


Finally gave up and went back to ubuntu server.

OK, but who has build images using ARM Windwos (downloadable) for this machine?
Or where is the Ubuntu-Version which also can be integrated with an emulator?
I am using RPI3b+ up to now but i have seen those images.

so please send me the WINDOWS ARM-Version for RPI3b+ ?!

was anyone successful in installing docker / omv on armbian?