Quad Sata Kit and OpenMediaVault 5 (Raspberry Pi 4)

Thanks for your feedback.

I found that the suggested fix, where the subsystem was stated as usb did not work for me.

KERNEL==“sd*”, ATTRS{idVendor}==“152d”, ATTRS{idProduct}==“2338”, SUBSYSTEMS==“usb”, PROGRAM="/root/serial.sh %k", ENV{ID_SERIAL}=“USB-%c”, ENV{ID_SERIAL_SHORT}="%c"

(With the right vendor and product ids of your drives.)

Since it appeared (using “sudo udevadm monitor”) that the device was actually being processed as a scsi rule, rather than the usb rule. After creating the “/root/serial.sh” as suggested in the fix (and chmod +x on it), the udev rule:

Sata-Hat drive fix

KERNEL==“sd*”, ATTRS{idVendor}==“1058”, ATTRS{idProduct}==“0a10”, SUBSYSTEMS==“scsi”, PROGRAM="/root/serial.sh %k", ENV{ID_SERIAL}=“USB-%c”, ENV{ID_SERIAL_SHORT}="%c"

Found the drives and got their correct serial number so I got all four drives.

I am struggling with this. I can only see the correct SNs and all 4 drives when using:
KERNEL=="sd*", ATTRS{idVendor}=="1058", ATTRS{idProduct}=="0a10", SUBSYSTEMS=="usb", PROGRAM="/root/serial.sh %k", ENV{ID_SERIAL}="USB-%c", ENV{ID_SERIAL_SHORT}="%c"

If I change the subsystems to scsi, I lose two drives and my SNs become generalized (1234567890123).

That had been my expectation as well, that it should be a usb rule. However for me it turned out to be a scsi rule which was prompted by the udevadm monitor command, where I saw that the device was appearing on my system as a scsi, for some unknown reason.

It would appear that there can be some variance in how things look, for whatever unknown reason. So my hack rule, which worked for me, does not appear to work for you.

I’d love to hear if there is an explanation of these two results.

Thanks Oket. That solution worked for me. The only thing missing was I had to chmod+x the /root/serial.sh file and then reboot.

Hi, thanks all for the info its been helpful
i was able to get all 4 drives to show up in OMV under the “disks” section
But when i go to RAID Management, and try to create an array, no disks are listed.
Im guessing this is because its not showing USB disks, how have you guys worked around that?

I saw the comment about somehow marking them for SCSI, but im not sure if that is what i should be doing (or even how)

i followed the info on the instructions page, and then watched through the youtube video but int he video when he got to the the raid section, his array was already setup
Any more direction would be helpful

Did you operate it on OMV?

You will have to create your raid array with mdadm. The “Create Raid Array” dialog on OMV will refuse to show you USB drives, with the warning below the disk display area of:

image

After you have created it externally, it will show up under OMV’s Raid management.

OMV appears to be pretty terrible… i eventually got a raid pair (just mirrored for now) working using mdadm command and much other magic spells, but it IS working. slow as shat, but working.

Is your RAID fully built? You can check with cat /proc/mdstat until it’s fully built performance will be degraded

I am only seeing the 2 drives as well I have been trying to use the script:

KERNEL==“sd*”, ATTRS{idVendor}==“1058”, ATTRS{idProduct}==“0a10”, SUBSYSTEMS==“usb”, PROGRAM="/root/serial.sh %k", ENV{ID_SERIAL}=“USB-%c”, ENV{ID_SERIAL_SHORT}="%c"

I get this error:
-bash: ATTRS{idVendor}==1058,: command not found

Am i doing something wrong?

@rpachco6 Do you use it in the terminal?

Yes, terminal on my mac

Please refer to the WiKi for operation.

@rpachco6 you are missing the script in root folder… you need to create a file called serial.sh on the root folder…

sudo nano /root/serial.sh, then paste the following commands into the script:

#!/bin/bash
/sbin/hdparm -I /dev/$1 2>/dev/null | grep 'Serial Number' | awk '{print $3}'

then issue sudo chmod +x /root/serial.sh to get the script to be executable…

Thanks @setq and @eskimo I was able to get it set up.

I was able to get OMV setup after executing the JMicron controller fix outlined in the main troubleshooting area of the instructions here:
https://wiki.radxa.com/Dual_Quad_SATA_HAT

After that I set up a raid 5 manually because OMV doesn’t handle usb automatically. For this I used these two commands:

sudo mdadm -Cv -l5 -c64 -n4 -pls /dev/md0 /dev/sd{a,b,c,d}
sudo mkfs.ext4 /dev/md0

Following this I was able to setup and access the disks via SMB/CIFS. So far so good. But then decided to modify the /etc/rockpi-sata.conf file and execute sudo systemctl restart rockpi-sata.service

Unfortunately after reboot I’ve lot ssh access entirely. OMV works and I’m able to view the logs to see what’s happening. I think that the main pi memory isn’t mounting or booting properly.

I got the hint from a comment on this youtube video >>>https://youtu.be/Eix0PCB0byQ

This backed up by a missing disk that I can’t mount in OMV. Ordinarily this would be the sd card.

Lastly, when I check out the OMV logs it’s clear that there’s the volume that needs to be mounted to run the pi and ssh isn’t getting mounted. I’d be super grateful if anyone could tell enlighten me about a workaround to change the mount order so that the pi system disk mounts before the HDDS.

I figured out a quick and dirty way to get ssh back. I booted the system without the four port usb connector plugged in. That forced it to first mount the main memory which reactivated my ssh access. After that I plugged it back in and OMV mounted the disks.

Strangely I never had this problem in my setup… also had omv and manually created the raid array with mdadm… when I boot up my system, I did see a message indicating that they raid array is waiting for some disks… and it always successfully waits and loads the array… it could be some of the setting flags u used when creating the array that caused it not to wait for disks to come online n fail…

Hi guys, found a solution for the problem that there’s no raid array after reboot: just follow this guide and you should be done. Worked for me after several reboots: