Missing Disks in OMV

Hi everyone:)

I have the same problem as dicussed here. In OMV I can see only two of the drives in the section Storage/Disks but under File Systems/create I can see all four drives [WD Red])
Edit: They also show up on the concole (see screenshot) Anmerkung%202020-06-17%20185914
However, I am too stupid to understand the solution, that is posted on the official page.
Could someone help me out with more detailed instructions?
I would be very gratefull since I have no experience with Linux outside of using pihole:)


Thanks to StephaneP OMV is up and running with all drives showing up. For all the other beginners out there, here are the steps that worked for me:

Change Password: passwd
sudo raspi-config -> update tool
sudo apt update
sudo apt upgrade
sudo reboot

sudo -s
nano /lib/udev/rules.d/60-persistent-storage.rules

look for the entry Fall back usb_id for USB devices
leave one line blank and copy:


You can copy it here.

After adding this, the first line (#Fix Quad …) should look like the other “headlines” (different colour)
quit and save

nano /root/serial.sh
Copy:

#!/bin/bash
/sbin/hdparm -I /dev/$1 | grep ‘Serial Number’ | awk ‘{print $3}’

save and quit
sudo reboot
sudo -i
chmod +x /root/serial.sh (nothing visible happened to me here)

sudo reboot
curl -sL https://rock.sh/get-rockpi-sata | sudo -E bash -
(installs the sata hat, fans should start spinning)

wget -O - https://github.com/OpenMediaVault-Plugin-Developers/installScript/raw/master/install | sudo bash
(installs OMV)

open ip adress of the pi in browser
log in using “admin” and “openmediavault”

Hopefully all drives should be there:)

Have you tried @setq update : How to upgrade F/W with jms561 under Raspberry Pi ?

Hi StephaneP,

Thanks for taking the time to respond:)
I have not tried the update because of the “Danger! Do not use…”
But I guess there is nothing to lose since I have nothing saved on the drives.
I will try it later today. It would be awesome if that worked:)
Thank you for the suggestion:)

I’ve done it on my four WD HDD. without issue.

Heyho:)

I did the update and all drives show v8.1.3.6 (see screenshot).Anmerkung%202020-06-18%20183841

However, in OMV they still do not show up under “disks” but are still visible under “File Systems/Create” :frowning:

What else can I do? / Can anyone explain to me (a dumdum:/) how and where to do what is suggested in the wiki?

Thank you again StephaneP for your help so far:)

Edit: The Problem is even discussed on the OMV Website
The suggested solution is what is said in the wiki:

You can “fix” this by adding a rule to /lib/udev/rules.d/60-persistent-storage.rules after the entry for “Fall back usb_id for USB devices

How do I do that? Just running the “/lib/udev/rules.d/60-persistent-storage.rules” gives me a permission denied message. Anmerkung%202020-06-18%20185728

1 Like

Update:
I am a bit further now:

sudo -s

then

nano /lib/udev/rules.d/60-persistent-storage.rules

seems to be getting me to the right place.
After edit the line looks like this:

Could someone please tell me if this is correct and how to do the next step? How do I do this?: Anmerkung%202020-06-20%20232629

1 Like

seem ok :+1: test without reboot : no risk

Hey StephaneP,

Thx for looking into it:)
However, the problem persists.

Right now “nano /lib/udev/rules.d/60-persistent-storage.rules” is looking like this (I replaced what I had with the commands from the official wiki):


nano /root/serial.sh ist looking like this:

Could you or someone else explain to a noop like me how to work with:

chmod +x /root/serial.sh

Do I just need to copy that into the console? Or does it require a prefix like nano, sudo or whatever else there is?

As always help would be much appreciated:)

Also paging @setq
I would really like to get past this stage. Otherwise the money on the oterh two harddrives was just wasted:(

you need to be root
sudo -i
chmod +x /root/serial.sh
exit

DUDE! Thank you!:grinning: All of them show up:


I am so happy right now! Thank you for your help:)
I started again from scratch and your last comment was what was missing:)
Interesting that I did not install the update we talked about earlier this time around - I simply forgot. Whatever:D
Tomorrow I will sit down, write down every command I used to get to this point and put it into my first comment - just in case another noob like me is running around out there and looking for help:)
Thank you StephaneP. Without you I would have to continue banging my head against the wall^^