[Guide] openFydeOS - Rock 5B - the best option 🍺

🖱️For an UPDATED follow up of this Guide:▼

Welcome to the OpenFydeOS guide, where you’ll find the best options to optimize your experience with this amazing operating system! Below are some helpful tips and features that you can make the most of:

For me openFyde/FydeOS is the best operating system to have on a single board computer like the ones on the market so hail to FydeOS to be with Rockchip on this arm64 adventure.

Installation process:

Installation process is quite basic since this last update you can pretty much run it from any microSD so just go to openFyde/FydeOS Rock 5B github grab the .img file from them and RPi imager or Balena flash it to your SD.

Download FydeOS for your PC

FydeOS for your System or openFyde for your System

Just choose the version you prefer the most. You can now complete the full installation to your nvme directly and carry on!

🖱️Frequently Asked Questions (Read This):🖱️

Some questions and answers are meant for x86 systems not arm64.
Frequently Asked Questions (FAQs):

  1. How to disable your GPU card with hwtuner?
  2. How to enable AHCI, Virtualizations and Fix Storage? (Fix installation errors).
  3. Step-by-Step Guide to Installing FydeOS on Your Hard Drive
  4. FydeOS Starts Up but Fails to Recognize a Device: Here’s What to Do
  5. How to set a multi-boot configuration with other systems?
  6. Troubleshooting Video Playback Anomalies
  7. Guide to Selecting the Right FydeOS Variant for Your PC
  8. A Manual Walkthrough to Install OpenGApps on FydeOS
  9. OpenGApps installation failed, what should I do?
  10. With FydeOS installed in a multi-boot setup and the PC to be found exceptionally hot, what should I do?
  11. Why I cannot find options to enable Linux subsystem?
  12. How to Enable Widevine? (Netflix, Spotify, Disney+, etc)

FydeOS Special Releases:

FydeOS doesn’t support the NVIDIA GPU. However some models do work and others you might need you to disable them on bios via grub or with HW Tuner.

Logo stuck on installation can often be bad USB pen drive or bad USB port. (Try to switch and swap).

Crosh Gentoo Linux - Quick Index for Help

Please follow the guide https://faq.fydeos.com/en/getting-started/shell-access/ to enter the shell and be root. (Open Chromium - Ctrl Alt T - Type Shell type sudo -i) Do line by line don’t copy paste it all.

🖱️Fan Control / Options:🖱️

Turn off type: echo power_allocator > /sys/class/thermal/thermal_zone0/policy
Turn on type: echo step_wise > /sys/class/thermal/thermal_zone0/policy
Nonstop type: echo fair_share > /sys/class/thermal/thermal_zone0/policy

mount -o remount,rw /
sudo nano /etc/init/rock5-fan-control.conf
#find the line and update to fair_share

  echo fair_share > /sys/class/thermal/thermal_zone0/policy

Then press Ctrl+X, save Y  then sudo reboot and exit


To reduce the fan speed this also works:
Minimum: i2cset -y -f 2 0x18 0x8a 0x1F
Play between: i2cset -y -f 2 0x18 0x8a <0x10 to 0x64>

echo 55 | tee /sys/class/fan/trigger_temp_low
This works also to set the minimum loud spinning.

🖱️Enabling Bluetooth on some Modules:🖱️

To enable bluetooth on some modules for openFyde/FydeOS:

mount -o remount,rw /
nano /etc/modprobe.d/blacklist.conf
-- then add these lines somewhere (at the bottom of the file is fine):
blacklist pgdrv
blacklist btusb
blacklist btrtl
blacklist btbcm
blacklist btintel
Then press Ctrl+X, save Y  then sudo reboot and exit

🖱️Set Chronos Password:🖱️


#Crosh - Browser Ctrl Alt T, type: shell, type: sudo -i and:

sudo mount -o remount rw /
sudo passwd chronos

🖱️Overlays and Perks:🖱️

To activate FydeOS extras for your board check all information available here: https://fydeos.io/docs/knowledge-base/recipes/RK3588-soc-how-to-use-device-tree-overlay/
Type: ls /boot/rockchip/overlay/

If you want to activate a Display or Camera or any other just add that overlay to the following:

mount -o remount,rw /
sudo nano /mnt/stateful_partition/fyde/Env.txt
Then press Ctrl+X, save Y  then sudo reboot and exit

🖱️How to enable Widevine:🖱️
  1. Obtain the necessary Windevine files for the appropriate architecture (arm64 in this case) from your preferred place/vendor. If you cannot find this, you may try this one: https://github.com/Twinaxeatk/WidevineCdm/releases/download/R114/WidevineCdm_ARM64.tar.gz
  2. Uncompress the file (if necessary) and obtain the file libwidevinecdm.so.
    Move the file from the folder Downloads to Linux Files and with Linux do:
    tar -xf WidevineCdm.tar.gz
  3. Navigate to “Settings” -> “openFyde Settings”, and find the option to “Enable Widevine”, and choose the file libwidevinecdm.so from the uncompressed folder.
  4. Reboot.

EnjOY Netflix via Chromium browser now.

🖱️Discord for a quick approach:🖱️

Android Container - Arch Hero

:tropical_drink::beer: From OpenFyde version 108 We have Project ArcHero activated which mean that we can Install .apks Hurray! :raised_hands:

Now the good stuff about openFyde/FydeOS is that with ArcHero Android container we can play big time games from the app store:

  • Install apkpure, aptoide, uptodown, aurora store any store you like.
  • Install some some apks, xapk, apkm intallers like App Mirror, XAPK Installer, APK Installer.
    For big titles these installers are required. For general purpose… apkpure is literally enough for most things.

The fun of being able to play this is amazing.

(dont mind the video stuttering its just that… the video recording doesn’t do its justice it runs smooth).

You can now enjoy your hearthstone, diablo immortal, call of duty mobile etc… etc.

There is however only one last thing missing for perfection but not even google ChromeOS made this work yet:

  • No gamepad support yet for the Android subsystem.
    There is #arc-input-overlay-beta - it can be turned on chrome://flags but what games supports it?

Linux Container - Optional Features

For this guide I use NALA and Aptitude ! On penguin do the following:

🖱️Nala Legacy Install and Aptitude:🖱️
#For best behaviour install nala and aptitude.
sudo apt update && sudo apt install git make python3-pip python3-apt python3-debian pandoc aptitude -y 
git clone https://gitlab.com/volian/nala.git
cd nala
sudo make install
sudo nala update && sudo nala upgrade -y
#Better visual GUI better debug and auto resolution.

After this dont do sudo apt install anymore do sudo nala install instead ex: sudo nala install neofetch. The terminal behaviour will not just be pretty but it will do more tasks and correct issues as well giving you better debug feedback. Aptitude fetches for the updated dependencies and corrects the deprecated ones. (Command: sudo aptitude install neofetch).

🖱️Vivaldi Browser:🖱️
sudo apt install wget -y
wget -qO- https://repo.vivaldi.com/archive/linux_signing_key.pub | gpg --dearmor | sudo dd of=/usr/share/keyrings/vivaldi-browser.gpg
echo "deb [signed-by=/usr/share/keyrings/vivaldi-browser.gpg arch=$(dpkg --print-architecture)] https://repo.vivaldi.com/archive/deb/ stable main" | sudo dd of=/etc/apt/sources.list.d/vivaldi-archive.list
sudo apt update && sudo apt install vivaldi-stable -y
#sudo apt remove vivaldi-stable -y

Install Vivaldi for Geforce Now and (Widevine DRM for Netflix couldn’t make it work if someone can please let me know.).

Vivaldi browser installation

  1. Download Vivaldi .deb here https://vivaldi.com/download/archive/?platform=linux
  2. Open GDebi and install your specific Vivaldi browser

Create a desktop launcher (‘Needed’ for GeForce Now and Widevine)

  • Info: This allows you to add browser start up lines to provide better performance. To let pages know you are at the latest version.
  • Command:
    /usr/bin/vivaldi-stable --disable-seccomp-filter-sandbox --user-agent="Mozilla/5.0 (X11; Linux aarch64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36"

Same as openFyde Chromium for testing (Might improve performance- optional)

/usr/bin/vivaldi-stable --disable-seccomp-filter-sandbox --edge-touch-filtering --enable-native-gpu-memory-buffers --platform-disallows-chromeos-direct-video-decoder --enable-webgl-image-chromium --enable-features=Pepper3DImageChromium,UmaStorageDimensions,Crostini,CrostiniGpuSupport,SmartDim --num-raster-threads=2 --gpu-sandbox-failures-fatal=no --passive-listeners-default=true --enable-logging --log-level=1 --use-cras --enable-wayland-server --system-developer-mode --disable-mojo-broker --ash-use-cros-mojo-service-manager --cros-healthd-uses-service-manager --allow-os-install --login-profile=user --has-chromeos-keyboard --enable-touchview --disable-explicit-dma-fences --guest-wallpaper-large=/usr/share/chromeos-assets/wallpaper/guest_large.jpg --guest-wallpaper-small=/usr/share/chromeos-assets/wallpaper/guest_small.jpg --child-wallpaper-large=/usr/share/chromeos-assets/wallpaper/child_large.jpg --child-wallpaper-small=/usr/share/chromeos-assets/wallpaper/child_small.jpg --default-wallpaper-large=/usr/share/chromeos-assets/wallpaper/default_large.jpg --default-wallpaper-small=/usr/share/chromeos-assets/wallpaper/default_small.jpg --enable-consumer-kiosk --device-help-content-id=rock5b-openfyde --ozone-nnpalm-properties={} --arc-availability=installed --enterprise-enrollment-initial-modulus=15 --enterprise-enrollment-modulus-limit=19 --enable-crashpad --ml_service=enabled --ondevice_handwriting=use_rootfs --ondevice_document_scanner=use_rootfs --arc-start-mode=always-start-with-no-play-store --arc-availability=officially-supported --disable-features=ArcAndGuestOsFileTasksUseAppService,CrostiniUseDlc --disable-buffer-bw-compression --login-manager --feature-flags=["arc-game-mode@1","full-user-agent@1","ignore-gpu-blocklist","launcher-game-search@1","use-passthrough-command-decoder@1"] --first-exec-after-boot --enable-features=Pepper3DImageChromium,UmaStorageDimensions,Crostini,CrostiniGpuSupport,SmartDim --disable-features=ArcAndGuestOsFileTasksUseAppService,CrostiniUseDlc --flag-switches-begin --ignore-gpu-blocklist --enable-features=Pepper3DImageChromium,UmaStorageDimensions,Crostini,CrostiniGpuSupport,SmartDim,ArcGameModeFeature,DefaultPassthroughCommandDecoder,FullUserAgent,LauncherGameSearch --flag-switches-end --user-agent="Mozilla/5.0 (X11; Linux aarch64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36"

Set the latest user agent or just your actual one: https://whatmyuseragent.com

Open Vivaldi with the DRM browser launcher and verify the parameters …

  • flags: vivaldi://flags Override software rendering list > Enable (Do it for performance!)
  • components: vivaldi://components (check if Widevine Content Decryption Module is loaded)
  • gpu: vivaldi://gpu

  • Just a side note about Mouse Cursor on Cloud Gaming on Vivaldi:
    All types of mouse issues will trigger you press Esc or Ctrl G the way to fix this is to keep pressing Esc a few seconds and going back into full screen mouse will go back into the game layout.

(Video recording over Linux apps really doesn’t do its justice this runs perfectly fine.)

🖱️Brave Browser:🖱️

Brave Browser Install # No DRM fun and neither is supported by GFN but for the fans its this:

sudo nala install curl build-essential python-setuptools python3-distutils
sudo curl -fsSLo /usr/share/keyrings/brave-browser-archive-keyring.gpg https://brave-browser-apt-release.s3.brave.com/brave-browser-archive-keyring.gpg
echo "deb [signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg] https://brave-browser-apt-release.s3.brave.com/ stable main"|sudo tee /etc/apt/sources.list.d/brave-browser-release.list
sudo nala update
sudo nala install brave-browser
# in case to uninstall
sudo nala remove brave-browser brave-keyring
sudo rm /etc/apt/sources.list.d/brave-browser-*.list
🖱️Debian Browser:🖱️

Debian Browser - no netflix fun, geforce now is supported but doesn’t work / kinda broken.

sudo nala install chromium chromium-l10n # Debian Chromium
/usr/lib/chromium/chromium --edge-touch-filtering --enable-native-gpu-memory-buffers --platform-disallows-chromeos-direct-video-decoder --enable-webgl-image-chromium --enable-features=Pepper3DImageChromium,UmaStorageDimensions,Crostini,CrostiniGpuSupport,SmartDim --num-raster-threads=2 --gpu-sandbox-failures-fatal=no --passive-listeners-default=true --enable-logging --log-level=1 --use-cras --enable-wayland-server --system-developer-mode --disable-mojo-broker --ash-use-cros-mojo-service-manager --cros-healthd-uses-service-manager --allow-os-install --login-profile=user --has-chromeos-keyboard --enable-touchview --disable-explicit-dma-fences --guest-wallpaper-large=/usr/share/chromeos-assets/wallpaper/guest_large.jpg --guest-wallpaper-small=/usr/share/chromeos-assets/wallpaper/guest_small.jpg --child-wallpaper-large=/usr/share/chromeos-assets/wallpaper/child_large.jpg --child-wallpaper-small=/usr/share/chromeos-assets/wallpaper/child_small.jpg --default-wallpaper-large=/usr/share/chromeos-assets/wallpaper/default_large.jpg --default-wallpaper-small=/usr/share/chromeos-assets/wallpaper/default_small.jpg --enable-consumer-kiosk --device-help-content-id=rock5b-openfyde --ozone-nnpalm-properties={} --arc-availability=installed --enterprise-enrollment-initial-modulus=15 --enterprise-enrollment-modulus-limit=19 --enable-crashpad --ml_service=enabled --ondevice_handwriting=use_rootfs --ondevice_document_scanner=use_rootfs --arc-start-mode=always-start-with-no-play-store --arc-availability=officially-supported --disable-features=ArcAndGuestOsFileTasksUseAppService,CrostiniUseDlc --disable-buffer-bw-compression --login-manager --feature-flags=["arc-game-mode@1","full-user-agent@1","ignore-gpu-blocklist","launcher-game-search@1","use-passthrough-command-decoder@1"] --first-exec-after-boot --enable-features=Pepper3DImageChromium,UmaStorageDimensions,Crostini,CrostiniGpuSupport,SmartDim --disable-features=ArcAndGuestOsFileTasksUseAppService,CrostiniUseDlc --flag-switches-begin --ignore-gpu-blocklist --enable-features=Pepper3DImageChromium,UmaStorageDimensions,Crostini,CrostiniGpuSupport,SmartDim,ArcGameModeFeature,DefaultPassthroughCommandDecoder,FullUserAgent,LauncherGameSearch --flag-switches-end --user-agent="Mozilla/5.0 (X11; Linux aarch64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36"
🖱️Firefox Browser:🖱️

Firefox Browser

sudo nala install firefox-esr
🖱️Thorium Browser:🖱️

Thorium Browser

wget https://dl.thorium.rocks/debian/dists/stable/thorium.list
sudo mv thorium.list /etc/apt/sources.list.d/
sudo apt update
sudo apt install thorium-browser

Keep in mind that these browsers will be best installed via flatpak to run with hardware acceleration and you will only see those which are compatible with your system arquitecture listed.

Install FlatHUB and grab your apps with Hardware Acceleration

sudo apt install flatpak gnome-software-plugin-flatpak -y
sudo flatpak remote-add --if-not-exists flathub https://dl.flathub.org/repo/flathub.flatpakrepo
🖱️How to uninstall flatpak:🖱️
flatpak uninstall --unused
sudo apt-get remove --autoremove flatpak
sudo apt-get purge flatpak

sudo flatpak install flathub com.heroicgameslauncher.hgl -y
(Heroic Games Launcher doesnt work on ARM64*)

Keep in mind that flathub is an store known for having apps to run with hardware acceleration and only lists those compatible with your system arquitecture.

Pretty much anything debian works on this terminal. So now I’m gonna leave here some of the classic basic apps that every linux usually comes with.

🖱️Debian / XFCE minimal desktop - Optional :🖱️

It takes long to install and you might not need them skip this step if you want:

# Basic linux apps libre office pulse audio etc etc. - Optional
sudo nala update && sudo nala install task-xfce-desktop network-manager-gnome gparted pulseaudio pavucontrol pulseaudio-module-bluetooth gvfs gvfs-backends policykit-1 udisks2 catfish mousepad xarchiver gdebi gigolo v4l2loopback-dkms gedit g++ qtbase5-dev qttools5-dev-tools libqt5svg5-dev qttools5-dev libqt5dbus5 libqt5network5 libqt5core5a libqt5widgets5 libqt5gui5 libqt5svg5 python-setuptools python3-distutils -y && sudo nala upgrade -y && sudo nala autoremove
# Utilities gits makes curls etc - Important
sudo nala update && sudo nala install xfce4-terminal lshw git openssl ca-certificates squashfs-tools gcc-arm-linux-gnueabihf libc6-dev-armhf-cross coreutils ninja-build make cmake build-essential autoconf automake autopoint gettext autotools-dev cmake curl default-jre gawk gcc g++ cpp libflatbuffers-dev  gdc gperf libasound2-dev libass-dev libavahi-client-dev libavahi-common-dev libbluetooth-dev libbluray-dev libbz2-dev libcdio-dev libcec-dev libp8-platform-dev libcrossguid-dev libcurl4-openssl-dev libcwiid-dev libdbus-1-dev libegl1-mesa-dev libenca-dev libflac-dev libfontconfig-dev libfmt-dev libfreetype6-dev libfribidi-dev libfstrcmp-dev libgcrypt20-dev libgif-dev libgles2-mesa-dev libglew-dev libglu1-mesa-dev libgnutls28-dev libgpg-error-dev libgtest-dev libiso9660-dev libjpeg-dev liblcms2-dev liblirc-dev libltdl-dev liblzo2-dev libmicrohttpd-dev libnfs-dev libogg-dev libomxil-bellagio-dev libpcre3-dev libplist-dev libpng-dev libpulse-dev libshairplay-dev libsmbclient-dev libspdlog-dev libsqlite3-dev libssl-dev libtag1-dev libtiff-dev libtinyxml-dev libtool libudev-dev libunistring-dev libva-dev libvdpau-dev libvorbis-dev libxkbcommon-dev libxmu-dev libxrandr-dev libxslt1-dev libxt-dev waylandpp-dev wayland-protocols wipe lsb-release meson nasm ninja-build python3-dev python3-pil python3-minimal rapidjson-dev swig unzip uuid-dev zip zlib1g-dev libdav1d-dev libdrm-dev ccache libclang-dev libiso9660++-dev libcap-dev clang-tools clang-tidy libpipewire-0.3-dev libsndio-dev libmariadb-dev cppcheck -y && sudo nala upgrade -y && sudo nala autoremove
# Yes it will take a while.
sudo reboot

List of Debian arm64 Packages: https://debian.pkgs.org/10/debian-main-arm64/

🖱️Install Docker.io :🖱️
curl -fsSL [https://get.docker.com](https://get.docker.com/) -o [get-docker.sh](https://get-docker.sh/) sudo sh [get-docker.sh](https://get-docker.sh/)

🖱️Install OBS (Doesnt work on ChromeOS I believe):🖱️
sudo nala install xcb obs-studio obs-gstreamer obs-plugins xdg-desktop-portal pipewire qtwayland5 -y
#RESTART here and then run OBS with:
export QT_QPA_PLATFORM="xcb"
#--this is the way it works on armbian not sure if needs changed for FydeOS

🖱️Useful applications on Linux:🖱️

More useful applications on Linux:

sudo nala install htop -y
sudo nala install bpytop -y
sudo nala install neofetch -y
sudo nala install screenfetch -y
sudo nala install snapd -y
sudo nala install kodi -y
sudo nala install inkscape -y
sudo nala install flatpak gnome-software-plugin-flatpak squashfs-tools && sudo flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
sudo nala install gnome-software gnome-packagekit -y
sudo nala install gedit -y #allows you to edit and save .vim 'documents'
#example gedit bashrc

# or all at once and correctly
sudo nala update && sudo nala install gedit htop neofetch bpytop snapd flatpak xcb obs-studio obs-plugins xdg-desktop-portal pipewire qtwayland5 gnome-software-plugin-flatpak squashfs-tools gnome-software gnome-packagekit kodi inkscape -y && sudo flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo && sudo nala upgrade -y &&

sudo reboot

Always make sure your terminal has internet by doing sudo ping google.com and Ctrl C to stop at each reboot before typing instructions.

[Guide] Getting Steam Installed on ARM64 devices

[Guide] Getting Steam Borealis on Intel or Amd devices (Gamepad Works)

[Guide] Adding other Containers to your Crostini

[Customization Guide] FydeOS - Material You Options

[Guide] Getting ChromeBrew Hack Working

Enable LaCros for Cloud Gaming and Widevine content!

LaCros becomes a perfect alternative to Chromium Browser with all of Chrome features just turn these on chrome://flags and get os://flags from #lacros-only

Plan B (In case LaCros support ends the best solution I have found):

🖱️Install Flathub Debian Browser:🖱️
sudo apt install flatpak gnome-software-plugin-flatpak -y
sudo flatpak remote-add --if-not-exists flathub https://dl.flathub.org/repo/flathub.flatpakrepo
sudo flatpak install flathub org.chromium.Chromium -y
sudo flatpak update -y

FlatHub Debian Browser: flatpak run org.chromium.Chromium
Access: https://play.geforcenow.com/mall/#/layout/games

🖱️How to fix the flatpak app invisible cursor:🖱️

On System, go to “Settings” → “Accessibility” → “Manage accessibility features” → “Mouse and touchpad.”
Toggle on “Highlight the mouse cursor when it’s moving”.

🖱️How to uninstall flatpak:🖱️
flatpak uninstall --unused
sudo apt-get remove --autoremove flatpak
sudo apt-get purge flatpak

Best tip to keep image steady without pixelation is to cut the gimmick crap by setting it to 30 FPS without Auto Adjust for Poor Network Conditions.

#Custom parameters just in case:
--user-agent="Mozilla/5.0 (X11; Linux aarch64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36" --accept-lang=en-US

You can now enjoy playing games on Geforce now with an huge quality like a champ! Finally.

  • Gamepad support works on Chromium Browser! (Works great on geforce now and Boosteroid)

Play Boosteroid too!


Play AntStream Arcade Classic Games !

Terminal Troubleshoot

Sometimes when the linux terminal jams a sudo reboot/poweroff or a Crosh vmc stop/start termina fixes it.

  • sudo ping google.com doesn’t work or… wierd launch error messages… etc…
#Open Chromium Browser - Ctrl Alt T
vmc stop termina
vmc start termina or vmc launch termina #ChromeOS is start FydeOS is Launch

#Some screen glitching can be fixed with this:
systemctl --user restart sommelier{,-x}@{0,1}.service

BlueStacks Cloud Games and Now.gg on Cloud for Android Games !

On now.gg you can run the aptoide app which allows you to play even more android apps and games via webapp.

Fan of Retro and Old Classic Games?! Try My Emulator Online

Installing the Google Store is easy!

Run GApps installation stucks at 20% for a long while but you can see the log showing information rolling.

🖱️Reported issues:🖱️

Follow some of the community issues as well here

Have lots of fun enjoy! Discord here for a more direct approach: https://discord.gg/3XAKWFRwrG

🖱️Other Sources:🖱️


there is also a site onlyfans for bad os

Not very different from your Android OS at least it cames with browser for your nasty tastes…

lol sure you didnt look right :rofl:

I just spent the better part of a day setting this up… Dolphin wont launch… gg openFyde


Yeah I was trying the android version, gamecube doesnt run well on Linux unfortunately



1 Like

Nice work, I honestly dont like RetroArch, its needlessly difficult to setup. As for dolphin, it just runs significantly faster on android in general than linux on arm. Wayland support is the dream


I have compiled RetroArch form source too for the board.


Widevine-flash installation // Couldn’t make it work! if someone care to help I’d appreaciate it

1. Close any opened Vivaldi Browser
2. Open xfce terminal and download the script that fetches a ChromeOS image and extracts the Widevine and Flash
***ARMv7 (armhf / 32-bit)***
git clone https://gist.github.com/e025024ecffa45ee4325a3915fd8dad1.git widevine-flash
cd widevine-flash
sudo sh ./widevine-flash_arm32.sh
***ARMv8 (arm64 / 64-bit)***
wget https://gist.githubusercontent.com/vyn20/7e1e1c313843d6a8180cfc1f47bee6aa/raw/8b27566580d3a8f5bf0084ec0f4f9ddef95b3171/widevine-flash_arm64.sh
sudo sh ./widevine-flash_arm64.sh 
***(and follow the instructions)***
tar zxvf widevine-flash-20230317_armhf.tgz
mkdir -p ~/.config/vivaldi/WidevineCdm
echo '{"Path":"/opt/WidevineCdm"}' > ~/.config/vivaldi/WidevineCdm/latest-component-updated-widevine-cdm
3. Open Vivaldi with the DRM browser launcher and check if DRM is working

Do you end up with working GPU drivers for Linux applications and Android ones?

It all works perfect. Give it a try and join discord.

I decided to test openFyde. When I switch from Debian to Ubuntu 22.04:

  1. it’s better to run lxc rename penguin debian instead of lxc rename penguin ubuntu
  2. tar f data.tar --delete ./etc/gtk-3.0/settings.ini did not work, but
    tar f data.tar --delete etc/gtk-3.0/settings.ini works fine:
root@penguin:~# tar f data.tar --delete ./etc/gtk-3.0/settings.ini
tar: ./etc/gtk-3.0/settings.ini: Not found in archive
tar: Exiting with failure status due to previous errors
root@penguin:~# tar f data.tar --delete etc/gtk-3.0/settings.ini
root@penguin:~# tar ft data.tar

Cool! I had given up on ubuntu have u tried debian sid? Works just fine like magic! Specially with nala.
Edit: @q4a did the rest worked? Do you wanna come discord to chat about it?

I would prefer to use ubuntu instead… of debian.

I like this. Best of both worls
just one problem. Can’t get the fan running
Followed the instructions a couple of time by copying the correct file and restart.
The file in /etc/fan-control.json does not exist after restart.The log file messages has lots of NOICE Temp_logger messages

I assume you are trying to use the FydeOS version right? follow my steps one by one it works. The fan behaviour is not perfect yet but they will fix it soon.

I followed the fydeos instructions this time and these are the messages I get in dmesg:
[ 0.538057] pwm-fan pwm-fan: Looking up fan-supply from device tree
[ 0.538062] pwm-fan pwm-fan: Looking up fan-supply property in node /pwm-fan failed
[ 0.538703] rockchip-thermal fec00000.tsadc: Missing rockchip,grf property
[ 0.539175] rockchip-thermal fec00000.tsadc: tsadc is probed successfully!

Any ideas

A little too fast on the gun… even though I get the previous error the fan has started running