[Guide] FydeOS & openFyde - Rock 5B - the best option


For me openFyde/FydeOS is the best operative system to have on a single board computer like this one so hail to FydeOS to be with Radxa ROCK 5B.


Installation process is quite basic since this last update you can pretty much run it from any microSD so just go to openFyde/FydeOS Rock 5B github grab the .img file from them and RPi imager or Balena flash it to your SD.


FydeOS for you Rock 5B

openFyde for Rock 5B

Just choose the version you prefer the most. You can now complete the full installation to your nvme directly and carry on!


Crosh Container - Gentoo Linux


Please follow the guide https://faq.fydeos.com/en/getting-started/shell-access/ to enter the shell and be root. (Open Chromium - Ctrl Alt T - Type Shell type sudo -i) Do line by line don’t copy paste it all.
https://fydeos.io/docs/knowledge-base/recipes/enable-pwm-fan-on-rock-5b/

Fan Control / Options:

Turn off type: echo power_allocator > /sys/class/thermal/thermal_zone0/policy
Turn on type: echo step_wise > /sys/class/thermal/thermal_zone0/policy
Nonstop type: echo fair_share > /sys/class/thermal/thermal_zone0/policy

mount -o remount,rw /
sudo nano /etc/init/rock5-fan-control.conf
#find the line and update to fair_share

  echo fair_share > /sys/class/thermal/thermal_zone0/policy

Then press Ctrl+X, save Y  then sudo reboot and exit

To enable bluetooth on some modules for openFyde/FydeOS:

mount -o remount,rw /
nano /etc/modprobe.d/blacklist.conf
-- then add these lines somewhere (at the bottom of the file is fine):
blacklist pgdrv
blacklist btusb
blacklist btrtl
blacklist btbcm
#blacklist btintel
Then press Ctrl+X, save Y  then sudo reboot and exit

Overlays and Perks
To activate FydeOS extras for your board check all information available here: https://fydeos.io/docs/knowledge-base/recipes/RK3588-soc-how-to-use-device-tree-overlay/
Type: ls /boot/rockchip/overlay/


If you want to activate Radxa Display or Camera or any other just add that overlay to the following:

mount -o remount,rw /
sudo nano /mnt/stateful_partition/fyde/Env.txt
overlays=pwm-fan 
Then press Ctrl+X, save Y  then sudo reboot and exit

Android Container - Arch Hero


:tropical_drink::beer: From OpenFyde version 108 We have Project ArcHero activated which mean that we can Install .apks Hurray! :raised_hands:


Now the good stuff about openFyde/FydeOS is that with ArcHero Android container we can play big time games from the app store:

  • Install apkpure, aptoide, uptodown, aurora store any store you like.
  • Install some some apks, xapk, apkm intallers like App Mirror, XAPK Installer, APK Installer.
    For big titles these installers are required. For general purpose… apkpure is literally enough for most things.

The fun of being able to play this is amazing.

(dont mind the video stuttering its just that… the video recording doesn’t do its justice it runs smooth).

That’s it all android issues resolved. You can now enjoy your hearthstone, diablo immortal, call of duty mobile etc… etc.

There is however only one last thing missing for perfection but not even google ChromeOS made this work yet:

  • There is no gamepad support yet for the Android container yet.
    #arc-input-overlay-beta - can be turned on chrome://flags but what games supports it?

  • We have now gamepad support for Chromium Browser! (Works great on geforce now!)

Linux Container - There’s a few perks I wanna share here too!



Give the Penguin Crostini a NALA boost! - Activate the Linux on the system and do the following:

#Lets start by giving our terminal a boost with nala the apt replacement!
sudo apt update && sudo apt install git make python3-pip python3-apt python3-debian pandoc -y 
git clone https://gitlab.com/volian/nala.git
cd nala
sudo make install
sudo nala update && sudo nala upgrade -y
cd
#It will take forever after you finish make a linux backup nala will make installations way better

After this dont do sudo apt install anymore do sudo nala install instead ex: sudo nala install neofetch. The terminal behaviour will not just be pretty but it will do more tasks and correct issues as well giving you better debug feedback.


How to enable Widevine:

  1. Obtain the necessary Windevine files for the appropriate architecture (arm64 in this case) from your preferred place/vendor. If you cannot find this, you may try this one: https://github.com/theofficialgman/testing/releases/download/gmans-releases/WidevineCdm.tar.gz
  2. Uncompress the file (if necessary) and obtain the file libwidevinecdm.so.
    Move the file from the folder Downloads to Linux Files and with Linux do:
    tar -xf WidevineCdm.tar.gz
  3. Navigate to “Settings” -> “openFyde Settings”, and find the option to “Enable Widevine”, and choose the file libwidevinecdm.so from the uncompressed folder.
  4. Reboot.

EnjOY Netflix via Chromium browser now.


Pretty much anything debian works on this terminal. So now I’m gonna leave here some of the classic basic apps that every linux usually comes with.

Debian / XFCE minimal desktop - Optional stuff

It takes long to install and you might not need them skip this step if you want:

# Basic linux apps libre office pulse audio etc etc. - Optional
sudo nala update && sudo nala install task-xfce-desktop network-manager-gnome gparted pulseaudio pavucontrol pulseaudio-module-bluetooth gvfs gvfs-backends policykit-1 udisks2 catfish mousepad xarchiver gdebi gigolo v4l2loopback-dkms gedit g++ qtbase5-dev qttools5-dev-tools libqt5svg5-dev qttools5-dev libqt5dbus5 libqt5network5 libqt5core5a libqt5widgets5 libqt5gui5 libqt5svg5 python-setuptools python3-distutils -y && sudo nala upgrade -y && sudo nala autoremove
# Utilities gits makes curls etc - Important
sudo nala update && sudo nala install xfce4-terminal lshw git openssl ca-certificates squashfs-tools gcc-arm-linux-gnueabihf libc6-dev-armhf-cross coreutils ninja-build make cmake build-essential autoconf automake autopoint gettext autotools-dev cmake curl default-jre gawk gcc g++ cpp libflatbuffers-dev  gdc gperf libasound2-dev libass-dev libavahi-client-dev libavahi-common-dev libbluetooth-dev libbluray-dev libbz2-dev libcdio-dev libcec-dev libp8-platform-dev libcrossguid-dev libcurl4-openssl-dev libcwiid-dev libdbus-1-dev libegl1-mesa-dev libenca-dev libflac-dev libfontconfig-dev libfmt-dev libfreetype6-dev libfribidi-dev libfstrcmp-dev libgcrypt20-dev libgif-dev libgles2-mesa-dev libglew-dev libglu1-mesa-dev libgnutls28-dev libgpg-error-dev libgtest-dev libiso9660-dev libjpeg-dev liblcms2-dev liblirc-dev libltdl-dev liblzo2-dev libmicrohttpd-dev libnfs-dev libogg-dev libomxil-bellagio-dev libpcre3-dev libplist-dev libpng-dev libpulse-dev libshairplay-dev libsmbclient-dev libspdlog-dev libsqlite3-dev libssl-dev libtag1-dev libtiff-dev libtinyxml-dev libtool libudev-dev libunistring-dev libva-dev libvdpau-dev libvorbis-dev libxkbcommon-dev libxmu-dev libxrandr-dev libxslt1-dev libxt-dev waylandpp-dev wayland-protocols wipe lsb-release meson nasm ninja-build python3-dev python3-pil python3-minimal rapidjson-dev swig unzip uuid-dev zip zlib1g-dev libdav1d-dev libdrm-dev ccache libclang-dev libiso9660++-dev libcap-dev clang-tools clang-tidy libpipewire-0.3-dev libsndio-dev libmariadb-dev cppcheck -y && sudo nala upgrade -y && sudo nala autoremove
# Yes it will take a while.
sudo reboot
exit

Replacing the penguin terminal from Debian with ArchLinux:

https://fydeos.io/docs/knowledge-base/linux-subsystem/archlinux


Cloud Gaming via Chromium Browser user-Agents bypass on GFN!

Since geforce now blocks chromium from using the service I’ve found an solution for this:


What it does it creates a second browser with clean parameters and apparently GFN doesn’t flags it.

#Custom parameters just in case:
--user-agent="Mozilla/5.0 (X11; Linux aarch64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/110.0.0.0 Safari/537.36" --accept-lang=en-US

You can now enjoy playing games on Geforce now with an huge quality on this tiny single board computer like a champ! Finally.


Play Boosteroid too!

20230614_224149
Diablo 4 on boosteroid ? Hell Yeah Boy!


Steam Installation Guide

image

Always make sure your terminal has internet by doing sudo ping google.com and Ctrl C to stop at each reboot before typing instructions.


More useful stuff on Linux:

#--OBS--
sudo nala install xcb obs-studio obs-gstreamer obs-plugins xdg-desktop-portal pipewire qtwayland5 -y
#RESTART here and then run OBS with:
export QT_QPA_PLATFORM="xcb"
MESA_GL_VERSION_OVERRIDE=3.3 MESA_GLSL_VERSION_OVERRIDE=330 obs
#--this is the way it works on armbian not sure if needs changed for FydeOS

sudo nala install htop -y
sudo nala install bpytop -y
sudo nala install neofetch -y
sudo nala install snapd -y
sudo nala install kodi -y
sudo nala install inkscape -y
sudo nala install flatpak gnome-software-plugin-flatpak squashfs-tools && sudo flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
sudo nala install gnome-software gnome-packagekit -y

# or all at once and correctly
sudo nala update && sudo nala install htop neofetch bpytop snapd flatpak xcb obs-studio obs-plugins xdg-desktop-portal pipewire qtwayland5 gnome-software-plugin-flatpak squashfs-tools gnome-software gnome-packagekit kodi inkscape -y && sudo flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo && sudo nala upgrade -y && sudo nala autoremove
sudo reboot
exit

Terminal Troubleshoot

Sometimes when the linux terminal jams a sudo reboot or a father stop start termina fixes it.

  • sudo ping google.com doesn’t work or… wierd launch error messages… etc…
#Open Chromium Browser - Ctrl Alt T
vmc stop termina
vmc start termina or vmc launch termina #ChromeOS is start FydeOS is Launch


Installing the Google Store is easy!

image
Run GApps installation stucks at 20% for a long while but you can see the log showing information rolling.


List of Debian Packages: https://debian.pkgs.org/10/debian-main-arm64/
Make pages into webapps: applicationize.me/now


Follow some of the community issues as well here


Have lots of fun enjoy! Discord here for a more direct approach: https://discord.gg/vX4UhRPT9A

3 Likes

Vivaldi Browser


Install Vivaldi for Geforce Now and (Widevine DRM for Netflix couldn’t make it work if someone can please let me know.).

Vivaldi browser installation

  1. Download Vivaldi .deb here https://vivaldi.com/download/archive/?platform=linux
  2. Open GDebi and install your specific Vivaldi browser

Create a desktop launcher (‘Needed’ for GeForce Now and Widevine)

  • Info: This allows you to add browser start up lines to provide better performance. To let pages know you are at the latest version.
  • Command:
    /usr/bin/vivaldi-stable --disable-seccomp-filter-sandbox --user-agent="Mozilla/5.0 (X11; Linux aarch64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/110.0.0.0 Safari/537.36"

Same as openFyde Chromium for testing (Might improve performance- optional)

/usr/bin/vivaldi-stable --disable-seccomp-filter-sandbox --edge-touch-filtering --enable-native-gpu-memory-buffers --platform-disallows-chromeos-direct-video-decoder --enable-webgl-image-chromium --enable-features=Pepper3DImageChromium,UmaStorageDimensions,Crostini,CrostiniGpuSupport,SmartDim --num-raster-threads=2 --gpu-sandbox-failures-fatal=no --passive-listeners-default=true --enable-logging --log-level=1 --use-cras --enable-wayland-server --system-developer-mode --disable-mojo-broker --ash-use-cros-mojo-service-manager --cros-healthd-uses-service-manager --allow-os-install --login-profile=user --has-chromeos-keyboard --enable-touchview --disable-explicit-dma-fences --guest-wallpaper-large=/usr/share/chromeos-assets/wallpaper/guest_large.jpg --guest-wallpaper-small=/usr/share/chromeos-assets/wallpaper/guest_small.jpg --child-wallpaper-large=/usr/share/chromeos-assets/wallpaper/child_large.jpg --child-wallpaper-small=/usr/share/chromeos-assets/wallpaper/child_small.jpg --default-wallpaper-large=/usr/share/chromeos-assets/wallpaper/default_large.jpg --default-wallpaper-small=/usr/share/chromeos-assets/wallpaper/default_small.jpg --enable-consumer-kiosk --device-help-content-id=rock5b-openfyde --ozone-nnpalm-properties={} --arc-availability=installed --enterprise-enrollment-initial-modulus=15 --enterprise-enrollment-modulus-limit=19 --enable-crashpad --ml_service=enabled --ondevice_handwriting=use_rootfs --ondevice_document_scanner=use_rootfs --arc-start-mode=always-start-with-no-play-store --arc-availability=officially-supported --disable-features=ArcAndGuestOsFileTasksUseAppService,CrostiniUseDlc --disable-buffer-bw-compression --login-manager --feature-flags=["arc-game-mode@1","full-user-agent@1","ignore-gpu-blocklist","launcher-game-search@1","use-passthrough-command-decoder@1"] --first-exec-after-boot --enable-features=Pepper3DImageChromium,UmaStorageDimensions,Crostini,CrostiniGpuSupport,SmartDim --disable-features=ArcAndGuestOsFileTasksUseAppService,CrostiniUseDlc --flag-switches-begin --ignore-gpu-blocklist --enable-features=Pepper3DImageChromium,UmaStorageDimensions,Crostini,CrostiniGpuSupport,SmartDim,ArcGameModeFeature,DefaultPassthroughCommandDecoder,FullUserAgent,LauncherGameSearch --flag-switches-end --user-agent="Mozilla/5.0 (X11; Linux aarch64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/110.0.0.0 Safari/537.36"

Set the latest user agent or just your actual one: https://whatmyuseragent.com

Open Vivaldi with the DRM browser launcher and verify the parameters …

  • flags: vivaldi://flags Override software rendering list > Enable (Do it for performance!)
  • components: vivaldi://components (check if Widevine Content Decryption Module is loaded)
  • gpu: vivaldi://gpu

  • Just a side note about Mouse Cursor on Cloud Gaming on Vivaldi:
    All types of mouse issues will trigger you press Esc or Ctrl G the way to fix this is to keep pressing Esc a few seconds and going back into full screen mouse will go back into the game layout.

(Video recording over Linux apps really doesn’t do its justice this runs perfectly fine.)


Browser from a Docker Container with DRM

Found a solution for Widevine DRM to work which is a Chromium 32bits that also works for Cloud Gaming but via docker:

  • I personally don’t like this very much… but it’s somewhat a better alternative to DRM.
  • chrome://settings/ is bugged.
  • You can watch netflix with it and other pages/services that requires it.
# Requires docker and it works again thank you mOnkaBlyat.
# Build this first
sudo nala install docker docker.io pulseaudio-utils pulseaudio
git clone https://github.com/monkaBlyat/docker-chromium-armhf
cd docker-chromium-armhf
sudo docker build -t hthiemann/chromium-armhf .
# stop here Make a volume for settings to be saved
sudo docker volume create chromium_home
# Stop here Start image
sudo docker pull hthiemann/docker-chromium-armhf
sudo cp chromium-armhf /usr/local/bin
sudo usermod -aG docker $(whoami)
chromium-armhf
# Stop here - Bring it to life
sudo chromium-armhf

Brave Browser

Brave Browser Install # No DRM fun and neither is supported by GFN but for the fans its this:

sudo nala install curl build-essential python-setuptools python3-distutils
sudo curl -fsSLo /usr/share/keyrings/brave-browser-archive-keyring.gpg https://brave-browser-apt-release.s3.brave.com/brave-browser-archive-keyring.gpg
echo "deb [signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg] https://brave-browser-apt-release.s3.brave.com/ stable main"|sudo tee /etc/apt/sources.list.d/brave-browser-release.list
sudo nala update
sudo nala install brave-browser
# in case to uninstall
sudo nala remove brave-browser brave-keyring
sudo rm /etc/apt/sources.list.d/brave-browser-*.list

Debian Browser - no netflix fun, geforce now is supported but doesn’t work / kinda broken.

sudo nala install chromium chromium-l10n # Debian Chromium
/usr/lib/chromium/chromium --edge-touch-filtering --enable-native-gpu-memory-buffers --platform-disallows-chromeos-direct-video-decoder --enable-webgl-image-chromium --enable-features=Pepper3DImageChromium,UmaStorageDimensions,Crostini,CrostiniGpuSupport,SmartDim --num-raster-threads=2 --gpu-sandbox-failures-fatal=no --passive-listeners-default=true --enable-logging --log-level=1 --use-cras --enable-wayland-server --system-developer-mode --disable-mojo-broker --ash-use-cros-mojo-service-manager --cros-healthd-uses-service-manager --allow-os-install --login-profile=user --has-chromeos-keyboard --enable-touchview --disable-explicit-dma-fences --guest-wallpaper-large=/usr/share/chromeos-assets/wallpaper/guest_large.jpg --guest-wallpaper-small=/usr/share/chromeos-assets/wallpaper/guest_small.jpg --child-wallpaper-large=/usr/share/chromeos-assets/wallpaper/child_large.jpg --child-wallpaper-small=/usr/share/chromeos-assets/wallpaper/child_small.jpg --default-wallpaper-large=/usr/share/chromeos-assets/wallpaper/default_large.jpg --default-wallpaper-small=/usr/share/chromeos-assets/wallpaper/default_small.jpg --enable-consumer-kiosk --device-help-content-id=rock5b-openfyde --ozone-nnpalm-properties={} --arc-availability=installed --enterprise-enrollment-initial-modulus=15 --enterprise-enrollment-modulus-limit=19 --enable-crashpad --ml_service=enabled --ondevice_handwriting=use_rootfs --ondevice_document_scanner=use_rootfs --arc-start-mode=always-start-with-no-play-store --arc-availability=officially-supported --disable-features=ArcAndGuestOsFileTasksUseAppService,CrostiniUseDlc --disable-buffer-bw-compression --login-manager --feature-flags=["arc-game-mode@1","full-user-agent@1","ignore-gpu-blocklist","launcher-game-search@1","use-passthrough-command-decoder@1"] --first-exec-after-boot --enable-features=Pepper3DImageChromium,UmaStorageDimensions,Crostini,CrostiniGpuSupport,SmartDim --disable-features=ArcAndGuestOsFileTasksUseAppService,CrostiniUseDlc --flag-switches-begin --ignore-gpu-blocklist --enable-features=Pepper3DImageChromium,UmaStorageDimensions,Crostini,CrostiniGpuSupport,SmartDim,ArcGameModeFeature,DefaultPassthroughCommandDecoder,FullUserAgent,LauncherGameSearch --flag-switches-end --user-agent="Mozilla/5.0 (X11; Linux aarch64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/110.0.0.0 Safari/537.36"

Firefox Browser

sudo nala install firefox-esr
2 Likes

Steps to Install ArchLinux Crostini on FydeOS :white_check_mark: :point_left:

  1. Start Termina
  • Press Ctrl+Alt+T to open the crosh terminal.
  • Type vsh termina.
  • If you see (termina) chronos@localhost ~ $, it means that Termina has started successfully.

Set Up the Arch Container

  • Run the command below to install the ArchLinux container:
#This installs archlinux into LXC container
lxc launch images:archlinux/current archlinux
lxc list
#lxc start archlinux
#Enter the command below to access the ArchLinux shell:
lxc exec archlinux -- bash

#set username and password and group
useradd -m your_username
passwd your_username
#just use the same user/pass

#Install basic dependencies
pacman -Syu base-devel git gtk3 openssh xdg-utils xkeyboard-config

#Turn Off Administrator Password Since we plan to launch Arch from the OS terminal application, we need to disable the administrator password.
visudo
#Find #%wheel ALL=(ALL:ALL) NOPASSWD: ALL and remove the #
:wq #to exit
enter

usermod -aG wheel your_username

exit # leave the container
lxc console arch
#Press enter and type your username and password

Optional: Update pacman config. Prefer to:

– uncomment [#Color]
– uncomment [#VerbosePkgLists]
– uncomment [#ParallelDownloads] = 3
Type: sudo nano /etc/pacman.conf and uncomment
:wq
enter
#Check the network by running (can't be empty)
ip -4 a show dev eth0
#if no connection
sudo dhcpcd eth0
sudo pacman -S dhclient
sudo systemctl disable systemd-networkd
sudo systemctl disable systemd-resolved
sudo unlink /etc/resolv.conf
sudo touch /etc/resolv.conf
sudo systemctl enable dhclient@eth0
sudo systemctl start dhclient@eth0

Install cros-container-guest-tools-git and Wayland

pacman -Syu base-devel git curl make neovim wl-clipboard fish base-devel pacman-contrib wayland xorg-xwayland devtools dhclient neofetch

sudo git clone https://aur.archlinux.org/yay-git.git
sudo chown -R your_username:your_password ./yay-git
cd yay-git
makepkg -si

sudo su # or sudo -i
yay -Sy cros-container-guest-tools-git 
#select using numbers
sudo reboot

Rename the actual container penguin to debian and YOURS to penguin

lxc stop --force archlinux
lxc stop --force penguin
lxc rename penguin debian
lxc rename arch penguin
lxc stop --force archlinux

Now into Crostini just boot up your Archlinux penguin and if it fail do it again.

Add an extra crostini container sommalier:


After creating it just have fun renaming at Crosh to Crostini et Voilá Sudo Pacman Treé Jolie.

You can switch it to ArchLinux https://fydeos.io/docs/knowledge-base/linux-subsystem/archlinux/
Debian to Arch: https://shibumi.dev/posts/install-arch-linux-on-chromeos/



Crostini Ubuntu Penguin :white_check_mark: :point_left: WORKS!

For safety first keep the original Crostini debian penguin unchanged and just enable the #crostini-multi-container flag!

Start the terminal and grant you have access to the internet by doing sudo ping google.com if no return - then: Shut Down Crostini.

if not then again repeat shut down and start crostini.

Open Crosh and lets make the LXC Ubuntu Container:

vsh termina # vmc stop termina / vmc launch termina
lxc list
# Clone your ubuntu container 
lxc launch images:ubuntu/jammy 'your_container'
lxc exec 'your_container' -- bash
exit
#Container created! Ubuntu ready.

Install some basic stuff - Optional but I do recommend it :smiling_imp:

sudo apt update && sudo apt install git make python3-pip python3-apt python3-debian pandoc neofetch adwaita-icon-theme-full -y 
git clone https://gitlab.com/volian/nala.git
cd nala
sudo make install
sudo nala update && sudo nala upgrade -y
cd
neofetch

Thats you on Ubuntu via Crosh. Now… the complicated part… which is the Google cros-ui-config.

#sudo rm /etc/apt/sources.list.d/cros.list** to clear anything not google/fydeos/etc.
#add fyde or google package
echo "deb https://deb-mirror.fydeos.com/cros-packages bullseye main" > /etc/apt/sources.list.d/cros.list
if [ -f /dev/.cros_milestone ]; then sudo sed -i "s?packages?packages/$(cat /dev/.cros_milestone)?" /etc/apt/sources.list.d/cros.list; fi
#keys for ubuntu
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1397BC53640DB551
#ChromeOS Required stuff so ubuntu linux works in ChromiumOS/FydeOS/ChromeOS
sudo apt update && sudo nala install cros-garcon cros-host-fonts cros-notificationd cros-sftp cros-sommelier -y && sudo nala upgrade -y
sudo nala install cros-ui-config -y #ignore errors
sudo nala update && sudo nala upgrade -y #this will fix them
#All done here! Lets implement this into Crostini now.
shutdown -h now
#you gotta use your brain here a bit..
lxc stop 'your_container'
lxc rename penguin 'something_else' #to switch by the actual one
lxc rename ubuntu penguin #that is if you only want 1 crostini penguin container instead of the debian.
#lxc stop ubuntu that is if u only created an named ubuntu lxc container and crostini
exit
exit

Go to your Crostini Terminal open Ubuntu it wil likely fail the first time so force its opening a few times and remember to check if it has connection once open. (What it does… it tries to establish the sommelier connections to the lxc container and it kinda… fails easily).


Crostini Vibes Enable and Become an LXC Expert:


Turn on the flag for multiple containers.
Go to settings and add another container with a random name it will automatically create it with your ip.

Google Tools required: https://chromium.googlesource.com/chromiumos/containers/cros-container-guest-tools/+/master/cros-guest-tools/BUILD

More info: https://linuxiumcomau.blogspot.com/2018/08/introduction-to-crostini-part-3-using.html
Alternative solution: https://github.com/jcdang/chromeos-ubuntu-sommelier
Extra info: https://blog.csdn.net/qq_37401091/article/details/127460700
Debian to Ubuntu Crostini: https://www.reddit.com/r/Crostini/wiki/howto/run-ubuntu/#wiki_install_crostini_packages
Very Good info: http://intertwingly.net/blog/2020/07/21/Ubuntu-20-04-on-Chromebook

there is also a site onlyfans for bad os

Not very different from your Android OS at least it cames with browser for your nasty tastes…

lol sure you didnt look right :rofl:

I just spent the better part of a day setting this up… Dolphin wont launch… gg openFyde

1 Like

Probably the linux version wont… what about the android version? Oh yes gamepad support is being added wont help you either for now.

I havent tried this yet but its interesting:

Replacing Debian with ArchLinux.
https://fydeos.io/docs/knowledge-base/linux-subsystem/archlinux

Yeah I was trying the android version, gamecube doesnt run well on Linux unfortunately

1 Like

07

Nice work, I honestly dont like RetroArch, its needlessly difficult to setup. As for dolphin, it just runs significantly faster on android in general than linux on arm. Wayland support is the dream

1 Like

I have compiled RetroArch form source too for the board.

1 Like

Widevine-flash installation // Couldn’t make it work! if someone care to help I’d appreaciate it

1. Close any opened Vivaldi Browser
2. Open xfce terminal and download the script that fetches a ChromeOS image and extracts the Widevine and Flash
***ARMv7 (armhf / 32-bit)***
git clone https://gist.github.com/e025024ecffa45ee4325a3915fd8dad1.git widevine-flash
cd widevine-flash
sudo sh ./widevine-flash_arm32.sh
***ARMv8 (arm64 / 64-bit)***
wget https://gist.githubusercontent.com/vyn20/7e1e1c313843d6a8180cfc1f47bee6aa/raw/8b27566580d3a8f5bf0084ec0f4f9ddef95b3171/widevine-flash_arm64.sh
sudo sh ./widevine-flash_arm64.sh 
***(and follow the instructions)***
tar zxvf widevine-flash-20230317_armhf.tgz
mkdir -p ~/.config/vivaldi/WidevineCdm
echo '{"Path":"/opt/WidevineCdm"}' > ~/.config/vivaldi/WidevineCdm/latest-component-updated-widevine-cdm
3. Open Vivaldi with the DRM browser launcher and check if DRM is working
https://bitmovin.com/demos/drm

Do you end up with working GPU drivers for Linux applications and Android ones?

It all works perfect. Give it a try and join discord.

I decided to test openFyde. When I switch from Debian to Ubuntu 22.04:

  1. it’s better to run lxc rename penguin debian instead of lxc rename penguin ubuntu
  2. tar f data.tar --delete ./etc/gtk-3.0/settings.ini did not work, but
    tar f data.tar --delete etc/gtk-3.0/settings.ini works fine:
root@penguin:~# tar f data.tar --delete ./etc/gtk-3.0/settings.ini
tar: ./etc/gtk-3.0/settings.ini: Not found in archive
tar: Exiting with failure status due to previous errors
root@penguin:~# tar f data.tar --delete etc/gtk-3.0/settings.ini
root@penguin:~# tar ft data.tar
etc/
etc/dconf/
etc/dconf/db/
etc/dconf/db/local.d/
etc/dconf/db/local.d/01-cros-ui
etc/dconf/profile/
etc/dconf/profile/user
etc/gtk-2.0/
etc/gtk-2.0/gtkrc
etc/gtk-3.0/
etc/xdg/
etc/xdg/Trolltech.conf

Cool! I had given up on ubuntu have u tried debian sid? Works just fine like magic! Specially with nala.
Edit: @q4a did the rest worked? Do you wanna come discord to chat about it?

I would prefer to use ubuntu instead… of debian.

I like this. Best of both worls
just one problem. Can’t get the fan running
Followed the instructions a couple of time by copying the correct file and restart.
The file in /etc/fan-control.json does not exist after restart.The log file messages has lots of NOICE Temp_logger messages