Armbian not booting

Hello guys! I got Rock Pi 4B v1.4 since half a year… I instaled on my Rokck Pi several systems like Debian, Android or Ubuntu. Every time I want change system to my Rock Pi I upload chosen image in my komputer with Windows 10 and upload do sdcard. I do it use Balena Etcher. Never I not haeve problems until now. I upload image Armbian from orginal Armbian download side. I upload Armbian Bionic or Buster. I decompress 7zip file to new folder and still used Balena Etcher uplading this img file to my SD card. This card I insert into Rock Pi and connect power. More minutes I waiting and monitor is black. Cad is good bicose I uplad diffrent system, it starting. Whot I do wrong ?

Do you have eMMC or SPI on this board?

Images are tested.

I use SPI and images was checked from Balena Etcher.

Your SPI loader is most likely too old and needs updating.

Thank you from sugestion, I shall try.

So i tryed this:

  1. I instaled on Oracle VM ver 5.2.8 Debian GNU/Linux 10 (buster) from
  2. Next I install extentions to Oracle beceause USB not working.
  3. I use instruction from Redoxa wiki
    Every thing to 2 Step was correct. When i connect usb to VM I have error

I very frustrate more of time I try instaled newer Armbian this is horrible.

Have you read the second forum topic?? You have more then one variants to sort out this problem.

Edit: most important information - how to deal with this problem - is written on our download pages for weeks. Its less complicated than Radxa manual:

Do you mean this

I haven’t tried that yet, mayby is my mistake i used wrong method. Sometimes i’m to speedy to do success. Tomorow i shall try next method.

Hi guys! Several day trials and small succes. Armbian was startet in my Rock Pi 4B. It is more ways to success but not any was good. Good way for my was method from. I use only different ambrian image. I used newer 20… Now is only small problem. I had the same problemin in one android. About 10 minut from strat system wifi is disconnect. On the screen connect is OK but Internet browser is not connect and putty disconnected, ping not working. I think mayby image have any errors. I try image 19.11.7.

IMO you should always use latest. It should work. And which kernel you are using? That is actually the most important information.

Version kernel is last numers? Armbian_20.02.1_Rockpi-4b_buster_current_5.4.20_desktop

I resigned from Armbian because I fought two weeks and not every thing working in this linux. I insaled on my Rock Pi 4 lastes (and others too) Armbian. This is terrible which I had to instaled and changing on my Rock Pi 4. And the end wifi disconnect after about 10 minuts of operation. I had to reboot computer every time. In Debian 9 I instaled octoprnit. In Debian it wasen.t easly either because I had small problem in install python. I’m glad you made it.

If you don’t listen to advises, its only your fault.

Kernel is talking to hardware. If you want to have a modern one, you have to understand its limitation - not going with the head into the wall or by blaming 3rd party. Don’t use it and certainly don’t cry that its bad …

Mainlining is an expensive process where community (on their costs) writes or ports features from development kernel (4.4.y called legacy in Armbian or “Debian” from Radxa have)

Not everything works in modern 5.4.y kernel which is why Armbian provides both kernels. That its simple for you - it takes less then 2 minutes to change to stock 4.4.y kernel … which you are using on “Debian 9” and which behaves better in certain situations.

You have no idea how lucky you were since this is a minor problem. Here, you will have this:
which is far more critical.

Igor I’m sorry, i understand how much strong work people in this and another projects. I dont have resentment only for my is too complicate. For my linux is new system. I working 30 years in dos/windows platform for me it is easly. In this problem I have one target: connecting with octoprint my Rock Pi 4 to my 3D Printer. I have sd card in Armbian and i shall try yours preferred solution.


I have same issue with wifi on newer kernels. It crashes after some time. The firmware is likely not adequate.

As a workaround, i am using a USB wifi dongle.

Can try usb wifi or older kernel 4.4 @igorp wrote.

Hi, Everyone.

I’m new to the forum and to Rock Pi. (Most of my projects have been based on Raspberry Pi.)

I try to be as thorough as I can when I post but I’m sure I’ll miss something, so feel free to ask any clarifying questions.

I bought a Rock Pi 4 B to use as a NAS and mini, low power home lab, primarliy because of the NVME port for fast storage.

I purchased a 16 GB eMMC module as I wasn’t sure, at the time, if I would be able to boot from the NVME drive. I forgot to purchase a USB eMMC flash tool when I made my purchase from ALLNET China so when it arrived, I installed it on the board anyway, figuring I could write to it once I’d gotten the system set up and possibly use it to run /root.

I’m using a 32 GB SD card for system set up.

Since I intend to run this headless, I flashed my SD card with the Armbian Buster minimal install found at armbian dot com / rockpi4. (New members have restrictions posting URL’s) :roll_eyes:

The system would not boot after multiple attempts.

To determine if it was a problem with my hardware configuration, I tried booting from the Rock Pi Ubuntu image found here:

That worked fine, though I was having issues with package management. (Probably user error.)

Once I confirmed that it wasn’t a hardware issue, I again flashed the card with the same Armbian Buster image and got the same results. (Meaning: no results.)

Finally, I found a YouTube tutorial from Nico D ( where he quickly installed Armbian Bionic desktop to his Rock Pi 4, so I tried that, just so I could replicate his results.

I’ve had no success.

Does anyone have any troubleshooting suggestions for me?

Thanks in advance.

Hi @gadgetboy

Using eMMC and SD card at the same time can cause conflict due to bootloader. Can remove eMMC and see if your SD card boots.


A USB serial device is helpful to debug such issues.

Also, suggest you to open a topic as your issue if different from the OP or post in similar topic here:

1 Like

Thanks @aaditya.

I’m going to try removing the eMMC to see if that helps. I guess I was reluctant to do that because I was avoiding removing the Big A** Heat Sink. :wink:

You can remove eMMC without removing heatsink. :slight_smile:

I do it using a flat spoon to pry off and reinsert.