Fixing U-boot to support boot from NVMEs

does the nvme Lenovo 256 gb also have the driver problem or only 512? I bought the 256GB one 10 days ago.

If you bought from Allnet store, I think they tested the models. @NBA should know it.

The 256GB Lenovo has no problem booting on Rock Pi 4. It has the same controller chip like the 128GB version.

Sí, yes, buy from them for the same reason, so as not to have problems.

We just added higher capacities from ACER which have proven to work without any problems. Now 512GB and 1TB are available.

I purchased a Lenovo SL700 256Gb from Allnet and it is with a PHISON controller. SPI boot not work!
I am telling you here so that other people do not fall for the older information from this topik.

then what do we do? I bought a 256 GB Lenovo sl700 from allnet and they told me it worked.

Hi, we just found out that Lenovo did change the controller chip without noticing us.

We therefore will stop selling them. We are very sorry for this and will replace the Lenovo´s with Acer which have proven to be stable supplying the same controller chip.

Please contact us on and we will find a solution to that.


1 Like

Most likely you purchased earlier, parcel came to me a week ago, I have PHISON chip

In my experience of using rock pi 4, I concluded that I do not really need spi boot because there is no way to select a boot device at startup. I have no problem having an SD card installed on board to boot from nvme. In addition, I can periodically synchronize rootfs on it and when I disconnecting nvme, I boot from SDcard with all changes in the system.
I have not yet fully configured the use of nvme. There are problems. And if I do not solve them, I will contact Allnet.
P.s. Thank you for putting the adapter from the SD card to emmc as a gift, which I forgot to order :slight_smile:

Hi Rua Is there a guide to configure the system to boot from the nvme with sdcard? I recognize that I am quite lost here.
do you speak Portuguese?

This still works if you want to move rootfs to nvme:

Moving file system to NVME procedure?

Thanks for the response. Works with armbiam? Because i have much problems with debian. I can’t put the spanish distribution on My keyboard and other some errors from console.

@aguapi with Armbian one can simply run nand-sata-install command or choose install to SATA, eMMC, NAND or USB option on armbian-config's system menu.

It will move root from SD to a first partition on the nvme (you need to create this partition yourself AFAIR) and mount bind the boot folder of SD to /boot for future upgrades.

There is an old video by @igorp on YouTube that presents the procedure:

1 Like

What serial device are you using? I have a Samsung PM961, and I cannot get it to boot. My USB TTL to Serial does not seem to work with RK3399.

@jack Any progress on fixing this? I don’t wish to be stuck to Radxa distros, nor using a uSD to boot.

Hey @Human_USB

I have tested 2 serial USB:

  1. CH340 based (like here) + good quality dupont cable.
  2. USB TTL debug cable found on AllNet store.

More info here:

and here:

Thank you @aaditya . I placed an order with Amazon for a CH340 device, and 22 awg dupont cables. Here is to hoping I can move forward on helping debug this board.

1 Like

Cool @Human_USB . USB TTL is almost necessary for ARM boards I have realized.

The dupont cables that I have are 24 AWG 70 cm length (like here), so your 22 AWG ones should be ok.

FTDI works fine - comX on the motherboard not works with 1500k

Hi.First of all I would like to tell you that I managed to work with the system from nvme.
Now, is it possible to overclocking? And is it advisable? I have the massive heatsink, but I don’t have a fan. I have the device, with all the USB ports busy, including a speaker on the top USB 3.0, and trying to work with a printer (which I still couldn’t get to work) the device gets quite hot.
My question regarding whether it can be done and if it is advisable to do overclocking in Armbiam, is because I notice that the Chromium browser is not fluid enough (for example, when wanting to deploy functions with the right button on links, it takes to load the options) and I assumed that that would be solved by overclocking, or maybe it’s a Chromium problem?