Windows graphics driver

Hi all.
I am unable to change the display resolution in Windows 10.
It seems the correct graphics driver isn’t installed in Windows.
It displays “Microsoft Basic Display Adapter” while it should be “Intel® HD Graphics”.

I do have these drivers for the Atomic Pi. But am unable to install them.
“Windows found drivers for your device but encountered an error while attempting to install them.
The installation of this device is forbidden by system policy. Contact your system administrator”

I checked the drivers on the download page. But it ain’t there.

The GPU also seems clocked at 400Mhz. Can it be set to 500Mhz in bios? Isn’t 500Mhz the default GPU clock for this SoC?
Greetings, NicoD

I edited the Windows Registry to be able to install the drivers (you can google the error message to find a guide on how to do it), but sometimes I get the BSOD, so it may not be the correct answer.
I don’t know for the GPU.

  1. You don’t need to edit registry for this. There is local group policy called
    "Prevent installation of devices using drivers that match these device setup classes"
    Computer Configuration > Administrative Templates > System > Device Installation > Device Installation Restrictions
    Disable it and you will be able to install drivers (that were made, because windows update is using wrong version for wifi driver which will lead to bsod, there is working version here)
  1. As for GPU drivers - here they are

Thank you Dante4. It works.
I didn’t know where to find Computer configuration.
It’s in : local group policy editor.

I can set all resolutions now. Thanks a lot. Cheers.

Have you encountered system crashes in windows? I did install the wifi driver you’ve mentioned.
I think I had it before installing any other drivers.

Stop code : Mememory Management

Had other stop codes too. I’d like to have a fix for this if possible before I can make a video about it.

In Linux all works like a charm. Only a mouse pointer glitch that’s fixed by logging out and logging in again. Didn’t look into it.
I must say I like the RockPiX a lot. Cheers.

PS: Happened again, now : Stop code PFN_LIST_CORRUPT

Yes, i have this problem. But on default wifi drivers i have this problem a lot often.

BSOD list includes

All of this is happens because of… How Microsoft handles Windows update. Old broadcom driver, which was working with old Windows 10, cause BSOD for current Windows version. The latest version improve it a bit, but it’s still far less from stable…

1 Like

Indeed. Seems a microsoft issue. I don’t think we can expect any help from them :slight_smile:
Only happens when I’m active on it. I’ve left it for hours without touching and no crash happens.

While when I’m using it, it crashes about every hour. I wonder if we could find XP drivers for this.

I played Flight Sim 2004 on it everything maxed out at 1080p. That was fun. Also GTASA. Plays great.
Would be a great retro windows games board if this can be fixed.
Wine works well, but still ain’t as good as windows.

1 Like

I finally have been able to install the GPU driver, the “Prevent installation of devices using drivers that match these device setup classes” didn’t work because it was repeated there and I wasn’t changing one of them.

Now my game runs at 60fps steady as expected. Now I have to check out to make sure it doesn’t crash when activating shaders inside the game.

Edit: The game was crashing with “D3DXCompile failed error” when starting to use shaders in the game because I forgot to install the DirectX End-User Runtime. After installing it, now the game runs perfectly with all the sader effects enabled. Here you have a couple of videos with the results:

I have constant BSODs after installing the drivers, I also tried the latest image from radxa and also have those BSODs.

the only way to stop my rockpi X going down after a few minutes (if not seconds) is to disable intel hd graphics.