Want to share my awful experience

Radxa really need to up their experience game.

I got two Quad Sata Hats. Starting with the assembly, the video instructions for the assembly was for an old version. Some ports don’t match. But I eventually figured that part out. Many of the screws that attach to the metal frame do not fit. There’s too much powder coat paint on them. I broke one of the screws because it was just too tight. Now onto the actual HAT itself.

One of them will load two of the 4 drives (all brand new drives) and I’m using the power adapter that came with the order, the other Quad Hat will load any of the drives at all, no light indicators. I thought I’d try to update firmware via PC. Looked at the instructions over at: How to upgrade F/W with jms561 under Windows and it’s completely useless… what’s the password? which ini file? I had to look at other users responses to figure out what to do. Well in either case, it didn’t help because the device was not picked up by Windows. So I saw someone posted at the end to use RPI to update, so I thought I’d give that a try. It appears the update targets specific sata ports? Well great, I can’t get the drives to load at all now. I replugged the USB connector from RPI to hat, changed the drives… plugged the power back in only to see smoke coming out the side. I fried the HAT… not sure what happened.

Radxa, if you’re reading this, you really need to up your game with documentation. I struggled so much with the Radxa Zero because your documentation was half baked. I ended up having to find other user’s posts on instructions to get it to work. Once I got the board running, I love that board, but your documentation is just awful. I want to support board makers outside of Raspberry PI, but this is just too much effort for very little gain. I have experience with Odroid as well and their products are much easier to deal with… and don’t have exorbitant shipping fees.

I have a question still in the CM3 board that’s still not answered.

You need to be careful about all electronic, You may kill anything with static electricity just by touching something.

For documentation - do You know that You can edit most of wiki pages and add any needed information yourself? This may help others in future. I’m not saying that everything is perfectly clear, but You just have chance to improve that.

I also have this hat and had no problems to assemble that. Moreover I decided to not watch or read any docs just because I think it should be easy thing. And it was. The only thing that I’ve changed was adding four small plastic screws on bottom, everything else fitted.

My ugly experience about SAT came after that on software side - I connected right ac adapter (12V 4A) and decided to go for Armbian first. This was large mistake because nothing worked out of box so I needed to spend extra time on libs and python that has messed packages, when I managed to get it working then it turns out that it’s just unstable and was dying after day or two for no reason. Long story short - I needed to switch to pi system and that one worked out of box and is stable till today. I still keep sd card with armbian to come back there but for now official os was just better idea.

Of course I hit some problems here, expecially the one for disappearing drives, but thanks to @tkaiser and his suggestion about usb3 port I managed to solve that one. I checked firmware and it was just latest.

Many others have some issues with those HATs but it was fun time to assemble that and learn something. I would correct few things in this build and looking forward for taco version. I understand that You are angry, but this doesn’t need to look like that.

Im glad it worked out for you but I tried both Armbian and RPI official images, I’ve also tried other PIs. I suspect something is hosed with the the USB ports as neither windows or RPi is reading it.

I have made various other NAS using SBCs with PCIE / NVME myself using easily found SATA Pcie cards or nvme m.2 to multiple sata adapters. And it’s surprisingly a lot less effort to get that working. Powering those was definitely more challenging. I only got this primarily for fun and would’ve stored non essential data. My x86 based NAS is still my trusted store.

There is missed opportunity to leverage the nvme ports found on 3A and 4C+ to use PCIE instead of USB, and both of those are RPI form factors if supporting the more popular RPIs via USB was still a priority.

Quad SATA had uses pcie lanes on those.

I believe you meant Penta Hat, if’s unfortunately been out of stock for some while. I hadn’t realized that didnt use usb.