Rock Pi X Wont POST

Hi All,

So just got my first Rock Pi X recently and ive been trying to get an OS on it but not had any luck after various attempts. After a few times the EFI shell stopped booting and would only show the Radxa logo so i tried a BIOS reset to defaults and then shortly after the board would not POST at all. The blue light goes bright immediately with no display.

Ive seen on the wiki that a settings can cause this and that flashing the BIOS should clear it but i have no idea how to even attempt using this tool and is beyond my skills. At this point for me the board is now a small light brick.

Is there any other way to get it to reset the BIOS to default without the controller flash option? I dont know if this is even this issue but its the last option before i return it.

Thanks all in advance


Check does usb have power in them

Yes, ive connected two devices and both light up. ive tried a keyboard but no numlock light which i would expect with a reset.

Hm, inactive numlock is not good thing. You tried USB 3.0 for this, correct?

yes, USB 3.0 external HDD and sitck. Keyboard was in 2.0 port. will try the keyboard again to see if i can get the BIOS. any suggestions are appreciated

Try keyboard in usb 3.0 port

Yeah tried that, no NumLock and can’t get the BIOS to show. Guessing the BIOS isn’t happy. Can the BIOS be bridged like ATX boards to force a settings reset?

No, HDMI output is one thing, but not having numlock is bad… At last i can advice you this

Thanks, tried but nothing. Just seems unresponsive. The force reset does nothing but dim the LED. I’ll contact the supplier and looks for a refund/replacement.

Thanks for your help

1 Like

Wait, dim led is what we need. led is dim when bios is starting, so try

Insert keyboard – start clicking del
Do full reset until led will dim
Do a few (30-50 sec) more Delete clicks
Then do F4-enter-F5-enter

Sadly, I have the same issue. Tried all of the suggestions. If any new suggestions come up, please let us know.

Same problem here, just received the board and started it up, everything went fine and the UEFI shell was displayed. Rebooted into the BIOS and changed some power management settings and boot device, after saving and restarting I have no HDMI output anymore. The led stays bright even after waiting a few minutes and will only dim when pressing the power key on the board for about 5 seconds.

Tried the blind reset trick but for me this is also not working, also no numlock and there does not seem to be power on the USB ports because the led in my optical mouse does not work.

Too bad there is no way to simply reset the bios. After only 15 minutes owning this board I already managed to brick it and is now an expensive paper weight ;(

I also ran into it. :frowning: ( Resetting the BIOS )

Not just me then. I’ve sent mine back to the supplier as faulty as I also lost the EFI shell so couldnt do anything even if the BIOS was ok.

It concerns me that the BIOS has not been customised for this board to stop any settings being applied that causes it to not boot. Having to flash it each time with a special tool is a no go for me.

The next revisions of the board needs:
Add an easier manual BIOS set option, pin jumper reset
Modify the BIOS to remove unwanted settings
ACHI boot support for a wider range of OS setups

For now I’m waiting for a refund and then buying something else. Shame as this board had so much potential.

Your problem seems to be different then the one I have with the Rock Pi X. In my case the blue led stays bright and would not dim, even after waiting a few minutes. I also noticed that the power led which should be green is very dim with an orange like color. There still seems to be some form of activity because the heatsink becomes warm after some time and when I press the power key for about 5 seconds the blue led dims.

I ordered the bios programmer set which will arrive in a few days and try to resurrect the board. Hopefully that will work, if not I will sent it back and order another x86 board.

exactly same to my rockpiX, I tested all usb ports with my little usb fan and the usb3.0 port is the only port has power, but when i plug the keyboard there was no led light.
I am not sure did the rockpiX recognize my keyboard, tried the blind f4-enter-f5-enter combo few times but no luck
thinking about order the BIOS reset tools

I got it working again :smiley: Had to use my Jetson Nano for it because that is the only Linux machine I have with easy accessible USB ports… After this I changed the exact same settings in the BIOS as before (when the board died) without any issue. Don’t know what caused it.

Process was simple, followed the steps as described on the Wiki.

1 Like

I ordered the CH341a Programmer and it seems same to yours. I am using Windows and I downloaded the BIOS binay(SPI Flash Image) from wiki and I have no idea which program should I use.
Will it be easier to flash the BIOS on linux?
I know it sounds silly, should I just connect everything (The 1.8v adapter) and open up the command prompt, and input the command

sudo flashrom --programmer ch341a_spi -w ROCKPI_V12_X64_20200821.bin

Is it how that works?

Thanks everyone

I used Linux because that was the only OS described on the Wiki and I could simply use the mentioned command there.

You first need to install flashrom when not already available (just try to execute the command), I needed to compile it myself because there was no binary available for the platform I used.

I used the command on the Wiki and for me that worked the first try.

1 Like