Resetting the BIOS

As the Rock Pi X includes a full UEFI BIOS, it’s inevitable that someone will do something wrong that will make their system unbootable. I have already gotten my self in this situation (still have no idea how), and it seems that I will need to reflash the SPI chip (Winbond W24q64fv).

If there are any other known methods of resetting the BIOS, it would be nice to have them listed. I know the Atomic Pi (which uses the same chipset) had a CMOS reset button (which was the subject of many accidents), I wonder if it’s possible to short certain pins to accomplish the same effect.

There is no Atomic Pi full schematic available, so we are not sure how they implement it. For ROCK Pi X, the bios setting is saved in one section of the SPI flash.

Actually I believe the partial schematic does show how they do it, but it may have had to do with the RTC.

Regardless, are there any other things that can be done?

Perhaps in a future version of the Rock Pi X, it should contain two SPI flash’s, one with the BIOS, and one with settings, so if all goes wrong, one could just short the settings one to keep it from getting read, and then everything would be fine.

I flashed a bad BIOS image and was able to recover my Rock Pi X via a very affordable CH341a programmer off Amazon.

I added some steps here:

Once I flashed, I noticed the BIOS settings were at defaults (I was missing my EFI boot options, for example). So most likely, by flashing a raw BIOS image with a CH341a programmer, you can effectively reset the BIOS settings.


In my attempts to get PFsense installed on this board I managed to lock myself out of the Rock Pi X by simply disabling the USB controller from the BIOS. You need the USB controller to use a keyboard and without a keyboard you can not do anything!

Thank you @tjcs90 tjcs90 your post was a helpful guide.

I ended up using a EZP2019+ SPI Flash Programmer to flash the Rock Pi X BOIS. I had a few failed attempts but setting the speed to 12mhz and clearing the SPI flash first before flashing the Rock Pi X BOIS finally worked.

SPI chip: Winbond W25Q64FW
Voltage: VCC 1.8V (–0.6 to VCC+0.6)
Write speed: 12 mhz (5mhz did not work)
Programmable Pages: 256-byte
Size: 8MB

IMPORTANT: most programmers on amazon are 3.3v or 5v. You must use 1.8V as per chip datasheet.

It would be nice if there is a mechanizem (shorting pins for example) to reset the BIOS settings back to default.

1 Like

@tjcs90 thank you for the guide

Also, i wanna add, unless you did something terrible with usb - you can still can reset bios in blind. As long as at least one usb have power you can connect keyboard to it:
Power up Rock Pi X
Click on power button (blue led change intensity from low to high) && tap Del for like 10 secs
Click F4
Click Enter
Click F5
Click Enter

Now you have reseted bios to default, that helped me a few times

1 Like

@Dante4 thanks for your tip, I tried the blind f4-enter-f5-enter combo, but it does not work for me :frowning: (latest bios, I set serial console in bios, hdmi output does not work anymore)

Usb port that you used for this had power, correct? Because when something breaks it’s possible that only usb 3.0 or only one of usb 2.0 is working

I tried them all :frowning:

And for first question? Does your usb provide power? And is in correct state (there is small tumbler Host/device)?

All of the USB ports have power, I checked

And for second question?
Does USB 3.0 in correct state (there is small tumbler Host/device)?

Yes, sure (but I tried in both position)

Also, follow led indication. I.e. connect keyboard, start pressing “del”, click power button (blue led should go low brightness), continue pressing Del for like 10-30 sec, then go for F-combo.

When I switch the Rock Pi X on, blue led is low, after 15 seconds, it goes to high brightness.
So the process: I connect the keyboard, after I connect the power adapter, I keep pushing ‘Del’ for almost one minute, after F4 - Enter - F5 - Enter, but HDMI output is still blank.
I tried another keyboard, another usb port (all of them).

I have sam e problem no run nothing …:sleepy:

Worked great with programmer EZP2019+.
First do an erase.

1 Like