Rock Pi X Wont POST

Finally I flashed the bios successfully and got my rock pi X working again.
I flash the bios with WINDOWS 10 and there are few tricks I would like to share for those who may need.
I download the driver and the program from the official website

  1. There is a “Detect” button at the top of the program, but even you click the button you still have to manually select the storage size of the chips and it should be 8MByte/8MBit. Otherwise you can still flash the bios, it will still popup successful message but actually doesn’t

  2. Sometime the program shows incorrect connecting states. I was struggling for a while. I erase and read the chips to confirm the program actually writing the chips before writing the bin file into the chips.

  3. At last I finally write the bin file into the chips, plug in power and hdmi, and I noticed the rock pi Logo flashed like 0.1 sec then the screen go black. I unplug and plug the power and keep clicking del, was successfully boot into bios, select restore to default and my rockpi X seems to work again.


Hi All,

So an update to my issues, sorry for the novel but here goes…

I sent the board back to the supplied as i don’t have the tools or knowledge to do the BIOS flash.
The report back was the the CPU has burned out due to an over voltage issue that was blamed on the USB charger. Now i used a PD compliant USB3.0 charger from a £1000 Toshiba laptop and not some knock-off one from eBay/Amazon so this left me confused. Its 9v to 20v rated with variable options

Thinking back to the time i was looking around the BIOS to see what i could to to reset other than the default to kick the EFI shell back in to life and i do recall in the BIOS is a setting to enable a ‘Turbo’ feature in the CPU section. Now i don’t beleive i enabled this but lets say i did (even though i set the defaults back and rebooted but flicking around and making a wrong key press is easy). At that point it died and got the no POST issue.

Now putting my detective hat on i feel that the setting drew more power/amps/volts than its rated to (maybe it does not support Intel turbo features) and fried the CPU. This would be regardless of the charger as the board is getting what it needs and is regulating it but the BIOS allowed the CPU to draw more. Now im not an electronics expert but this is my logical conclusion…happy to be corrected or advised as to what else may have caused it. By the way, i had this charger on the board for days before this possible BIOS setting change with USB HDD’s connected so highly doubt this is the case.

My first impression of the BIOS was that there are too many options for a board of this type such as PCI-E x16 config that has not been removed…why have them if the hardware is not present on the board. Anyways i suspect this or another option being turn on has caused it but awaiting further testing to find out.

Basically learn from me…DO NOT enable the turbo feature on the BIOS and hope to what ever god you subscribe to that Radax tunes this BIOS down to remove all potentially dangerous settings not just the annoying ones that need a BIOS reflash. If Radax is reading this please optimise the BIOS to stop these types of issues.

Depending on the report next week i will update as its good to share this experience if nothing else.

Speak soon

1 Like

I don’t see any problem with the charger you used to power the device, I use a 9v dummy adapter with a USB-C end to power it and did not have any trouble with that.

I also changed the power mangement settings in the BIOS, to be precise enabling turbo boost. This was also shown in a Youtube video and I don’t see any problems with changing that. After changing that setting my board also became unusable and would not boot anymore, which I eventually fixed with the BIOS programmer set.

After I got the board back to life I changed the exact same setting and the second time it worked just fine, I can also confirm the turbo feature works because the CPU goes to it’s max speed when needed.

I still don’t know what caused the problem the first time. And yes, there are options in the BIOS which can cause the board not to boot anymore but I did not change those. Afterwards I tested a few settings, I found out setting the dual channel memory option will cause the board not to boot anymore, the problem nn_hung also mentioned. I think these options need to be removed, unaware users can easily break their Rock Pi X with that.

1 Like

That is intereting then…not sure what else what would have caused it other than a hardware fault.

I do think this board is very flakey and fragile with the BIOS as it is and appears to be a big weak point for the board. Does put me off wanting a replacement instead of a refund and opting for another x86 SBC. Such a shame really.

Hopefully i will get an update next week and see what they say but i feel this is going to drag on for a while until they agree its just a simple faulty board.

1 Like

First at all. You don’t mess with bios of you don’t jnow what are you doing
Second. Read first.
Third. If you are unsure how it will affect your board don’t touch it.
Fourth. If you gonna experiment…well, give a monkey rock and glass and you will get broken glass in 99%. That doesn’t mean, that glass is bad or that stone is bad.

I read the specification page and it shows it has dual-channel memory, that is why I changed the BIOS setting.

Please don’t insult my intelligence or waste time posting useless comments.

Changing settings in the BIOS should not cause the board to not boot, they do…simple. If I changed a setting and it killed the board then it’s the fault of the board and not me.

If your not going to comment with help then don’t bother.


Well, it’s you who think that he is monkey in this example, so choice up to you :slight_smile:
You rip what you sow. You can kill anyboard by messing with it BIOS or by updating BIOS. Multiple vendors says that don’t mess witb bios unless you know what you are doing. And now you putting blame on everyone else like a child. That’s not great attitude.


I’m a cloud/infrastructure architect and have been working for over 25 years in IT. Yes I know what I’m doing…the board is faulty. Also how do u learn if you don’t try on an board desiged for experimental use? Not very bright are you.

Stop making up rubbish and move on if you have nothing to offer with this issue.

Yeah, sure, you are working XX (maybe one more X?) years in Y industry and you are one hell of big brain, how could we think that you, who reached real of PRO, don’t know that messing with bios can be dangerous. Wait, you actually said so yourself

Hm, it’s sad when person don’t wanna follow simple guide on wiki, but prefer to blame devs on forum, while being “expert”

No-one knows everything about everything…unlike yourself?

Well optimized BIOS does not cause a board to not POST, clearly you have no clue.

Yes I don’t have the tools, but I could acquire them but I should not have to manually flash a BIOS in this way. You should not have to use JTAG type programmers as a consumer on any other product No other manufacturer I’ve every used products from does this.
Yes I dont have the knowledge but I can learn, or is that wrong to learn in your world? Nobody should touch the BIOS? Even though you have to to enable some features in the BIOS. can you hear yourself?

I’m not blaming any Devs on here, I’m saying the board needs to be improved. No feature should exist if it causes the board to fail.

Does the simple wiki say don’t enable a feature that is available to select? Don’t recall one saying turning on a feature will kill the CPU or break the board. If we can’t be trusted don’t allow it.

Never killed any board by turning on a feature as you can always get back to the BIOS to fix the issue. On this board you can’t without special tools. You flash in software not a BIOS programmer.

Also you say don’t touch the BIOS but yet we are forced to use tools to flash it with could kill the board. Massive contradiction.

Know everything? You don’t need to know everything, you just need to know how to google. Let me show you how

Optimized? By whom? By you? Well, yours clearly not booting :slight_smile:

Remind me, how much does this “other products” cost? Something-something 100$+?
If you could learn we would not talk like this now. But you think that you know what is best based on your own individual experience. That’s clearly not the way to go.

Well, monkey shouldn’t. Human who go “i know what id best”? Shouldn’t. Human who understand to what his choice may lead to and who did his homework regarding restoration in case of fault? Yes, this one have every right to mess with bios.

Your post only about limiting user, it’s not “improvement”. Improvement is adding vga driver for example.

Well, if you watched wiki before messing with bios you should have already ordered programmer for restoration. And of you are not - you would still come to forum crying that “why this option is in bios when even in wiki it says that it dangerous”, what more as someone else posted - this option did not burned his cpu. Maybe you are not telling whole story?

As for “i say don’t touch bios”, bice word play. But you forgot one detail:

Dante4, you’re probably not wrong with your warning. But as a three time buyer of the Rock Pi X, two of which spontaneously got bricked and now will not POST, I can tell you that most (if not all) of the POSTing problems are NOT being caused by people “messing” with the BIOS settings. I don’t “mess” with the BIOS (ever) and two of mine are locked up. I just received the CH314a reprogrammer, and I’m going to follow the instructions (and pray a lot). I also do not believe that the power supply had anything to do with my X’s locking up. I have a fairly dumb, manually settable PS’s, and ahead of time, I read to prevent it from dropping to 5v, so I set one for 12v and one for 9v…so I know they never dropped to 5v and did not go anywhere near the the upper limit. I also second Andy_C’s comments that the board is very fragile, and has BIOS attributes that should be removed. It needs to be “hardened” to to prevent random software calls from being allowed to arbitrarily change the settings. If I can recover the two X’s (without too much effort), I’ll keep buying Rocks’ because I believe in being an early adopter to help further a product line, …so long as the manufacturer stands behind it.

Honestly have you been smoking some you shouldn’t have? Ill give you a clue, starts in ‘R’ and ends in ‘adaxa’. If you had bothered to read this post by board i back with the supplier.

Ok bored of your nonsense ramblings. PrimMvr said it well, im not ‘messing’ around but trying to look for a soluton to what is clearly a board fault. I know what im doing and please for everyones sanity stop calling people a monkey. You are just making your self look like an immature 5 year old.

Anyways, should be getting a response back this week to see what fried the CPU.

Once again, you are playing with words. You did messed up, also without recovery plan. And you still completely ignored my question about price.

Thanks god i don’t care how i look in eyes of PRO with WHOLE 25 years in IT industry. Like that even matter, if that person don’t have habbit of preparing recovery plan when he messing with bios or system in total.

Well, but you still locked up yours boards. That means you messed up with bios. You can’t lock in POST unless you either tried non-compatibility PSU and literally fried your board (and then there is no really POST at all) or you actually messed up with bios. There is no magic begind it.

Dante4, I actually feel sorry for you. Your actions are small-minded and your arguing about facts that you clearly don’t know. It makes you come off as a young know-it-all, while others are laughing at your hubris.
As I said, I didn’t change a single BIOS setting…both boards became locked, after the Windows install completed. The same PSU has been in use on all three X’s, so it’s not the problem either.
Hopefully when you grow up (or latently mature), you’ll learn that arguing to prove you know more than others, is a obvious sign of immaturity. Most people don’t go on a Forum to publicly lie about what happened, they’re just looking for help. Don’t insert yourself, where you clearly have nothing to offer.

Yeah, sure. Another one “i know what best”. Wanna continue? It’s always funny great to see persons who buy cheapest available solution and then expect premier level support.

PrimMvr - For what its worth i do apreciate your input as i know i didn’t do anyting out of the norm to cause this and that you had other similar experiences.

Having to buy chip programmers is just something that consumers should not have to do to recover a BIOS. If consumers should not ‘mess’ with the BIOS then we certainly should not be having the maufacturer expect us to physically connect a programmer flash it with hardware. We can easily do more damage doing this than selecting any BIOS setting. I dont allow anyone to flash the BIOS in software let alone hardware. Anyways i just hope the manufacturer improves the board as i see many posts just like mine with these issues all most appear to be BIOS related. Don’t like the idea of my board running as my UTM firewall and then it suddenlying not POSTing. Thats not normal however you look at it.

Ignore the petty child…nothing is going to get him to understand logic or reason.

Would be great if you stopped playing with words, but i guess i expect too much. Like, i already said about messing with bios.

Btw, it wasn’t Radxa who created this guide, but one of user in this thread, so yeah, manufacturer did not expected this, but yeah, let’s blame manufacturer, we are too PRO to read or google, right?