Rock Pi will not boot


#1

I was following the advice posted by Brian here: Official Rapsberry Pi Display My Rock Pi isn’t recognizing that the Raspberry Pi display was connected to the DSI port. I got the the last part:

The file, “/boot/extlinux/extlinux.conf” does not have a line, “default kernel…”, so I added it to the file and rebooted. Nothing. I removed the eMMC module and plugged in a SD card with Debian and still nothing. The power LED is on, but no signal from the HDMI port.

What did I do and how do I fix it?


#3

You do not read the instructions, even after they have pointed you out, but you complain about lack of documentation. You make absolute beginner mistakes and ask for help for beginners. When you are offered help, however, you deny that you are a beginner. You complain about the necessary power supply, and a suitable USB-C charger (PD) is offered at a reasonable price. By the way, of all the SBCs in the RK3399 class, the RockPi has the best designed power supply of all! If you haven’t ordered a suitable USB-C charger don’t blame others. You can also find out which USB-C charger are suitable in the documentation I recommended you to read yesterday. Please understand that I was enjoying the sun on Easter weekend. Other users might not come in that often this weekend either, and the developers deserve their weekend too.

ROCK Pi 4

This is the documentation for ROCK Pi 4, written by Radxa Team with community contributions.

Power USB PD Support USB Type C PD 2.0, 9V/2A, 12V/2A, 15V/2A, 20V/2A Qualcomm® Quick ChargeTM Support QC3.0/2.0 adapter, 9V/2A, 12V/1.5A


#5

I deleted the inflammatory comments. I shouldn’t let my frustration get the better of me. I do apologize.

I’m using this as my home PC. I cannot afford a “real” computer right now and this does everything I need. The price makes it worth learning Linux. Unfortunately, while the roughly $170 USD I spent may not be much to most people, it is more than I can afford to spend again. I really need to get this fixed.


#6

I’ve forgotten everything. In the heat of excitement and anger, sometimes harsh words are used, but as they say in my homeland: “It is not eaten as hot as it is cooked”.

Believe me, I’ve had problems before that at times seemed insurmountable. That was mostly because the thoughts went in a circle during the search for a solution. I believe, in such moments, our brains close themselves to intuitions. Our thoughts are similar to those of cycling in winter, when the roads are snowed in and the temperature is around zero degrees Celsius. As long as you are the first cyclist, you can easily steer, but if other tires have already ridden a groove in the re-frozen snow, then it is very difficult to leave this groove. It may be that only one thing helps, stop and lift the wheels out of the groove to be able to steer again without restriction. This is how our thoughts behave, if they went too long in a circle, they can hardly leave the way. I got into the habit of taking a longer break and doing something else. With a combined project of hardware and software it can be enough to switch from hardware to software or vice versa to get an intuition. But it’s safer to do something completely different, sports, play with your kids or go for a walk with the dog.


#7

I happened across a power supply that closely matches the one that came with the Rock Pi, but no change. I can rule out a power issue. I have Debian on both the eMMC as well as the SD card. At the time this happen, the SD card was not installed, so I know it it not corrupted. I tried booting with both the eMMC and SD card with no results. I removed the eMMC and tried booting from the SD card and nothing. I then tried booting up without either installed, expected to see the error telling me to install a boot drive, but didn’t get that either. I thought it might be the Hdmi cable, so I connected a blu-ray player and got a picture, so it’s not that.

I followed Brian’s instructions twice, first from the SD card and then, with the SD card removed, from the eMMC. The second time I added the “default kernel…” to extlinux.conf, but also typed “sync” and “reboot” from the console, thinking that maybe he meant those as commands. When I typed “reboot”, the screen went black and that was the end of the Rock Pi.

Clearly I did something wrong. I have no idea what, nor do I know how I could have corrupted the board. I could see corrupting the installations, but this seems to go beyond that. The hardware is corrupted.


#8

Can someone please help me? I hate to beg, but I’m out of options. I don’t know what happened and have no solution. Why would what I did brick the Rock Pi? How do I fix this?