Rock pi 4C + NVME boot clarified!

Hopefully this post gets pinned as there ins’t enough clarification on this point.
Using ROCKPI-m2-extend V1.6 board.

1.SD cards was imaged with rockpi4c_ubuntu_focal_minimal_arm64_20200820_1207-gpt.img.

  1. SPI flash is 4MB on this board an flashed according to
    Method Two: Write image to SPI flash using mtd tool
    https://wiki.radxa.com/Rockpi4/install/NVME

  2. Using rockpi4c_debian_stretch_desktop_arm64_20200716_0647-gpt.img etched to NVME (via usb reader+ etcher) does SD need to be always inserted (from setup 1)?

when removing the SD, board can’t boot to NVME.

Is there no solution to just burn working image to NVME and boot?

UPDATE: Solution solved… Once SPI is correctly flash no need for the SD always in. Ubuntu server 20.04 and Debian Desktop image are both booting off the NVME.

1 Like

what nvme ssd model?

Thank you for the reply.
The issue is solved I recommend you update your wiki.

ubuntu 20.04 server image + xubuntu-dektop all works well

Can you explain what content we should update? You can edit the wiki with register too :slight_smile:

I had no luck with method two. Used method one. Now boots from nvme SSD. The problem I have is trying to install Radxa APT. Wget command not found. So unable to unmiminimize the system.

Minimal images tend to not have wget installed.
It’s quite simple to install it with,

sudo apt install wget

Hi,

I too have quite some difficulty getting this working.

I did flash the SPI though the instructions on the wiki. Those instructions are very definitely wrong!
It claims you should execute sudo /usr/local/sbin/rockpi4b_upgrade_bootloader.sh but the line in that script to flash the SPI is commented out.

I followed the advice from others in these forums to use the erase script then the flash script.
I did also execute sudo /usr/local/sbin/rockpi4b_upgrade_bootloader.sh but only because it was the first attempt with following the wiki.

Next, getting the NVMe to boot is really weird. I flash Debian 9 Desktop(Dual Display) on it using etcher.

Now if i only have my NVMe in the Rock Pi 4C (so nothing in the SD and eMMC) then it won’t boot at all. The blue led just stays on. If i add in an eMMC (not tried an empty one yet) but flashed with the same distribution then the Rock Pi 4C does boot! And it does so from the NVMe. I confirmed that by typing “df -h” and seeing that my NVMe was the / partition. It was also confirmed by downloaded files that were on my eMMC but not the NVMe.

Is this how it’s supposed to work?
So with an NVMe and and eMMC connected?

Cheers,
Mark

ok, I’v been doing some testing with Rock Pi 4C and crucial P1 M.2 1TB nvme.
I can successfully boot after running /usr/local/sbin/rockpi4c_write_spi_flash.sh as written above.
These are my results:

Armbian buster current minimal: - no boot
Armbian buster current desktop: - OK
Manjaro Mate: logo shows but gets stuck
Debian strech desktop: OK
Ubuntu Server focal minimal: - no boot
TornadoOS : no boot

This is quite disappointing. The main selling point for the Rock Pi 4 is the M.2 interface in my view. I can’t understand that there hasn’t been more effort on the software side to make this board more usable.

1 Like

Me no understand. Details please maybe a video would do it. Thanks very much :grinning:

Tank you very much. Same here🤘

Oh and mine is a 4c. Thanks