Quad SATA Hat Disconnects

I am writing to you because I have had the Quad Sata Hat on my RPI4 4GB since January and a few days ago I changed it to the 8GB one.

I have tried with OS. Raspian and now with Ubuntu.

I have 4 2.5" drives connected and the power is 12v 5A to the board. But I also tried it with the ATX connector.

It works fine for me when it starts, but when it has been active for a while, the disks are disconnected and there is no way to recover the data, it is only solved by unplugging the power and connecting.

Attached capture of the failure when the HDD begins to disappear.

I have been reviewing the forum, with topics from other users that the same thing happens to them.

SATA 1 AND 4 of Quad SATA HAT not working

[solved] SATA HAT disconnects disk on heavy use

Quad sata hat failure : disk sudden disconnection

Hello, try to disable UAS and test again.

# /etc/modprobe.d/blacklist_uas.conf
options usb-storage quirks=Vendor_ID:Product_ID:u
# mkinitcpio -p linux
# reboot

I have it in the start file
"usb-storage.quirks=152d:0561:u "

Also the command “mkinitcpio -p linux” is not available to me, it is Ubuntu.

I’m still the same, the units are disconnected and connected with another name.

[ 1243.948736] usb 2-1: new SuperSpeed USB device number 4 using xhci_hcd
[ 1243.969984] usb 2-1: New USB device found, idVendor=152d, idProduct=0561, bcdDevice=81.36
[ 1243.970000] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=5
[ 1243.970005] usb 2-1: Product: External
[ 1243.970010] usb 2-1: Manufacturer: JMicron
[ 1243.970015] usb 2-1: SerialNumber: DD564198838B6
[ 1243.972571] usb 2-1: UAS is ignored for this device, using usb-storage instead
[ 1243.972594] usb-storage 2-1:1.0: USB Mass Storage device detected
[ 1243.973191] usb-storage 2-1:1.0: Quirks match for vid 152d pid 0561: 800000
[ 1243.973305] scsi host2: usb-storage 2-1:1.0
[ 1245.001091] scsi 2:0:0:0: Direct-Access JMicron Tech 8136 PQ: 0 ANSI: 6
[ 1245.001406] scsi 2:0:0:1: Direct-Access JMicron Tech 8136 PQ: 0 ANSI: 6
[ 1245.002124] sd 2:0:0:0: Attached scsi generic sg2 type 0
[ 1245.002461] sd 2:0:0:0: [sde] 1465149168 512-byte logical blocks: (750 GB/699 GiB)
[ 1245.002578] sd 2:0:0:1: Attached scsi generic sg3 type 0
[ 1245.003179] sd 2:0:0:0: [sde] Write Protect is off
[ 1245.003199] sd 2:0:0:0: [sde] Mode Sense: 47 00 10 08
[ 1245.003570] sd 2:0:0:1: [sdf] 1953525168 512-byte logical blocks: (1.00 TB/932 GiB)
[ 1245.004242] sd 2:0:0:1: [sdf] Write Protect is off
[ 1245.004257] sd 2:0:0:1: [sdf] Mode Sense: 47 00 10 08
[ 1245.004970] sd 2:0:0:1: [sdf] No Caching mode page found
[ 1245.010455] sd 2:0:0:1: [sdf] Assuming drive cache: write through
[ 1245.017290] sd 2:0:0:0: [sde] No Caching mode page found
[ 1245.022898] sd 2:0:0:0: [sde] Assuming drive cache: write through
[ 1245.235479] sdf: sdf1 sdf2 sdf3 sdf4
[ 1245.235792] sde: sde1 sde2 sde3
[ 1245.239109] sd 2:0:0:0: [sde] Attached SCSI disk
[ 1245.239919] sd 2:0:0:1: [sdf] Attached SCSI disk

Well, you can’t fix connector or underpowering problems by exchanging a driver. ‘Disable UAS’ is often a joke since all it does is exchanging the error messages that do read ‘uas $something’ before with ‘xhci $something’ when mass storage is used.

USB3-A receptacles are maybe the worst connector ever invented since the contact area is super tiny and the position of the data line contacts ensure that even vibrations can end up with issues:


I would try to exchange the USB cable first with one that really fits tightly, and if that doesn’t help check power supply situation and here the cable since the problem often is not the amps but voltage drops due to cable diameter too small.

More info.

Buy 2 USB3.0-A to A cables.

I did the test and I got the following error. "Maybe the USB cable is bad? "
These wires don’t seem to be making good contact.

Already desperate as you indicate, I tried to connect it to the usb2.0 ports of the RPI since with the bridge you cannot do it.

Although it worked at 480M instead of 5G, they have been working for 2 weeks without problems.

Quoting myself:

Hi @peromingo,
Did you resolve your problem? I have exactly the same with a fresh raspian install.
Disabling UAS only changed the error message as @tkaiser said.
I haven’t tried with other USB cables yet

The tolerances for the USB bridge and case are very tight. There is a possibility that the bridge is is not making good contact due to being limited by the case/board geometry . You might try the bridge with the case off as an experiment since you can seat it several millimetres deeper. It is a pity that the bridge does not not have more depth on the connectors so that it is fully seated and still has case clearance.

Buy Usb3.0 cable and connectors to make the cables.

But I haven’t had time to make them.