Quad sata hat + Argon One enclosure

I’m a happy owner of both a Argon One case and a Quad sata kit.
I love the quad sata hat but thing is the temperature gets really hot inside its aluminum enclosure. As appearance does not really matter in my case (pi’s hidden in a technical room, protected from dust), I would like to use the hat but having the pi inside the Argon One.

Question is, should I run both install script, I believe there would be some conflicts, maybe just install the software so the raspberry can talk to the hat and only install the Argon’s install script.

I saw a “lite” script (Lightweight Installation (SATA HAT only, no cpu fan, no lcd, no buttons)) would this fit my needs? I would like to use only the hat with the Argon One enclosure and if possible being able to install their script to control their fan ( I know I will not be able to use the power button as the pi and the Argon one would be powered by the quad sata hat)

What do you guys think?

Thank you!

Hello Unipo,

I’ll make time to see if its installation script conflicts with ours.

There is no conflict.

Hi setq!

Thank you so much for having taken the time to test it for me!

I do have 2 more questions now:
_Should I power the pi via the quad sata hat or should I power the hat and power the pi (via the Argon one’s board) independently?
_In the meantime I tried to find schematics of both the quad sata hat and the argon One’s, but unfortunately I couldn’t find anything relevant. Are you sure they don’t use the same GPIO pins?

Thank you,

So to keep you updated, I can power the pi, ARGON ONE and quad sata hat using the hat’s power supply.

So i put the pi in the Argon One case, set up the hat on top of it and I used usb3 type A to Type A cables to connect the hat to the pi. Installed both Argon’s script and your lite.
But the pi does not see the drives or the hat…
Do you have any idea?



It seems that using the hat with the light script does work. So no conflicts with Argon One’s GPIOs.

The problem is much more of a mystery, let me explain:
I can use the hat connected to the pi using the usb 3 “bridge”. In an other hand if I use 2 usb 3.0 type A cables instead of the bridge, I am unable to connect to the hat. I found the reason hiding in dmesg:

I can swear those cables work, I have a few pair and I tried them all on my computer. (Ugreen, Inatek, nobrand)

So the issue seems to be using cables instead of the usb bridge.

Do you guys managed to use the hat with cables? Is the brigde more than a simple bridge?

Just a simple bridge.

There may be a problem with the USB of RPi or Argon One.

Well… I don’t understand.

Usb of the pi work fine, I can access my drives => sata to usb => powered usb hub => Pi’s usb 3.0

Issues connecting with usb cables are not related to the Argon One as my lasts attempts were with a naked pi with fresh install of raspian 64bits + light-rock-sata install script

Ordinary A-A cables can be used, and you can even make it by yourself.

Hi again,

I appears the problem only happen connecting the cables to the usb 3.0, using the 2.0 ports of the raspberry it works…
Do you have any idea what’s going on?
I mean it works but not taking advantage of the 3.0 bus it kind of useless…