Plex server freezes every 5-10 minutes on android client

Hi everyone,
I installed a Plex media server (last version) on my Rock Pi 4 and the playback freezes every 5 to 10 minutes, I have to restart the movie/series for it to continue.
I tried with many distros on the Rock Pi 4, Ubuntu Server 18.04, Debian 9 Desktop and Armbian, all downloaded from the dowload page but plex is still freezing.
However when play throught the plex web page there are no issues, only with android client (android TV on my Fire Tv and on my phone).
Does anayone haver ever encounter that problem ?

1 Like

Maybe @mo123 can help you.

Hi @totocrenn

Did you try LibreELEC with the Plex addon?


https://kodi.wiki/view/Add-on:Plex

You can also try the same addon in AndroidTV firmware with Kodi

Maybe Plex will work better in other Linux OS’s when all Rockchip components are added to mainline Linux
You can try mainline Manjaro but only H264 codec is working so far, H265, VP9 will be available in a few weeks.


(Remember to erase the emmc to boot this Linux from a micro-sd card)

Thanks for the detailed answer !
I didn’t knew LibreELEC but if I understand correctly it’s an OS with a KODI client. And the KODI client allow to install a Plex client. Am I right ?
For me the problem is not from the client but from the server so I want to be able to install Plex Media Server on my Rock Pi 4 and connect to it via plex clients on my phone, my fire tv or any browser.
That’s what I was doing with my Raspberry Pi 3, the pi was juste the plex server and not the client. I just wanted a bit more power so I moved to the Rock Pi 4B.

But I will try with Manjaro if you think there is more chance for it to work with the Rock Pi 4 :slight_smile:

Also I have made more test and it appears that it freezes even with the browser.

Probably that transcoding overloads the CPU and should be avoided or disabled.
Does Plex support HW transcoding on RP3?

I always watch in direct play, so there is no transcoding in my case right ?

Correct, in that case I’d check the power supply. Maybe not strong enough for the RockPi and a possible external USB drive?

I dont think that the case either. I tested with the penta sata nas kit and the power supply it came with (60W DC) and I got the same results…

Edit : I just tried without any external disk, so a small librairy on the emmc itself and the result is the same

I just tried with Manjaro, same results freezes every 5 to 10 minutes. Same with Ubuntu server with latest kernel (manual update)… I’m out of solutions now

try to log the temperature maybe :thinking:

I just found the source of the problem, it’s the eth0 port. If I switch to wifi the stream works fine. So for now I will buy an usb3 to ethernet adpater and work with that.

2 Likes

Cool :slight_smile: Maybe this is something that the @radxa team should be aware of.
Thanks for letting us know and enjoy the movies!

1 Like