My zero Wi-Fi is not working

I haven’t tried it yet.
If I have a chance this afternoon, I’ll try it right away!

1 Like

sudo dmesg was too long to paste here. Im including plain txt to look at.

sudo dmesg

dmesg looks fine so let’s try fix the clm_blob missing error. Try download https://github.com/pyavitz/firmware/raw/main/brcmfmac43456-sdio.clm_blob and copy it over to your Zero as /lib/firmware/brcm/brcmfmac43456-sdio.clm_blob.

Also please attach your journalctl log: https://wiki.archlinux.org/title/NetworkManager#Secrets_were_required,_but_not_provided

Another workaround I found:

nmcli connection modify <SSID> wifi-sec.key-mgmt wpa-psk
nmcli connection modify <SSID> wifi-sec.psk <WiFi password>
nmcli connection up <SSID>
1 Like

I did copy

clm_blob

to exactly path you mentioned. I didn’t need to do anything else. i followed the steps to activate + connect to wifi from Debian page;

Switch to super user mode

$ sudo su

Open the WIFI

$ nmcli r wifi on

Scan WIFI

$ nmcli dev wifi

Connect to WIFI network

$ nmcli dev wifi connect “wifi_name” password “wifi_password”

THEN THIS IS WHAT I GET - AND IT CONNECTS !! WHICH IS AWESOME

root@radxa-zero:/home/rock# nmcli dev wifi connect pacific password xxxxxxxxx
Device ‘wlan0’ successfully activated with ‘fb58615c-91c7-4f04-a6e0-9f017ca35d31’.

BUT AFTER ABOUT 10 MIN. IT WIFI DISCONNECTS. I TRIED TO CONNECT AGAIN, AND I GET THE SAME MESSAGE

root@radxa-zero:/home/rock# nmcli dev wifi connect pacific password xxxxxxxxx
Error: Connection activation failed: (7) Secrets were required, but not provided.

Try clear all saved connection and connect with the above workaround again. Also please post your journalctl message as mentioned in above post.

yes, forgot the journalctl. If i understoo right, im sending;

journalctl -b

for the workaround i tried couple of times;

nmcli connection modify wifi-sec.key-mgmt wpa-psk
nmcli connection modify wifi-sec.psk
nmcli connection up

But i keep getting error about - Secrets were required, but not provided.
with a warning;

nmcli connection up xxxxx
Passwords or encryption keys are required to access the wireless network “xxxxx”

Warning: password for ‘802-11-wireless-security.psk’ not given in ‘passwd-file’ and nmcli cannot ask without ‘__ask’ option.

Error: Connection activation failed: Secrets were required, but not provided

Try sudo nmcli connection up pacific --ask as requested by the warning. If that doesn’t work please run sudo journalctl -u NetworkManager for journalctl log.

Additionally ls -la /etc/NetworkManager/system-connections/ to check permission, and you might want to examine pacific.nmconnection file under this folder to see if it contains psk.

@RadxaYuntian I can try all those requests, no problems at all. But at the end, i have to wipe this board and install Manjaro on my device like the other zero i have.

If this was an issue for both of my zeros i would understand. But im only having this wifi issue with this specific board.

and as an extra, Im not a developer at all (Thank you for your patience with me) … and I’m already having hardtime catching up with your requests, as you would understand everyone has their own expertise and skillset… and I’ll be honest, i dont really understand what im trying to accomplish, or what those comments, logs means… I do respect your expertise, and im doing my best to deliver your requests. But im working at the sametime and i really cant reserve more time on this…because every step its getting deeper and deeper.

Simple question is:

  1. What causing this problem with my current board, and why wifi isnt working like my other board. Would you be able to express this information considering your knowledge ?
  2. Do you think that this is a software issue ? or is it an issue with hardware ?
  3. Should i just wait for solution or should i just request a replacement for my board ?

I appreciate all your help,

Thank you.

I was making those requests because the nature of your issue is still not clear. At this point I cannot say with confidence that the issue is on the hardware (since you were able to connect once and there was no hardware related error message in dmesg) or on the software (since the no secret error should not happen as that should be saved automatically). I was just trying to gather more information to make a proper judgement.

However, I understand you just want something works. In that case the fastest way for you to confirm that probably is just to have a fresh install of another system, and if that still doesn’t work, RMA the board.

Thank you for understanding @RadxaYuntian

Actually before i came to this topic, I tried to install Manjaro first and discussed about the problem with in WIFI on Manjaro topic which you know about, because i had conversation with yourself and @spikerguy . We did a bit of investigation and i found myself here with @SKRSKR question / Topic. Which we ended up here.

So far;
I did install Manjaro > wifi didnt work.

Then i moved on to official releases
Tried Official Ubuntu without involving desktop environment > didnt work
Then I was here with Debian, and your help (which i highly appreciate, you are big help !! )

I will send an email about it, and hope i can return / replace my unit.

Thank you again,

I’m very sorry for the unpleasant experience you have. We are still working on this issue so hopefully we will have stable Wi-Fi on Zero soon.

1 Like

No problem at all. @RadxaYuntian I totally understand…and zero is an amazing board for my projects.
Other unit is still working great and i have no problems with it.
I will still be in forums and troubleshoot some other problems and find solution for my questions. This wouldn’t be possible without this community.

Hi @RadxaYuntian
I’m getting comments from .allnet team that the Wi-Fi problem i was facing is a software issue on zero board ? and they told me that developers are working on it.
Do you have any information about it ?

Thank you

Your issue is weird and so far you are the only one reporting this specific issue (Wi-Fi listed but won’t connect). Allnet was talking about another issue where Wi-Fi device won’t properly initialize. We are working on the latter but we have no clue on your issue since we can’t reproduce it.

1 Like

Hi @RadxaYuntian,

I have six zero’s three of them demonstrate this behavior. I have tried multiple different images including the base android image. I have also tried different power supplies to see if it’s an under volt issue. I have also tried to update the AP6256 firmware images as well.

It seems to be some sort of timing issue on power up.

Here is the type of error I see on boot which prevents wlan0 from being created. The current workaround is to logon via serial console and do a “rmmod brcmfmac” and then a “modprobe brcmfmac”.

What is strange is that some time it boots correctly and will do that for multiple boots and then randomly start to fail again. So it seems to be some sort transient state and timing error.

Here is the dmesg output.

[Sat Feb 26 03:33:42 2022] systemd[1]: systemd 245.4-4ubuntu3.15 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD +IDN2 -IDN +PCRE2 default-hierarchy=hybrid)
[Sat Feb 26 03:33:44 2022] brcmfmac: F1 signature read @0x18000000=0x15294345
[Sat Feb 26 03:33:44 2022] brcmfmac: brcmf_chip_cores_check: CPU core not detected
[Sat Feb 26 03:33:44 2022] brcmfmac: brcmf_sdio_probe_attach: brcmf_chip_attach failed!
[Sat Feb 26 03:33:44 2022] brcmfmac: brcmf_sdio_probe: brcmf_sdio_probe_attach failed
[Sat Feb 26 03:33:44 2022] brcmfmac: brcmf_ops_sdio_probe: F2 error, probe failed -19…

Here is where I unload the module and reload it:

[Sat Feb 26 03:35:12 2022] usbcore: deregistering interface driver brcmfmac
[Sat Feb 26 03:35:12 2022] file system registered
[Sat Feb 26 03:35:12 2022] brcmfmac: F1 signature read @0x18000000=0x15294345
[Sat Feb 26 03:35:12 2022] brcmfmac: brcmf_of_probe: interrupt could not be mapped
[Sat Feb 26 03:35:12 2022] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43456-sdio for chip BCM4345/9
[Sat Feb 26 03:35:12 2022] usbcore: registered new interface driver brcmfmac
[Sat Feb 26 03:35:13 2022] read descriptors
[Sat Feb 26 03:35:13 2022] read strings
[Sat Feb 26 03:35:13 2022] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43456-sdio for chip BCM4345/9
[Sat Feb 26 03:35:13 2022] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/9 wl0: Feb 11 2020 11:54:51 version 7.45.96.61 (be7af2d@shgit) (r745790) FWID 01-a41d86bd es7.c5.n4.a3
[Sat Feb 26 03:35:14 2022] dwc2 ff400000.usb: bound driver configfs-gadget
[Sat Feb 26 03:36:13 2022] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

I have seen other SBC’s that use the AP6256 wifi module seem to have had similar issues. Please have a look at the Pine64 forums .

Finally, wireless and BT/BLE are all stable after doing the workaround. The devices have been up for days with no wireless issues.

Thank for taking the time look in to this for us.

Cheers,
Charles

Yes this is a known issue and we are looking into it. Currently there is a workaround for this issue: reduce SDIO’s frequency. You can (backup and) replace your dtb under boot partition (the exact location differs in different distros) with the following file: https://file.io/y3hjkOXKABAC

SHA256: f9a9fbfaae3ec29009941b13418a7bb88170e7a5951c3e06ea28e8ade5cb03f5 meson-g12a-radxa-zero.dtb

Thank you @RadxaYuntian Unfortunately the included link indicates the file has been deleted. Please advise?

The AP6256 on my Zero has displayed similar intermittent wifi/bt connection issues. Two observations:
a) It seems to happen less when I have the secondary usb-c and mini-hdmi connected.
b) When it does happen, switching to the initial virtual terminal via: Ctrl+Alt+F1 shows bluetooth isn’t able to start. I’ve been trying to grab a pic but since it’s intermittent, it’s been elusive.

When wifi does fail to connect, I’ve been logging into one of the virtual terminals to diagnose. ifconfig and iwconfig don’t show the wlan0 device. I’ve been saving the dmesg output when the device comes up and when it doesn’t. Both show similar errors with brcmfmac. I’m happy to share these if it is helpful.

From here, removing and reloading the module does typically load wifi, ie via:
rmmod brcmfmac
modprobe -i brcmfmac

The problem for me is my application for the Zero is in a utility closet, so disconnecting it and bringing it to a keyboard & monitor is toilsome.

Initially, my troubleshooting was on the OS config side, so I setup wpasupplicant but that provided no joy, since the hardware wasn’t loading.

Please let me know any other details or logs you would find helpful?

Thank you!

meson-g12a-radxa-zero.dtb.zip (13.8 KB)

Sweet, thanks! I’ll test tomorrow and report back…

I took my chances and replaced this file under dtb folder. [Distro = Dietpi]
No luck:(