LibreELEC - RockPi 4

New LibreELEC image, see OP

If using RockPi 4C replace with this dtb file to have all the USB ports working

1 Like

Hi Mo123,

It looks like your post might solve my issue, I have just setup a brand new Rockpi 4C with LibreELEC but only the top USB3 port is working.

You say to replace the dtb file listed above but I have no idea how to do that, can you please give me instructions or point me in the right direction?



Hi Mo123, I worked out how to do it but still only have the uppermost USB3 port working. Any ideas?

Thanks in advance

I’ll try to post an updated dtb file.
I think the last one I posted might not have contained all the required changes.
But might be better if I rebuild LE from the latest source-code tomorrow.

Much appreciated

New images

RockPi 4B

RockPi 4C

Thanks Mo123, all 4 ports now working on 4C.


i have try install latest image but it fail to start (no video, no blinking blue led)
When i try armbian, official LE or other image with same sd card it boot fine…

Should this image work with Rockpi4 model A v1.4?

Thank you


I have a rockpi 4c and the usb port won’t work when booting with official LE.
After I replaced the dtb file with the one in Armbian folder rk3399-rock-pi-4c.dtb (Yes I changed the dtb name in extlinux.conf), it won’t even start.

Any idea or help?

The Armbian & LE images you use likely use different kernel versions so the dtb file will contain different settings and cause no boot problems.

Try to use the latest LE from here and change the default dtb file.

or use my image based on the legacy 4.4 kernel with working USB ports and HDR playback.

Could someone help me with installing image to 4A v1.4?

Hi @mo123 Can you please update to the latest LE codebase so we can get widevine working again?

I did test Netflix with the new changes but it wasn’t working.
Other addons with Widevine was working.
I think LE still has to add additional patches.

LibreELEC with the 4.4 kernel was discontinued and it will be very difficult to work with it now since it uses the 5.10 kernel.

You can use the latest LibreELEC nightlies, they support all the codecs now like H265, VP9, 10-bit color, 4K resolution, fractional frame-rates correctly which wasn’t working last year.

@mo123 Thanks for your quick response. The rock-pi-4 nightly build is missing the library /usr/lib/ which is required to get the newer widevine to work.

See instructions here:

Any idea why the library is missing in the nightly rock-pi-4 images?

Oh this explains why the lib is missing:

Still doesn’t work though…

Apparently LE upstream is still doing changes for fixing widevine on 64bit arm as we speak. I guess we just have to wait.

Probably this also needs to be merged

And you need the latest inputstreamhelper addon to load the correct Widevine lib for these new glic patches.

I tried those changes and unfortunately they don’t help. For example if we add the arm64tls glibc suffix like Amlogic does and how inputstreamhelper v0.5.6 expects it will continue to download the “newer” Widevine image automatically without prompting, but will fail just the same with an 1044 error.

Unfortunately I don’t have much free time to look into this and I will continue to use my raspberry pi with libreelec 9.2.7 which for some reason works without problems, not sure what’s happening on Rock Pi 4.

@mo123 BTW I noticed everything works on latest nightly LE except for Widevine and the audio jack.

Can you please point me to the change you did in the 4.4 kernel to enable 3.5mm audio jack support? It likely needs to be added to the newer 5.10 nightly kernel.

Needs to replace changes from rk3399.dtsi
i2s0_8ch_bus: i2s0-8ch-bus {
rockchip,pins =
<3 RK_PD0 1 &pcfg_pull_none>,
<3 RK_PD1 1 &pcfg_pull_none>,
<3 RK_PD2 1 &pcfg_pull_none>,
<3 RK_PD3 1 &pcfg_pull_none>,
<3 RK_PD4 1 &pcfg_pull_none>,
<3 RK_PD5 1 &pcfg_pull_none>,
<3 RK_PD6 1 &pcfg_pull_none>,
<3 RK_PD7 1 &pcfg_pull_none>,
<4 RK_PA0 1 &pcfg_pull_none>;

Try to convert it to the same format as in rk3399.dtsi and add to the rk3399-rock-pi-4.dtsi file
3 24 is 3 RK_PD0 1, it works in sets of 8 pins