Enable openssh-server and latest kernel in ubuntu image

Hi radxa team,

I spent the whole last weekend to get the ubuntu image “act” the way I want.

As mentioned in this I would suggest that you provide a new ubuntu (server) image with openssh-server already enabled.
(as it is a server, I assumed ssh would be available right away… but since it was not working, I had to connect the rock pi to a keyboard and display just to find out that I need to manually install openssh-server).

And providing the lastest kernel in the updated ubuntu image would improve the first contact experience with rock pi 4
(details with my issue can be found here

1 Like

We will do that, thanks for the feedback.

There is always the raspi-config utility that could be emulated.
But a simple conf file called first-boot.conf with ssh, wifi, locale that is in /boot and used by the first-boot script could be handy as it can be edited on the machine the image is flashed from.

@jack @RadxaYuntian
Has this been fixed yet? Hope it is a quick fix. I am wanting to use quite a few CM3 boards, and I expect the server image to have ssh-server enabled as default. Very trouble some to setup things on physical hdmi and keyboard.

Other than opernssh-server package, another package to be pre-installed should be wpasupplicant. It is not found on Ubuntu jammy os at least. Without it wifi connection is also broken

I am using https://github.com/radxa-build/radxa-cm3-io/releases/tag/20230330-0135
and it did say “SSH is disabled by default to prevent unauthorized access. Host key will be generated at first boot.”. Need a way to enable it without hdmi / keyboard

We changed our software to enable SSH if there is no monitor plugged in during the first boot: [230331] System Release Notice for ROCK 3C & CM3S IO

You can try with https://github.com/radxa-build/radxa-cm3-io/releases/tag/20230401-0056

Otherwise we will work on new CM3 system a bit later.