Support Ubuntu server

Hi all.
What is the default login + password for Ubuntu please?
I can’t seem to find it.
Thank you.

The default username and password is:

username: rock
password: rock
1 Like

Thanks Jim.
I think I tried root + rock. I was so close, yet so far away.

I tried installing this image into my RockPi4. It boots fine, but doesn’t seem to have the driver for the ethernet adapter.

running ifconfig shows only the lo and wlan0.

So, even if I have already connected the rockpi via LAN cable, I’m still unable to go online to update and get started.

Hi. You need to do this for ethernet :

ifconfig -a
sudo ifconfig eth0 up
sudo dhclient eth0

For wifi it’s this :
sudo nmcli dev wifi connect ESSID_NAME password ESSID_PASSWORD

If you would like to install a desktop, then use this :
sudo apt install lxde (installs only lxde desktop)
sudo apt install ubuntu-mate-core && sudo apt install ubuntu-mate-desktop (to install ubuntu mate desktop)
sudo apt install lubuntu (to install Lubuntu desktop + lxde desktop)

1 Like

I see… I’ll try this later. Thanks for the pointer!

Note to self and to others who will come across this thread in the future:

The eth0 interface will not be automatically raised on boot, even after you’ve manually raised it before.

To have it automatically brought up on boot, you’ll have to make sure that NetworkManager is managing this interface. It can be done by editing the file /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf

Add the following to the exceptions: except:type:ethernet

…so that the contents of the file will then be:


And if you have a need for static ip on your device, create a network profile using nmcli:

Following is an example series of commands:

nmcli con add con-name your-network-prof-name ifname eth0 type ethernet ip4 gw4 ip4
nmcli con mod your-network-prof-name ipv4.dns ""
nmcli -p con show your-network-prof-name

For more details, see the manpage for nmcli-examples here.


I tried running unminimize but I got an error creating directory in init-system-helpers-1.51-all and it stopped.

Whenever I try to install anything on this image, I get errors from dpkg about needing “structure needs cleaning”, and the installation fails. Running apt install -f, apt clean and apt autoclean do not help.

Edit: some web searches suggest that this may be a problem with my SD card or the card writer, so I will try replacing them and see how it goes… Further edit: I tried with a new SD card and a new writer, and that seems to have worked.

Ubuntu image should be using DHCP on Ethernet if available (turned on at least) and allowing SSH access.

User shouldn’t be forced to connect Rock Pi to HDMI monitor and own a keyboard.

A beginner will be lost, especially that there is no network configured.


Just to clarify. Can I download official Ubunto image and do corrections written in notes above and it will work fine?

I don’t think so, because official ubuntu simple don’t know anything about RockPi4B. So, no boot code, no kernel, no drivers, nothing.

You can just download this image from official wiki

That already have ethernet and everything else working

rock/rock does not work for me :frowning: Any ideas for working login details? Installed rockpi4b-ubuntu-bionic-minimal-20190104_2101-gpt to emmc

Erm… Are you sure you typed rock/rock? Not ROCK/ROCK, thatvyou don’t have scroll lock on on the keyboard or different language?

When I type ’rock’ to login prompt, it is all small letters ie. no ROCK or Rock. Assuming that pwd is also small letters. Disconnecting keyboard momentarily or restarting the board does not help.

Maybe I need to take out emmc, boot from sd-card, attach emmc and mount that. After mount vi for needed files passwd,groups etc. Will this work? And is it safe to attach emmc while system runs from sd-card?

Any other ideas, like booting to single user mode via serial, is that possible with these cards?

For some reason it feels like you are using Again, what does happens after you type “rock” as login? Does it ask for password next?

Are you really sure it’s Ubuntu Server? And not Armbian Bionic or Armian Stretch? Or Debian?
For Armbian it’s : root
With Debian it’s : linaro
should work with Ubuntu. I’ll try with a new install.

1 Like

It just works like it should work. With rock and rock.

No, I am not using After typed rock and enter, it asks password. And then permission denied. I’ll flash rockpi4b-ubuntu-bionic-minimal-20190104_2101-gpt.img again into the emmc. Let’s see how system behaves after that.

Re-wrote image to the emmc and after that I was able to login…weird…

1 Like

I’m using latest rock-4c-plus-ubuntu-focal-server-arm64-20221109-1302-gpt.img that is linked to from the radxa website downloads area and these passwords don’t work as root user.

Can anyone clarify the working PW?