Solved! Rock pi 4 a - ubuntu - unable to install apache2

when I try to install apache2, I get the following messages

rock@rockpi4a:~$ sudo apt-get install apache2
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
apache2 : Depends: perl but it is not going to be installed
Depends: apache2-bin (= 2.4.29-1ubuntu4) but it is not going to be installed
Depends: perl:any
E: Unable to correct problems, you have held broken packages.

any hints on how to fix this?
thanks in advance

Hi, It could be a few things check out this article as it covers all options.
How to fix Broken Packages

After having written the post yesterday, I looked at other posts here…
I found some hints about unminimize.

as user rock, i did: sudo unminimize
it asked for confirmation and started to install packages…

BUT: I don’t remember how many time… the system “crashed” and would not recover.
I had to pull the power cable and insert it again in order to boot properly.
Only then I was able to continue…
and a lot times, the system was not able to continue… I had to
sudo dpkg --configure -a

Questions: What might have caused the “crashes”?

from what I read about Rock Pi 4, I could imagine the following:

  1. general instability of the packages (OS)
  2. the CPU getting too hot and the system is stopping therefore
  3. a bad sdcard

Can anyone judge the above options and/or provide a better explanation?

regarding 2)
I use the Rock Pi 4a (4GB) without heat sink or extra fan

regarding 3)
I am right now trying another sdcard (also 64 GB, but more expensive)

Like you I also run Rock Pi 4A’s as I use them as mini servers.
To answer your points.

  1. No Ubuntu 18.04.2 is a stable arm64 OS.
  2. You need a heatsink or the Official Rock Pi Heatsink
    to find the temp of your cpu run $ paste <(cat /sys/class/thermal/thermal_zone*/type) <(cat /sys/class/thermal/thermal_zone*/temp) | column -s $’\t’ -t | sed ‘s/(.)…$/.\1°C/’

mine run at 28 - 32c with the offical heatsink

  1. Bigger more expensive does not mean better. Sandisk & some Toshiba sd designed to work in digital cameras (M203 & ADP-H502 both come with a 5 year warranty).

  2. stabalise your cpu temprature.

  3. boot from sd.

  4. run sudo -i

  5. apt update

  6. sudo apt install openssh-server -y

  7. unminimize

  8. check ip addr

  9. reboot

  10. login through a terminal or putty.

I hope this helps clarify’s where your isue maybe?.


All, I just wanted to let you know what I did in order to solve the issue with my crashing rock pi 4a

As mentioned herehere there seems to a fix for the kernel regarding the powering of the sdcard.
Here is described how to upgrade to the newest kernel.

I did the following steps:

  1. use a power supply which offers 5V=3A
    -> this obviously was much better than the 5V=2A! During the following steps, the rock pi 4a did not crash a single time!

  2. add: deb bionic main
    to the /etc/apt/sources.list

  3. sudo apt-get install linux-4.4-lastest

  4. sudo apt-get install openssh-server
    (this is needed in order to ssh into the SBC from another machine)

  5. sudo shutdown -r now

  6. sudo apt-get update && sudo apt-get upgrade

  7. check on which version my rock pi 4a is now
    uname -a
    Linux rockpi4a 4.4.154-83-rockchip-00023-gae7a309 #2 SMP Fri Apr 12 20:04:24 CST 2019 aarch64 aarch64 aarch64 GNU/Linux

  8. check what release we have installed
    cat /etc/os-release
    VERSION=“18.04.2 LTS (Bionic Beaver)”
    PRETTY_NAME=“Ubuntu 18.04.2 LTS”

Now with the latest kernel installed, I was able to switch back to my 5V=2A supply and it works like a charm!

thanks for your feedback!

I’ll try to get hold of a heat sink asap!

regarding your cmd line the print out the temperature:
this does not work on my side… complains about “column”

paste &lt;(cat /sys/class/thermal/thermal_zone*/type) &lt;(cat /sys/class/thermal/thermal_zone*/temp) | column -s $’\t’ -t | sed ‘s/(.)…$/.\1°C/’

when I run the first part:
paste &lt;(cat /sys/class/thermal/thermal_zone*/type) &lt;(cat /sys/class/thermal/thermal_zone*/temp)
I get this result:
Does this indicate a soc temp of 48 degrees celsuis?

yes, you can try: $ paste <(cat /sys/class/thermal/thermal_zone*/type) <(cat /sys/class/thermal/thermal_zone*/temp) | column -s $'\t' -t | sed 's/\(.\)..$/.\1°C/'
that works for me.

Tnx, but I get this error:
bash: column: command not found
and I did not yet find how to install the command “column”

update: google was my friend :wink:
apt-get install bsdmainutils
now it works fine!
paste <(cat /sys/class/thermal/thermal_zone*/type) <(cat /sys/class/thermal/thermal_zone*/temp) | column -s $'\t' -t | sed 's/\(.\)..$/.\1°C/'
soc-thermal 38.1°C
gpu-thermal 38.7°C

1 Like

Hi, sorry for the delay,busy on the web server. No problem glad to be of some help. Glad to see you worked it out.

With the heat sink it comes with white thermal paste, Which I used on 1 Rock Pi 4
soc-thermal 32.2°C
gpu-thermal 30.5°C
That is a low volume email server.

The other I did with Arctic Silver Thermal paste.
soc-thermal 27.5°C
gpu-thermal 28.1°C
That is a low volume web server.

Strange bsdmainutils were not installed during setup as they were on my setups.

Right the trick in using paste on the heatsink is to put the paste on a X corner to corner.
The get an old credit/store card and spread out the paste in horizontal & vertical strokes, do not worry about over spillage, as that is easily removed with kitchen paper towel with a little lemon juice on it will remove all excess paste, once dry ( a few mins) then fit to Rock Pi 4.
I hope this helps you. And remember all experts were beginners once.


I assume that bsdmainutils was not available on my system because I did NOT unminimize it (since this was not needed anymore after the newest kernel was installed (and the sources.list was updated).

Thanks for the hint with the Arctic Silver Thermal paste! This seems to make a big difference!
Do I understand correctly: first dry the paste before fitting the Pi on the heat sink?
(I would have fitted while paste is wet…)

I intend to use my Rock Pi 4a as low volume web server, too (with wordpress and some plugins installed). The Raspi 3b+ does not have enough RAM… that’s why I chose Rock Pi 4a with 4GB.

O.K you will need to unminimize to be able to build a web server. otherwise you will run into dependency issues which will cause a fail in the install, I know as I have already tried it. Also with unminimize you get a real minimal ubuntu server which means alot of programs are not installed & you will need to build up the server to your requirements (i.e no send mail or postfix installed)

No problem, my bad look at the pics plz.

This is the paste spread corner to corner.


This is after it is spread out, look carefully you will see the marks of thermal paste outside the ridge, i was referring to cleaning that off with lemon juice. once the you have cleaned it up. the thermal paste is in the right place & can not cause issues.
Hope that helps explain what I meant. I am actually moving over to Ghost, as the plugins in the main cms’s are not security validated and that is where the exploits come from.
Same here the Raspi 3b+ did not fit my needs as the mail server needs at least 2gb ram being iredmail. I did get Freepbx to work on Raspi 3b with 15 users & 5 trunks.

Arctic Silver is a thermal grease so it never goes hard.