Boot Order difference between Ubuntu and Debian


#1

Hi,
I thought radxa boot order is sd-card and then eMMC. So when I install Ubuntu image on sd it boots up ubuntu, but when I install Debian image on sd-card it boots from my eMMC card (there is Armbian image installed). Images on sd-card are written with windows etcher. Image on eMMC card is written with dd command on Rock Pi. Any info why boot order with debian is different than ubuntu.
Thanks Norbert


#2

My Debian boots from SD first, have 2 micro SD cards all the same, all flashed with etcher.


#3

The boot order has not caused confusion for the first time. :wink:



#4

I guess the chance is your SD card image doesn’t have the correct boot partition so Rock Pi skipped it.


#5

Just tried again and it works. Booting Ubuntu from sd when inserted. Don’t know why it did not work last time. I also did get my M2 extender today and it works fine with my samsung. I had to order longer connection cable so I can change sd when M2 Board is installed. When everything is ready I will try the different images.
Thanks


#6

I’d check if inserted the microSD card in the right direction, make sure the connector side always face the circuit board.


#7

Yes, I noticed a change in boot order when I upgraded from Debian armhf to the recent build of Debian arm64. Prior to the upgrade, I could boot from uSD (then mount the SSD to extract an image onto eMMC, overwriting the existing OS). Now, the 64 bit build ignores the uSD and USB during boot up.

Shouldn’t there be a subroutine at the beginning of the boot process that checks for bootable removable media, prior to loading the OS from eMMC?


#8

In my experience seems to be related to the microSD card, if I had the fastest SanDisk in, it will always boot from there. If I had the slow PNY card in, the booting sequence seems to be random :smiley:


#9

I have the fastest SanDisk and the booting sometimes is still random


#10

You nailed it again! It was the uSD, even though I have always purchased the fastest Class 10 SanDisk media.
Waliworld only had more of the same… except for one PNY uSD that was rated for 4K video. So, I figured I had little to lose and it worked!

Thanks !

BTW, is it possible to replace an OS that’s currently running? That’s a no-no in Windowsland w/o rebooting into a another OS as part of the process.


#11

I believe (which mean I can’t prove it) it’s the “boot loader” - which is comparable to BIOS in PC, resides in the on-board flash and loads u-boot from eMMC/microSD has a short timeout setting, it gives that much time for microSD to boot, or goes to eMMC if microSD doesn’t respond in that period of time. The pricier microSDs got shorter latency.

But if you reboot while the microSD is still “hot”, it will response quick enough, so you will almost certainly boot from microSD if you “reboot” when microSD is mounted.

There is a package called ksplice to “hot swap” the kernel in Linux, I don’t trust it, and it doesn’t seem to be available to Debian stretch. but again that’s beyond my knowledge.


#12

Thanks for the reply & explanation. Would be nice to be able to extend the timeout setting. But, I like the reboot hot uSD trick. Gonna try it on the SanDisk uSD, just for laughs.
While this solved my problem with being able to replace my OS, the reason it was necessary still exists. The issue is that YouTube videos are reporting “Audio rendering error. Restart your computer.” That is, if audio works at all.
Doesn’t happen on the 32-bit Debian build and I have downloaded and installed the arm64 image twice, with the same results.

1: Chromium will ONLY play audio if the rockchip,es8316-codec has been configured to ‘Analog Stereo Duplex’ or ‘Analog Stereo Output’ PRIOR to launching the browser. Without this, Chromium Playback doesn’t appear under the ‘Playback’ tab.
2: Audio still doesn’t make it to HDMI analog output unless the rockchip,es8316-codec is changed to either ‘Analog stereo input’ or ‘off’.
3: Close and re-open Chromium, YouTube videos have no sound, again.
4: Repeat step #1.

The ‘Audio render error…’ seems to happen during playback of movie trailers, but not Explaining Computers videos (unless it is paused for a while). I think the error is occurring whenever the video stream is interrupted (ads). Haven’t been able to playback videos at all on other sites, like CBS or MSNBC. Player doesn’t seem to load. Probably needs Flash or something.

Need to get some locally stored sound & video files for further testing.

Didn’t want to burden you with this. Surprised that no others have reported this.