Armbian images are now available for Rock 5b!


Hello Everyone!

Just wanted to stop through and make sure everyone with a Rock 5b had an opportunity to check out and test the Armbian Legacy images which have been produced!

You can find our current images linked at the bottom of the Rock 5b download page on our site! For Rock 5a images read text on download page.

For those of you with a Rock 5b, please check them out and feel free to give some feedback either here or in our forums on your experience!

While you’re here, please take a moment to fill out our poll!

Please let us know if you have tested the Rock 5b image and how you feel about them:

  • I tried Armbian on Rock 5b and it doesn’t work :frowning:
  • I tried Armbian on Rock 5b , it is awesome and works great, some might say it even ROCKS! :slight_smile:
  • I don’t have a rock 5b and want one
  • I am not interested in Rock 5b at all and have no idea why I am reading this, someone send help!
  • A Rock What?! Who is 5b?

0 voters

I meant it to be a single selection poll but it won’t let me change it now, @moderator if you see this in time please feel free to update the poll. Thanks.

Thanks for your time and have a great day!



Is there any video reference to understand better what is this armbian images all about? Is it like… the oowo bios kinda of thing?

1 Like

Armbian is a Linux distribution for ARM single board computers.
It provides both Ubuntu and Debian images with a wide variety of desktop flavors for about 100 different SBCs and even x86/AMD64 and aarch64 UEFI.
Also Armbian provides a flexible build environment to build your own images with whatever configuration you’d like.


Super Thank you NicoD.

Just tried, it boots up and get into the desktop well, and is a more polished distro than the official ones.

But I found that the GPU driver is not working/no driver at all. Both the XFCE and the browsers are running on llvmpipe. Is this a license issue or it is just not working yet?

1 Like

armbian never support those libmali closesource shit in its images.

1 Like

The guy throwing out videos about Armbian doesn’t understand what he’s talking about :slight_smile:

It’s a build system relying on Debian-style tools and as such produces OS images that rely on either the various Debian or Ubuntu distributions:

Of course it did: video acceleration and ‘libmali closesource shit’ especially for cheap Allwinner boards running on an ancient 3.4 kernel was what made Armbian popular half a decade ago. Maybe the project’s biggest mistake so far (attracting the ‘wrong’ target audience).

Today I tried it an nvme SSD, and it seems like nvme boot is not working. Seems like it would need a special SPI image.

I am using pretty much standard eMMC boot, NVME root without any issues. Trying to use it as a GitHub build runner. Its resourceful enough to assemble images, but compressing and signing is slow.

arm-04:~:% df
Filesystem     1K-blocks     Used Available Use% Mounted on
tmpfs            1609748     9800   1599948   1% /run
/dev/nvme0n1p1 960302804 18380108 893068236   3% /
tmpfs            8048732        0   8048732   0% /dev/shm
tmpfs               5120        4      5116   1% /run/lock
tmpfs            8048732        0   8048732   0% /tmp
/dev/mmcblk1p1  14906688  8182300   6541752  56% /media/mmcboot
/dev/zram1         47960      996     43380   3% /var/log
tmpfs            1609744        0   1609744   0% /run/user/1000

In case you wanna run Docker, this is the workaround:

update-alternatives --set iptables /usr/sbin/iptables-legacy
update-alternatives --set ip6tables /usr/sbin/ip6tables-legacy

Great news! Looking forward to trying it when I get my Rock 5b.

Does the Legacy in Armbian Legacy refer to it is using the Radxa BSP 5.10 kernel rather than a patched mainline kernel?

1 Like

And for kubernetes on debian:

apt-get install iptables ebtables arptables

update-alternatives --set iptables /usr/sbin/iptables-legacy
update-alternatives --set ip6tables /usr/sbin/ip6tables-legacy
update-alternatives --set arptables /usr/sbin/arptables-legacy
update-alternatives --set ebtables /usr/sbin/ebtables-legacy
1 Like

GUI locks up after a few mins of trying to use - so will try will have to try another disto


Does it work with Radxa images without freezing? The reason I ask is we have seen at least one Rock 5b development board on which the GPU doesn’t work correctly and does what you are describing in any GUI or when video framebuffer is used. Do you see any graphical glitching on screen as well? If it does work on Radxa’s images, then you should check the power supply you are using to make sure you have enough power, it would be best to run it at 12V+ for higher workloads and when using m.2 drives.


or compatible nvme :slight_smile:

Did not notice any glitches on screen when running Armbian
Running on Radxa Debian image and see not to freeze but I am seeing some graphic glitches
Not using m.2 drive at moment
Will double check power output

With the Radxa Debian images, I notice a lot of graphical issues myself, but I assumed that they were driver issues.

With Radxa Debian, opening Chromium and going to works fine for a low number of fish, but when increasing it to higher numbers I see a lot of half-rendered frames and cases where time appears to go backwards. Is this something uncommon or is every board affected?

I think there is something wrong with the build - Radxa Debian build ran good no issues,
But armbian when running hardinfo benchmarks first time it crashed / rebooted, 2nd time ok will do more testing, anything log wise that might be useful?

Rebooted again when trying to sign in to google aaarrraahhh - going to try twistedOS and see how that fares

We are building images with Rockpi 5 and it never crashed. Some devices are faulty …

You know how to change wallpaper? Do you think that will have any influence on functioning?