Zero 3E not booting

I recently received a Zero 3E 1GB version which won’t boot. The behavior is similar to:

Which does not make any sense to me if this were the same problem, since the 3E does not even have a physical maskrom button.

I have tried out a lot of images including:

b3-cli, b6-xfce from:

debian bookworm minimal kernel 6.1.43
debian bookworm minimal kernel 5.10
ubuntu jammy server kernel 6.1
ubuntu nobel server kernel 5.10

from:
https://www.armbian.com/radxa-zero-3/

No video output on display, no serial output on UART (tried both flow control xon/xoff and none), only the green light is lit up.

And the other 2GB Zero 3W booted on all versions above. In addition, this board had the same camera connector issue as described here:


Which is probably not the root cause of my problem.

One thing I noticed was, that the 3E and 3W have different RAM module, the 3E is from SAMSUNG and the 3W is from SK Hynix. Thos armbian at least, uses the same lpddr4 and lpddr4x settings for both board in the dtb.
Note these are the only two files i have found those are zero 3 realted. They do not differ at all in the RAM section. The armbianENV file specifies to load the rk3566-radxa-zero3.dtb.

This is the only thing I could figure. Also, I have 2 questions:

  1. Does anyone have the same problem with the exact configuration (3E 1GB SAMSUNG RAM)?
  2. How can I determine whether the board is faulty without using a multimeter?

Am asking these questions mainly to determine whether I should throw that one away or keep it for future support. Also to decide whether to re-purchase the same model again to finish my project.

Thank you for your time reading!

Hi @Max_j I got my Zero3E yersteday and had the same problem I spend all evening on that trying different uSD/images/PSUs. solution was to make a good clean of uSD connector with IPA. Also at the back where Card Detect pins are.

@minie I have so many questions, but let me thank you first! Thank you so much!

This helped me a lot! I nerver doubted the micro SD slot, then only to find out later:

My SD detect pin is not even making contact… Bent this together and it worked flawlessly!

Again, thank you very much!