Radxa Zero not booting Question

Hi there, I recently got started with my Radxa Zero had some trouble getting it to load Twister to eMMC. Last night I succeed, but shortly failed after trying to erase a microsd that I’ve been trying to get working again. I’m now back to the issue that I was originally dealing with, which is my radxa zero not booting at all- nothing on the monitor, just the green light. It appears to be going into maskrom mode immediately. I tried following the same steps as I did last time to get it booted, but it’s not doing anything. Currently I am able to get it into fastboot and udisk mode. Udisk mode has not been looking like there was a partition on it after copying the image to the eMMC storage though. MicroSD cards also wont boot.

Any advice? I’m not finding much about being stuck in maskrom mode.

Using fastboot, flash u-boot.bin to eMMC and this will allow you to boot from uSD(microSD) again.


Thank you so much, I was trying to do that through DD. It finally worked when I did it instead of fastboot-loader.img.

1 Like

Tried flashing the rz-fastboot-loader.img and u-boot-bin and it succeeded in stopping the maskrom mode but there is no way to start it in udisk mode.
Still having problems and I cannot boot the system or flash new one or even format the emmc.