X2L won't boot at all - just a single flash of the red LED

I was waiting until I had a suitable heatsink before powering up my X2L board for the first time and I installed a heatsink yesterday, but when I tried powering up the board nothing seems to happen. There is no display from either HDMI port or any other indication that the system is attempting to boot. I have a brand new CR1220 CMOS battery installed.

The LED light next to the power button flashes one time as the power cable is installed and then nothing else happens. I have tried 4 different USB C PD power adapters and 3 different USB C cords with the same result.

I tried removing the M.2 NVME drive and the M.2 wifi/BT module and booting without those but the results are the same.

please advise.

Even you install a CR1220 battery, the first time boot still takes around 1 minute and the white led will be on. The red led should be always on before the white led is on.

1 Like

Hi,
You can remove all devices, including the heat sink, and try connecting only the power supply to see what happens. Don’t worry, the CPU’s TDP is very low, so it can work for a period of time without a heat sink.

If the situation remains the same as before, you can try resetting the SBC by pressing the clear CMOS button on the back for 5 seconds.

The LED is keep RED or just flash it?
You can try to clear CMOS, follow the instruction here.

Hello, when I connect the power supply, the LED flashes red one time then turns off. Nothing else happens after that no matter how long I leave the power supply plugged into the board. I have tried removing all of the devices from the board including the cr1220, and the results are all the same. I have also tried resetting the CMOS. It seems to be a bad board.

I found that the metal base of the heat sink on the M.2 M key NVMe drive I used was shorting out some of the components underneath it when installed. I unplugged everything, added an insulator underneath the NVMe SSD heat sink, remounted it, and plugged everything in. Then it powered on normally.

Note this may happen with some NVME SSD’s even without an extra heat sink, since some have metal foils as their labels.

1 Like

Thanks, that doesn’t seem to be the case here.

I am using a 256GB Inland Professional 3D TLC NAND M.2 2280 PCIe NVMe 3.0x4 with no heatsink and the bottom face of it is non-conductive. I have tried booting with the M.2 NVME installed on the X2L as well as removed just to see if the board would show any sign of life, but the X2L seems to be DOA no matter what I have tried.

Hi friend, can you take the clear photos for the top/bottom board, we can check if there is obvious damage?

Thank you. Here are the photos of the top and bottom of the board.

The photos looks fine.
another thing: please make sure connected PD power adapters have 12v output, do not use DC 12V USB-C, if sure, looks like the board is damaged.
we kindly request that you contact your respective dealer or retailer to initiate the replacement process. They will provide you with further instructions.

Thank you. I have contacted Allnet. They are starting the return process but they indicated that they don’t have any 8GB boards in inventory so it might take some time to get the board replaced.

This is my USB analyzer showing that current is actually going to the board and my 30W USB PD is delivering 12.02V

The nominal voltage is 12 V, that is right

This was an 8GB board that cost $72+ shipping for a total of around USD$85 when I purchased it. Since it was delivered in non-working condition, I have been asked to return it to the retailer, which is understandable but the lowest cost I can find for return shipping is around USD$40, which is over 50% of the price of the board in the first place. Does anyone know a good shipping option from the US to China that won’t cost me so much? This is a package that weighs under 300g with all packaging materials.

I have exactly the same issue.
I succeeded at booting once when received, but after a few days, it started doing the same : quick red flash, fan running, but nothing happens…

@Mathieu_Grenonville I am sorry for the issue you met. Can you take a video and upload somewhere so that we can check? Thanks.

Hi friend, can you try to change another PD adaptor or cable? Dose “Clear CMOS” can fix the issue? during a few days, the board is heavy running or just power off?