[X2L] Freezing when attempting to run Windows installation

Hi, I’d posted about this earlier in another thread but it’s probably best separate here.

Radxa X2L
Official heatsink/fan combo
CMOS battery installed
Radxa Power PD 30W
Crucial P3 PLUS 500GB NVME

Accessories plugged in:
Keychron K10 Keyboard (USB)
Sandisk UltraFit USB (256GB - Windows installation media)

Every time I attempt to install Windows 10 (from various USB drives), it will always hang randomly. Sometimes it doesn’t even make it into the setup, it’ll just hang on the splash screen where it shows the spinner, and there some artifacts in the framebuffer during this time:

I’m yet to try linux but the main reason I purchased this board was cause it could run Windows. Is there anything special I’m supposed to do? I just used the windows installation media tool to create the USB media “MediaCreationTool22H2.exe”.

Maybe you should try a live Distro to be sure the card is working, then investigate Windows with some knowledge?

Are you sure that you are using GPT–>UEFI as Rufus options?

Tried with rufus as well, making sure I was using GPT -> UEFI, same issue. It feels like some incompatibility with the windows installer/setup process, has anyone else had any issues?

I successfully managed to install linux mint (from that same USB that windows kept freezing on), although I had to boot through compatibility mode (live distro) and then run the installation from there because their default installer also hung.

Can you please provide me with the download link for your Windows installation media? We have tested it, and Windows installation does not have this issue.

I’m going to https://www.microsoft.com/en-us/software-download/windows10%20 and then downloading the tool to create a windows installation media.

I even used it and selected the ISO option and burned it to a DVD DL disc (as well as trying the ISO via rufus), it still it hangs during the install at the step after “Copying files (100%)” and then eventually reboots. Where should I be obtaining Windows 10 from?

Your image seems to be fine. For convenience, we directly use the tool Ventoy to place the ISO image and boot from it. You can try using this software as it may perform some special handling. By the way, Ventoy is a fantastic tool.
However, I feel that it may not solve the problem, so I recommend resetting the BIOS and then trying again. You can refer to the Restore Factory Settings guide for instructions on resetting the BIOS.

I’m having exactly the same problems. Using Ventoy or restore factory settings didn’t help.

I had a similar problem with Windows 11 install.

I had done one install on one X2L with a 1TB SSD and worked. Tried a second X2L with another mfg 1TB M.2 SSD and it hung on install. Tried a second SSD that was the same style of 1TB M.2 SSD as the first X2L and it worked. Not sure of the difference, but the drive that would not work, formatted for NTFS file storage externally.

Hello, could you please check the differences between the two boards? Specifically, I would like to know if there is a WiFi module and if the BIOS versions are the same.

I still have this issue and the board has been sitting for months. The only thing haven’t changed is the m.2. SSD. Would be nice to identify the issue, I can provide whatever info you need.

Please attempt to update your BIOS.

If you are referring to me, both my X2L’s have the AMI 2.19.1268 version BIOS and both have the WiFi boards installed.

You should look here. This is the build version number.

The latest version should be 014 now. It’s not 011 as shown in the image.

Both of mine say PS006.011 x64 as delivered. These were from the first batch of X2L’s. Will work on the 014 update.

One of the new batch arrives tomorrow to check.

What’s the difference between the v13 and v14 bios?

Herr the data of my Board

Bios PS006.14 x64
Build Date 02/21/2024
Wifi Module
Crucial P3 Plus 1TB

Can you try using SSD from other brands? It is preferable to choose one that is included in the X2L supported list.

Updating the BIOS didn’t fix it. I bought a Lexar NVME and that fixed it.

The new X2L board arrived. To test, I started with the M.2 SSD 1TB SSD board that works for the other X2L’s. That worked correctly as before.

Will try the M.2 1TB SSD board that did not work with the latest BIOS. The board came with PS006.13 x64 installed, so will have to update it.