Write speeds JMS561

I was wondering what speeds people are seeing when writing to discs over the JMS561? The spec says they can do 400 Mbytes/s however I am seeing significantly less.

My setup:
Macbook wired to Pi over gigabit switch - 940 Mbit/s with iperf (~117 MByte/s)
4TB WD Red NAS HDD - Max 150 Mbyte/s
JMS561 SATA Hat on Pi - 400 Mbyte/s spec
Samba share from Pi to Macbook

Taking overhead into account I would expect something around 100 MByte/s when writing over the network, however I am only seeing between 25-30 Mbyte/s right now… My feeling is that Samba is to blame, I am going to give NFS a try and see if that helps.

What is everyone else seeing on their setups?

Use dd or iperf directly on Raspberry Pi to get more accurate data.


I’ve had ~11500 kB/s (11.5 MB/s) write speed on Rock Pi via samba when my home Ethernet was 100 Mb/s.

Later and for now I have ~115000 kB/s (115 MB/s) write speed in the same situation but I’ve changed Ethernet to 1 Gbps.

On stand-alone Rock Pi and SSD drive connected via USB 3.0, when I test the write speed I’ve got 240 MB/s writing simple file of NULs. In the same situation when I write to eMMC, I have 134 MB/s.

I used iperf to test the connection speed, I get 940 Mbit/s

I used dd to test the write speed to the HDD, I got ~150 Mbyte/s with multiple block sizes

So I am pretty confused why I am getting max 30 Mbyte/s over the network…

I ran an additional dd test writing to the SD card in the Pi instead of the Sata HDD, and this test got 30 Mbyte/s, which is about the same speed I get over the network…this leads me to believe the data is somehow first being written to the SD and then copied to the HDD, but this seems strange.

Any ideas?

Run iotop command when copying from samba, check which speed exactly it is.

I ran iotop and got between 24-31 MB/s for the Total disk write. The Current disk write jumped all over the place so I am not sure how to interpret that.

root 0.00 B/s 24.05 M/s 0.00 % 0.00 % mount.ntfs-3g /dev/sdb /media/share -o rw,nosuid,noexec

I have tried Samba and NFS, both gave same results. I also tested a linux, windows and osx client, all gave the same result. I am running out of ideas, the only idea I have is to try out some other versions of the firmware, I am currently on the latest version.

Aha! The culprit is ntfs.

Try to use ext4 or another Linux filesystem.

1 Like

@setq Yes, NTFS is treated differently. I’ve already posted in other thread, that speeds on NTFS are amazingly low. And I also got max 30 MB/s.

Wow, thank you! I would not have thought of that.

I just plugged in an ext4 drive I have, huge difference.

Copying directly via the finder to samba connected share, I see ~100 MB/s on iotop.
CPU usage reaches 90% on 1 of the cores.

Using rsync over ssh I am maxing out around 60 MB/s.
CPU usage reaches 100% on 1 of the cores, so I think this may be CPU limited by the Pi.

FYI I reformated both my drives to ext4 and I now see ~110 MB/s over my network, very pleased! :slight_smile: