USB touch screen support on Android

Can’t get my USB touch screen work on ZERO, Tested the touch screen on ROCK PI4&ASUS Tinker board, all worked fine.
It looks like most of the amlogic devices such as S905/S912 does not have the usb touch screen support on android system, I’ve tested the touch screen on several S905/S912 TV boxes, None of them worked.

Mmmm… I wonder if it does on s922x.

Checked config, It seems the usb touchscreen driver was not enabled by default,trying to rebuild the image.

1 Like

Is that still true? Would be nice to have it by default (didn’t receive my zero yet, waiting for it).

Tried the latest image, not working.
It turned out my usb touchscreen is an HID touchscreen, No special driver needed, but the kernel only have hid-generic device driver loaded.
Then I compiled the image with:

Touch screen worked.

1 Like

How did you compile with those flags? Can you provide the steps?

those are kernel config options, throw then into the appropriate kernel defconfig and recompile the kernel

Can you send me a recompiled file that supports touch? thank you.

Whole image is around 900MB, So I compiled the hid-multitouch driver and send you by email, you can test it by following step:

1.Connect zero via adb

2.push the hid-multitouch.ko file to the device:

adb push hid-multitouch.ko /system/vendor/modules/hid-multitouch.ko

3.Try insmod to load the driver to test the touchscreen,This will take effect immediately.

insmod /system/vendor/modules/hid-multitouch.ko

1 Like

I edited the config file at following place:
It took a little while to find the config file which takes effect, maybe there are other config files might takes effect too, But this one seemed work for sure.

Hi please, could you send mr your image to me as well?

Thank you so much!

I uploaded the image on my NAS
user: radxa
password: radxa
The launcher is different from the official image, maybe the source code which I downloaded is quite early, I didn’t change anything about it. only add the touchscreen driver.
everything seemed work fine with some minor bugs.

Individual touchscreen driver is located at:
you can test it before you download the whole image.


@huzy Can you please give access to your nas , I tried to download img file but can’t connect to ftp my connexion get refused
Thanks in advanced

any updates concerning from where i can download the imagefile

Stopped the ftp service since there is no connectivity after several weeks…

FTP is available now.

Hi huzy, is the .ko driver file available still? I can give my email to send to. If possible, it might be nice to upload it somewhere like mega or google drive so you don’t have to use your own ftp. Let me know!

FTP is still available, try with user name and password as “radxa”
Can’t get access to google drive because of knowing reason.

1 Like

Through your method, after loading the driver, the touch function is turned on smoothly. However, the USB interface cannot work after you swipe into the ROM provided by you. What’s the problem?

Olá amigo confuso! No meu Radxa funcionou corretamente com som e touch, vc teria uma imagem que não fosse para AndroidTV e sim para tablet com os opengapps? Pois queria usar meu Radxa e minha tela como um tablet para testar meus apps que desenvolvo para o Google.
Ou será que a partir de sua imagem Android, seria possível instalar uma versão da LineareOS?

I suppose you are using the usb3.0 port for touchescreen, The USB2.0 port was set to slave mode by default, therefore you can’t use the USB2.0 port for other device, this is an hardware limitation, has nothing to do with the ROM.
However, it is possible to use the USB2.0 port as OTG, but you need to do some tiny modification on the PCB, I did it several months ago and it worked fine(USB2 for touchscreen and USB3 for another device).