Ubuntu Server - ARM64 for Pi4

Installation of Ubuntu Server ARM64 for Pi was successful. (20.04LTS)

Python3 will need to be installed post boot.
The tophat fan script will run without issues. Fans come on and operate as expected
All drives on SATA hat work as expected
The oled.py install script will error out do to a bad file reference, so no oled display as of now.

OMV is NOT supported on Ubuntu Server ARM64. You will get an “incorrect version” error on the install script.

I also managed to get it to work on unbuntu and manjaro without issues, everything works, but I didn’t use the script, did it manually

As a suggestion, make sure you have pip and gcc installed and do:

sudo pip install Adafruit-SSD1306

Might solve the display issue
I’m on manjaro at the moment so can’t replicate what I did on ubuntu, also I think I installed RPi.GPIO

sudo pip install RPi.GPIO

good luck

on the original install script I see this:

Building wheel for spidev (setup.py)…error
ERROR: Command errored out with exit status 1
ERROR: Failed building wheel for spidev

Also get a:

FileNotFoundError: [Errno 2] No such file or directory: ‘/boot/config.txt’

unable to execute ‘aarch64-linux-gnu-gcc’ No such file or directory

I will give PIP task a try, thanks!

This one still errors out.

sudo pip3 install Adafruit-SSD1306

Same wheel error. My default pip is pip3.

do you have gcc installed? also check if you have setuptools
try installing this and give pip a try:
sudo apt install build-essential

Yep, already installed gcc. Ran the command you noted.

“build-essential is already the newest version (12.8ubuntu1)”

pip will not run under sudo.

it will run outside of sudo but I get the same wheel error.

make sure you have python-dev(python3-dev) and git and try the manual way:

git clone git://github.com/adafruit/adafruit-beaglebone-io-python.git
cd adafruit-beaglebone-io-python
sudo python setup.py install


Sorry for so many comebacks. It finally worked.

To respond your last post I confirmed the following:

  • Installed python legacy
  • ran the git clone
  • ran the python command (which errored out due to a GCC error)
  • ran “sudo pip install Adafruit-SSD1306” (which errored out)
  • ran “sudo pip3 install Adafruit-SSD1306”

Which ran perfectly and installed. The oled display now works.

So it appears I was missing the legacy python at the start. (sudo apt-get install python)

My apologies. I have rebuilt this Quad SATA NAS on several OS’es and probably lost track of what I had installed.

in lsblk I see the 4 drives listed as expected. (sda, sdb, sdc, sdd)

But when I run the disk utility, it shows only 2 physical drives (4 are installed) and they show as 1.

sda and sdc
sdb and sdd

I can mount sda and sdb, but not the rest.

The partition manager shows them as “unallocated” and cannot acquire them.

I only highlight this because this was not an issue on Raspbian. Ubuntu ARM64 seems to detect them but can only allocate 2 of them for mounting.

glad it worked, as for the other stuff I assume you are referring to the gnome app, honestly i never even opened it :slight_smile:
if lsblk shows the drives could be something related to the app itself, you could try gparted, or partition them with fdisk and mkfs, or mdadm for raid.

Agreed. That is next.

I have tried various GUI’s on top on Ubuntu Server ARM64.

Kubuntu, Lubuntu for ARM all overheat the CPU and it hangs. Xubuntu seems to be working w/o a hang. That Pi4 CPU will need a better heat sink I am thinking.

MATE for ARM will load, but none of the menu items work. I can modify the Wifi, but the GUI is non functional. Not even a terminal will come up.

Since OMV wouldn’t load, I was setting up shares on Samba and that is when I noticed the drives wouldn’t mount properly.

Interesting work in progress. Thanks again for the feedback.

I don’t remember needing Python legacy when I installed it, but some stuff might need a package called python-is-python3