Stuck in broken hardware RAID

Hi there,
First post here :slight_smile:

I’m using RPi 4B 2Gb with Quad SATA Hat with 4 HDD (2x1TB & 2x 750GB) and I was trying to use the hardware RAID capabilities provided by the JMS 561 controller, as already described there:
Setting up HARDWARE RAID with QUAD SATA-HAT (jms561 controller)

After having created by RAID 0 array and “played” with it, I wanted to remove it in order to use mdadm again.

I used the following command to delete my RAID array:
JMS56X>dr c1 r0
And got that kind of output:

RAID Port  = 0
RAID level = 0

But my array is still present (sdc here):

flo@raspberrypi:~ $ lsblk
sda           8:0    0 931.5G  0 disk
sdb           8:16   0 931.5G  0 disk
sdc           8:32   0   1.4T  0 disk
mmcblk0     179:0    0    29G  0 disk
├─mmcblk0p1 179:1    0   256M  0 part /boot
└─mmcblk0p2 179:2    0  28.7G  0 part /
flo@raspberrypi:~ $

And when I’m trying to get the raid status:

JMS56X>sr c1
-- Raid[0]
------ ModelName       = H/W RAID0
------ SerialNumber    = 2TVVSVZELAOP9BMRVKRY
------ Capacity        = 1397 GB
------ RaidStatus      = Broken
------ RaidLevel       = RAID 0
------ RaidMbrCount    = 2
------ RebuildPriority = 3
------ RaidMember[0]
--------- Ready        = 1
--------- LBA48Support = 1
--------- SataPage     = 0
--------- SataPort     = 0
--------- SataBase     = 0
--------- SataSize     = 698 GB

The RAID status is BROKEN.

Both controllers FW were up to date, and I tried to flash them again but changed nothing.
I also tryed with the Windows JMS Raid Manager and I get an error when trying to remove my RAID.

And last but not least, this RAID array is completely unusable:

flo@raspberrypi:~ $ sudo fdisk /dev/sdc

Welcome to fdisk (util-linux 2.36.1).
Changes will remain in memory only, until you decide to write them.
Be careful before using the write command.

fdisk: cannot open /dev/sdc: Input/output error
flo@raspberrypi:~ $

Anyone have an idea to “reset” completely the controller?
Thanks in advance :slight_smile:


After having spent a few hours on the subject, appeared that one of my HDD (one of the RAID array) was 16k hours running, and had a few SMART failures, replacing it solved the problem.
JMS Controllers are fine :slight_smile: