SSD not visible in OMV6 neither in the terminal

Hello community,
I’m new to this forum and need some help with my 4x SATA HAT.

Am running a raspi4B 2GB with raspi-OS-lite and OMV6 6.0.14 (Shaitan). Want to run a NAS application.
On the raspi attached is a HAT ‘quad SATA’ from allnetChina.
For the HAT I followed the instructions from wiki-radxa-com site.

I could install the SW by executing the one-liner:
curl -sL | sudo -E bash -

After that in OMV6 the SSD is not visible. Looking for it in the terminal fails as well.
I am usinig an internal new SSD 2TB Ultra from SanDisk. Tried it on all of the 4 SATA interfaces of the HAT. LED at the attached connections is ligthing blue permanently when attached.
BTW: does anyone know, what the LEDs and their colors and their kind of flashing or permanent-lighting are indicating? I really miss any kind of documentation for the HW.

Tried to find the SSD with different terminal commands like:
but cannot find anyting of it.

Running command:

pi@raspberrypi:~ $ systemctl status rockpi-sata.service
● rockpi-sata.service - Rockpi SATA Hat
Loaded: loaded (/lib/systemd/system/rockpi-sata.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2022-02-27 20:06:29 CET; 1min 42s ago
Main PID: 462 (python3)
Tasks: 6 (limit: 1831)
CPU: 3.035s
CGroup: /system.slice/rockpi-sata.service
├─ 462 /usr/bin/python3 /usr/bin/rockpi-sata/ on
├─1015 /usr/bin/python3 /usr/bin/rockpi-sata/ on
├─1016 /usr/bin/python3 /usr/bin/rockpi-sata/ on
├─1017 /usr/bin/python3 /usr/bin/rockpi-sata/ on
└─1018 /usr/bin/python3 /usr/bin/rockpi-sata/ on

Feb 27 20:06:29 raspberrypi systemd[1]: Started Rockpi SATA Hat.
pi@raspberrypi:~ $ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
pi@raspberrypi:~ $ blkls
-bash: blkls: Kommando nicht gefunden.
pi@raspberrypi:~ $ lsblk
mmcblk0 179:0 0 29,7G 0 disk
├─mmcblk0p1 179:1 0 256M 0 part /boot
└─mmcblk0p2 179:2 0 29,5G 0 part /

Tried to upgrade anyhow, but failed:

Auflösen des Hostnamens wiki-radxa-com …
Verbindungsaufbau zu wiki-radxa-com ||:443 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 200 OK
Länge: 434393 (424K) [application/zip]
Wird in »« gespeichert. 100%[=============================================================================>] 424,21K 364KB/s in 1,2s

2022-02-27 20:09:41 (364 KB/s) - »« gespeichert [434393/434393]

pi@raspberrypi:~ $ unzip
creating: jms561-fw-update/
inflating: jms561-fw-update/jms561b_v8.1.3.6.bin
inflating: jms561-fw-update/JMS561FwUpdate
pi@raspberrypi:~ $ cd jms561-fw-update/
pi@raspberrypi:~/jms561-fw-update $ sudo ./JMS561FwUpdate -b backup.bin -f jms561b_v8.1.3.6.bin -d /dev/sda
Backup Firmware file name: backup.bin
Update Firmware file name: jms561b_v8.1.3.6.bin
ERR : open device fail
Get Bridge version FAIL!

ERR : open device fail
Read Back to Backup Error!!

The display on the top PCB is working and showing information as it should.
After searching for similar threads I found some from the year 2020 and 2021, but those could unfortunately not help me so far.
Appreciating any kind of help and hints and of course also the explanation for it, as I want to understand it and learn something! :slight_smile:
Does someone knows why I cannot see the SSD?

Hello. Will the drive be recognized before the OMV6 is installed?


Unfortunately not. I tried it like this as well:
flash raspi OS lite on SDcard

install quad SATA HAT software by:
curl -sL | sudo -E bash -

Also in this order above I cannot see the SSD.

Is the blue led light of the hat on?

Yes. When starting up, first red is blinking, then blue is blinking (some self tests I guess) and then blue is on permanently.

Also just reattached the USB bridge. Did not help.

When I use a USB3.0-to-SATA adapter to connect the SSD with just the raspi, than it works.
Then I can see the SSD in OMV6 as well as in the terminal by command lsblk:

pi@raspberrypi:~ $ lsblk
sda 8:0 0 1.8T 0 disk
└─sda1 8:1 0 1.8T 0 part
mmcblk0 179:0 0 29.7G 0 disk
├─mmcblk0p1 179:1 0 256M 0 part /boot
└─mmcblk0p2 179:2 0 29.5G 0 part /

Or lsusb:
pi@raspberrypi:~ $ lsusb
Bus 002 Device 002: ID 152d:1561 JMicron Technology Corp. / JMicron USA Technology Corp. JMS561U two ports SATA 6Gb/s bridge
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Maybe a HW defect in that case… Is there any way to check the HAT or the USB-bridge in a relative easy way?

Do you have an A-A cable? You can use to connect a computer to the hat or the raspberry pi to the hat.

Thought about such a cable to test the connection. Do not yet have one, but I think I will order one.

Now I got me a A-A USB3.0 cable to connect the raspi with the HAT, but still don’t see the SSD.
Is there anything more I can try?

During installation the following message came up:

WARNING: The directory ‘/home/pi/.cache/pip’ or its parent directory is not owned or is not writable by the current user. The cache has been disabled. Check the permissions and owner of that directory. If executing pip with sudo, you should use sudo’s -H flag.

I fixed that warning by creating the directory:

pi@raspberrypi:~ $ mkdir .cache
pi@raspberrypi:~/.cache $ mkdir pip

Still cannot see the attached SSD.
Does it make sense to integrate this in the script? So when the directory is not yet existing it will be created by the script. By that the warning could be fixed/skipped.

So far one warning remains:

WARNING: Running pip as the ‘root’ user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead:

Can this be a reason why I cannot see the SSD or can I neglect this warning?

Does anyone knows what the red and blue LEDs of each SATA socket is indicating when it is:
=> lit permanently
=> blinking (in what ever different kind of pattern)
=> etc.

Problem solved.
The USB-bridge was not pushed in totally. Hence I assume there simply was no contact established.
The last bit of movement really requires to push the USB-bridge in firmly. Felt almost like a “click”. You will feel it.

Thanks for the help and hints so far! :+1: :slightly_smiling_face: