SATA Hat with Rock 5 A and Armbian

I installed Armbian_23.2.1_Rock-5a_bookworm_legacy_5.10.160 on Rock 5A running OpenMediaVault.
with the Sata HAT and Penta SATA as a NAS

Unfortunately i am not able to run any script from your side or to get the display on top working,
also i am not able to control the Top Fan.

Could you help me please?

You can enable shell access on omv and login there. Then just run installation script and double check output for errors. It adds new service that need few debs, python packages, libs as well as pwm on gpio and i2c. On releases there is something that brake dependencies, like new python release without needed libs already ported. Armbian and OMV is not actively tested by radxa, but probably You will manage to install needed things.

1 Like

thank you already for your reply and help.

i am very new to linux and stuff.
i connected to to the Rock with putty and i have bash installed.
is this what you mentioned?
i was trying to run the script already, its not doing anything and i dont see any error outputs.
how can i enable these?

i already installed all the python packages i found in the script with apt install and tried, but i had the same result

If You already inspected installation script then You should know that tested and supported distros was much older armbian and official radxa image. It should give You message about that and point for manual installation which is hard for unexperienced users because You will need to resolve several issues, dependencies, maybe compile something yourself.

I didn’t see any Pointing to an manual installation.
What would be the easiest way for me to get everything running like it’s supposed to run with open media vault?

i installed bullseye CLI now since it is the latest supported by Radxa,

the script now comes to this point

Using /usr/local/lib/python3.9/dist-packages/Adafruit_PureIO-1.1.5-py3.9.egg
Finished processing dependencies for Adafruit-SSD1306==1.6.2
dpkg-deb: error: ‘/tmp/tmp.Nrd8yKPu62’ is not a Debian format archive
dpkg: error processing archive /tmp/tmp.Nrd8yKPu62 (–install):
dpkg-deb --control subprocess returned error exit status 2
Errors were encountered while processing:
sed: can’t read /usr/bin/rockpi-penta/ No such file or directory
mv: cannot stat ‘/boot/dtbo/rk3588-pwm14-m1.dtbo.disabled’: No such file or directory
mv: cannot stat ‘/boot/dtbo/rk3588-i2c8-m2.dtbo.disabled’: No such file or directory
P: Checking for EXTLINUX directory… found.
P: Writing config for vmlinuz-5.10.110-35-rockchip…
P: Writing config for vmlinuz-5.10.110-12-rockchip…
Installation will take effect after reboot. Do you want to reboot now? [y/N]

Why is that? Any idea?

oh by the way, even when i say yes to reboot, its not working after. already tried that