SATA Hat does not boot after reboot


Having issue where after installing drives, getting them setup under OMV and setting up a share folder I rebooted, however it never came back on. The status lights don’t light up, and I cannot connect to the raspberry pi through SSH. It seems to have power because the lights on the Pi turn on and the fans spin, but otherwise cannot get power to the drives.

I did notice on mine, after I’d loaded a lot on the pi (Pihole, PiVPN, OMV and a bunch of plugins) it took an unusually long time to see the drives come to life.

I also noticed my unsupported setup invariably screwed up after a plugin install or an update. Doing something like what you’re saying.

Once I stopped doing anything unsupported, it became stable (and I never saw these booting issues again).

I’m not saying this is what you’re doing, just saying how I broke my own in such a way that I saw a similar issue.


Could you tell me the details of your operation?

Is your system entering an “emergency state”?
Do you have a unionfs file system?

No and yes. I havent tried running as a raid yet though.

such as? I have 4 x 2tb drives with a unionfs and snapraid.

Then probably you are having the same issue that I had.
Because the fstab can not mount the drives, it can not mount the unionfs and it enters in an emergency state (I think is called like that).
The solution is to do a clean install and before reboot edit the /etc/fstab file and add noauto, in the options section, to all lines between [openmediavault] to have something like :

/dev/disk/by-label/Disk1 /srv/dev-disk-by-label-Disk1 ext4 noauto,defaults,nofail,user_xattr,usrjquota=aquota.user,,jqfmt=vfsv0,acl 0 2`

Edit also the /etc/openmediavault/config.xml and add noauto in every <opts> tag, just in case omv rebuilds the fstab

After that, edit /etc/rc.local and add the mounts to your drives, something like

mount -o defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,,jqfmt=vfsv0,acl /dev/disk/by-label/Disk1 /srv/dev-disk-by-label-Disk1

and to your unionfs

mergerfs -o defaults,allow_other,cache.files=off,use_ino,category.create=mfs,minfreespace=15G,fsname=Stack:c0083937-7492-4afd-a975$d-a975-4516a61977d8 /srv/dev-disk-by-label-Disk1:/srv/dev-disk-by-label-Disk2:/srv/dev-disk-by-label-Disk3 /srv/c0083937-7492-4afd-a975-4516a61977d8

You can copy the names and the options from your fstab file

So I tried this and it didn’t seem to make a difference. Rebooted and I have the same problem.

Try to comment the lines between [openmediavault] in /etc/fstab by adding a # at the beginning of line.