Samba write delay


I’m running a RPI 4 8GB with the quad sata hat and 3 disks. I have tried this with ubuntu and raspberry pi os both but this issue remains. I have tried it with old 2.5" disks (salvaged from the family’s laptops), newish SSDs (around a year old) as well as brand new (purchased today) 2.5" hdds.

There seems to be a write delay on the pi. When I transfer files using rsync from my unraid machine the first file copies and then there is a delay before the second file. Time seems to vary between 5-10s or more depending on the size of the first file.

I’m not exactly sure why this is happening. It happens with the disks in raid as well as individual mounts. All my tests have the disks / raid array formatted as ext4. I’ve followed all instructions in the wiki for the setup. I’m assuming there is a buffer somewhere before the write but I can’t find it.

One thing I have noticed is that the blue lights for disk activity start blinking a while after the transfer begins and cut out for a bit in the middle randomly. I dont know if this is expected due to the low power cpu or something else but I’ve never observed this before and I can’t figure out how to fix it.

Please let me know if any additional details are required.