[ROM] ROCK 5B Android 12.1 rkr10 GoogleTV

from log I see this

[    2.695657] [WLAN_RFKILL]: wlan_platdata_parse_dt: wifi_chip_type = ap6255
[    2.695661] [WLAN_RFKILL]: wlan_platdata_parse_dt: enable wifi power control.

but my actual wifi is

03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:b852] Subsystem: Lenovo Device [17aa:4853]

it’s a RTL8852BE, which label as lenovo device, subsystem id as [17aa:4853]


yeah the wifi init is diffrent with pcie .

i will look at it ,if it is in normal rom it should work in v5 if i didnt overlooked something .

for v6 i pretty sire it dont work , i put a notice when i build one with a attempt to fix

AFAIK, ap6255 showed in dmesg is a broadcom model BCM43455
rtl8852 is a realtek module, with wifi 6 capability. same chip with radxa a8 wifi module, but different subsystem id

just wondering if this is working on debian? i was wondering if i could just purchase non radxa realtek rtl8852 module, just to save up some delivery cost.

on debian you can install driver manually,
try this HRex39/rtl8852be: Realtek Linux WLAN Driver for RTL8852BE (github.com)

flashed the v5 build
setup with ethernet worked a charm.

thanks for the build!

So does Radxa WiFi A8 work on V5 or V6?

And how about apps trying to use the native file manager - do they work? Redream for example - can you add a folder to the library?


Did you try ?

and did you read link i shared from m on discord ? so hope you also understand that your complaining over a feature what is by default not there !

And here a person who likes the same emus as you are complaining about .
i should ask him he already has it on a tablet version with rklauncher wich is called box in rockchip terms.

you should just askl the emu DEVELOPERS to make it compatible with androidtv or googletv wich dont have a native filemanager .

here someone already made the question

That’s my issue opened. Now it is closed, as not planned and they don’t like idea of emulation on GTV device. Weird …

dont know if they dont like their app running on a GTV . but i can understand it is not a emu issue on a CFW .

Has anyone tried hooking a touch screen to this? Or do I need to wait for a lineage os or something :slight_smile:

Google files cannot install in all your recent build

1 Like

What is CFW?

By the way, I’m getting a Kodi (20 beta) issue on v2 - when I enable the http Web server for remote control, the app starts to go to the background constantly (while it is still running) and if I restart it it starts to crash.
Need to disable the Web server and clear the cache for it to start working again. Has anyone had this problem on the Google tv android?

cfw means customized firmware, which differ from official ones;
all fw for rock5b should be categorized as cfw, since there is no official on that google approved.

for kodi, don’t use beta

Well, I just saw the most recent version (2 days ago) now is 20 rc1. I will test this and see whether it works better.

But I would be really surprised if it was a Kodi issue so this is why I am asking if it happened for anyone else on this android version. With any Kodi. The app being moved from foreground to the background seems like a system/launcher thing.

Can somebody provide information on how to install this via rkdeveloptool I don’t understand what I should do with update.img

update image you use with rkdevtool ,and for rkdevtool there are tons of videos and tutorials so please google it is easy enough .

@icognito itnis kodi beta whats on it so you could go back perhaps that helps.

Well i wonder if there is a certified rk35xx because that would have widevine l1 perhaps.

thc013 - you have h96 max v58 (mine is not delivered yet), what is widevine cerification level?

i dont have any h96 or r58 is just default box :sob:

did you look in the about ? since when is a h96 a redfin device :open_mouth: on original fw